locked
Getting error when I try to remove eum secondary email address from the Mailbox from Exchange 2013 server RRS feed

Answers

  • Now for an answer - your remote session doesn't have the same object you have on the server itself.  Notice it says this is an array list, not a ProxyAddressCollection.  If you need to work around this, you'll need to massage the addresses another way that the system will accept.  I'd try the following:

    $NewAddresses = $mailboxEmailAddresses | ? { $_ -notlike "eum:50004;phone-context=telExt5digits.lync5.com" }

    See what you get in the $NewAddresses variable when you do this.


    Friday, April 11, 2014 7:12 PM

All replies

  • Could you move this to one of the Exchange 2013 forums?  I'd suggest this one ...  http://social.technet.microsoft.com/Forums/en-US/home?forum=exchangesvrunifiedmessaging
    Friday, April 11, 2014 7:05 PM
  • Now for an answer - your remote session doesn't have the same object you have on the server itself.  Notice it says this is an array list, not a ProxyAddressCollection.  If you need to work around this, you'll need to massage the addresses another way that the system will accept.  I'd try the following:

    $NewAddresses = $mailboxEmailAddresses | ? { $_ -notlike "eum:50004;phone-context=telExt5digits.lync5.com" }

    See what you get in the $NewAddresses variable when you do this.


    Friday, April 11, 2014 7:12 PM
  • It worked. Thank you. I will make select the correct forum for next question

    Friday, April 11, 2014 8:51 PM
  • Was your response the answer?
    Monday, April 14, 2014 12:25 PM
  • Yes. It worked. Thanks!
    Monday, April 14, 2014 12:26 PM
  • So your response, where it says only "it worked", was the answer?  Or did the response above answer the question?
    Monday, April 14, 2014 12:53 PM
  • Using your suggested powershell command $NewAddresses = $mailbox.EmailAddresses | ? { $_ -notlike "eum:50004;phone-context=telExt5digits.lync5.com" }, I was able to remove the email address from the UM mailbox. Server did not produce the error.

    The question was anwered.

    Monday, April 14, 2014 12:56 PM
  • You need to mark the response that answered the question as the answer, not your response.  That way, when someone who has the same issue comes to read this thread, they will see the answer at the top of the thread, right under the question.
    Monday, April 14, 2014 1:02 PM
  • got it. Thanks!

    Monday, April 14, 2014 1:06 PM