locked
IE10 Compatibility View default behavior RRS feed

  • Question

  • The problem: IE10 seems to now default all web sites to "Internet Explorer 10 Compatibility View" browser mode.  

    This will in turn change the Documents mode to something other than "Standards" unless each web page has explicitly defined : <meta http-equiv="X-UA-Compatible">, and often screw up how things are rendered.  The user is able to change it manually via the f12 menu, but it reverts back the next time IE is opened.

    Also: the broken paper icon in the address bar is no longer displayed for any page, and "tools > compatibility view" is greyed out.

    It's this same way for any PC at my business, and regardless of what's in the compatibility view list.  And yes "display all websites in compatibility view" is not checked.

    Up until some point in the last year, it didn't work this way.  Before: it would default to "Internet Explorer" unless the web site was explicitly included in the compatibility view list.

    Can anyone still on IE10 recreate this?  Was there a windows update at some point in the recent past that has affected this behavior?  Or does this have to be something in my environment?

    Thanks,

    Jaime

    Thursday, March 17, 2016 2:25 PM

Answers

  • Hi,

    f12>Emulation tab, lists HOW the emulation mode/ documentMode was established (the blue text, directly under the documentMode dropDown).

    there is a compatibility view setting for "Use compatibility view for intranet sites".

    You can determine which IE security zone a domain is mapped to from the File>Properties menu in IE.


    Rob^_^

    Saturday, March 19, 2016 2:20 AM

All replies

  • does this have to be something in my environment?

    Probably.  What happens with IE11?  Use the Developer Tools to check.  It's Emulation tab and Console tab will give more explicit clues than IE10, although that does have analogous functionality in it.


    Robert Aldwinckle
    ---

    Thursday, March 17, 2016 7:51 PM
    Answerer
  • the "broken page" icon, was removed, at a point in time (yes it could have been when IE10 released, can't find the blog post about it just now)

    Are you using the "run intranet in compat view" setting? If so, have you recently re-zoned things in your network, or, implemented a changed/new proxy setup?


    Don [doesn't work for MSFT, and they're probably glad about that ;]

    Thursday, March 17, 2016 8:51 PM
  • Environmental for sure: this is only happening on certain PC's.

    I upgraded an affected PC to IE11 and the console throws a "The attached page targets document mode 5".

    So the mystery that remains: why would certain PC's target document mode 5, but others default to standards.  Exact same URL on both.

    Will let you know if I find any more useful info.

    Friday, March 18, 2016 1:04 PM
  • Hi,

    f12>Emulation tab, lists HOW the emulation mode/ documentMode was established (the blue text, directly under the documentMode dropDown).

    there is a compatibility view setting for "Use compatibility view for intranet sites".

    You can determine which IE security zone a domain is mapped to from the File>Properties menu in IE.


    Rob^_^

    Saturday, March 19, 2016 2:20 AM