locked
Exchange 2003 => 2010 Cross forest migration bulk user migration fails RRS feed

  • Question

  • Hi

    I'm testing bulk user migration from Windows 2003/Exchange 2003 forest to Windows 2008/Exchange 2010 forest.

    Everything works fine when migrating one user at time but mass migration fails. Thats the way i'm trying it:

     dsquery user "OU=xx,OU=xx,OU=xx,DC=xx,DC=local" -limit 200| dsget user -upn > c:\users.csv

    users.csv looks like this:

    Identity

    posti.siirto12@domain.local

    posti.siirto13@domain.local

    $LocalCredentials = Get-Credential

    $RemoteCredentials = Get-Credential

    Import-Csv users.csv | .\Prepare-MoveRequest.ps1  -RemoteForestDomainController dc.domain.local -RemoteForestCredential $RemoteCredentials -LocalForestDomainController dc.testi.local -LocalForestCredential $LocalCredentials  –targetmailuserou ”ou=xx,ou=users,ou=xx,dc=testi,dc=local”

    and error:

    Error looking up source MBX @{Identity = posti.siirto12@domain.local} in souce forest ...

    Credentials are ok because migrating one user works

    I have only few days left testing time, so if mass migration doesn't work without fail, i have to migrate one user at a time.

    ~ Jukka ~ 

     

    Saturday, October 15, 2011 8:36 AM

Answers

  •  

    Everything works fine when migrating one user at time but mass migration fails. Thats the way i'm trying it:

    dsquery user "OU=xx,OU=xx,OU=xx,DC=xx,DC=local" -limit 200| dsget user -upn > c:\users.csv

    users.csv looks like this:

    Identity

    posti.siirto12@domain.local

    posti.siirto13@domain.local


    Hi,
    Open users.csv in notepad and select all input and make sure you don't have any white spaces before or after every single row.

    Martina Miskovic - http://www.nic2012.com/
    • Marked as answer by Jackzhou_5 Monday, October 31, 2011 8:28 AM
    Sunday, October 16, 2011 9:38 AM
  • Hi Jukka,

     

    You can create a new distribution group for the existing groups using Exchange Management Console/Shell in Exchange 2010.

     

    Mail-Enable or Mail-Disable a Distribution Group

    http://technet.microsoft.com/en-us/library/aa997448.aspx

     

    Thanks,

     

    Evan

    • Marked as answer by JuMV Tuesday, October 18, 2011 10:24 AM
    Tuesday, October 18, 2011 7:26 AM
    Moderator

All replies

  • Inly have about 50 users, what is the syntax to do it one at a time?  .

     


    David Qualls
    Saturday, October 15, 2011 9:21 PM
  • Hi David

    scripts and syntaxes migrating user1@domain.local:

    $LocalCredentials = Get-Credential (target forest credential domain\username  passwd)

    $RemoteCredentials = Get-Credential (source forest credential)

    .\ Prepare-MoveRequest.ps1 -Identity user1@domain.local dc.source.local -RemoteForestCredential $RemoteCredentials -LocalForestDomainController dc.target.local -LocalForestCredential $LocalCredentials –targetmailuserou ”ou=xx,ou=users,ou=xx,dc=target,dc=local” -RemoteForestDomainController

    $cred = Get-Credential (source forest credential)

    New-MoveRequest –identity user1 –RemoteLegacy –targetdatabase ”databasename” –Remoteglobalcatalog ’dc.source.local’ –remotecredential $cred –targetdeliverydomain ’target.local’

    Get-moverequest

    Get-MoveRequest -MoveStatus Completed

    After migration users could not receive emails. Thats because users Targetaddress -attribute must be clear and in my my situation it was not. Clear attribute using following script in target forest domain controller Active directory Module forWindows PowerShell

      Get-Aduser -Filter {targetAddress -notlike "$null"} -properties targetAddress | set-aduser -Clear targetAddress

    ~ Jukka ~

     

    Documentation is quite unclear, but syntaxes above works ok in my situation.

     

    Sunday, October 16, 2011 8:38 AM
  •  

    Everything works fine when migrating one user at time but mass migration fails. Thats the way i'm trying it:

    dsquery user "OU=xx,OU=xx,OU=xx,DC=xx,DC=local" -limit 200| dsget user -upn > c:\users.csv

    users.csv looks like this:

    Identity

    posti.siirto12@domain.local

    posti.siirto13@domain.local


    Hi,
    Open users.csv in notepad and select all input and make sure you don't have any white spaces before or after every single row.

    Martina Miskovic - http://www.nic2012.com/
    • Marked as answer by Jackzhou_5 Monday, October 31, 2011 8:28 AM
    Sunday, October 16, 2011 9:38 AM
  • UPS.. Editor did not like copy-paste

    Prepare-moverequest again migrating user1@source.local

    .\Prepare-MoveRequest.ps1 -Identity user1@source.local -RemoteForestDomainController dc.source.local -RemoteForestCredential $RemoteCredentials -LocalForestDomainController dc.target.local -LocalForestCredential $LocalCredentials  –targetmailuserou ”ou=xx,ou=users,ou=xx,dc=target,dc=local”

    ~ Jukka ~

     

    Sunday, October 16, 2011 10:22 AM
  • White spaces after was the reason

    Thanks

    ~ Jukka ~

    Sunday, October 16, 2011 10:24 AM
  • I have been there myself before so I always check csv-files in notepad nowadays :)

    So, is everything working for you now?


    Martina Miskovic - http://www.nic2012.com/
    Sunday, October 16, 2011 10:32 AM
  • Look's quite good now. Maybe I can sell off my ticket to South America :)

    ~ Jukka ~  

    Sunday, October 16, 2011 3:35 PM
  • Still one question :)

    We have global security groups in our AD which are also email Distribution groups. After migrating those groups there is no email addresses any more. Primary email address of those groups is clear in Exchange 2010 Management Console.

    Should I just re-create addresses or is there some other way?

    ~ Jukka ~

    Monday, October 17, 2011 10:24 AM
  • Hi Jukka,

     

    You can create a new distribution group for the existing groups using Exchange Management Console/Shell in Exchange 2010.

     

    Mail-Enable or Mail-Disable a Distribution Group

    http://technet.microsoft.com/en-us/library/aa997448.aspx

     

    Thanks,

     

    Evan

    • Marked as answer by JuMV Tuesday, October 18, 2011 10:24 AM
    Tuesday, October 18, 2011 7:26 AM
    Moderator