locked
ie8 on windows 7 "connecting..." RRS feed

  • Question

  • When opening a desktop shortcut to a website on my Windows 7 PC running IE8, Internet Explorer opens as expected, but stays at "Connecting..." without going any farther.  If I copy/paste the URL into the address box, it works like a champ.

    At the company I work for as an IS engineer, I've had three computers with Windows 7 and all three have had the exact same problem occur.   I've reset everything to default, cleared the cache, and run without add-ons, but the links never come up.   I tried Firefox and it worked as expected, but we have SharePoint, so IE is pretty much required.

    I downloaded and installed Fiddler so I could capture my HTTP traffic within a log.   Every TCP port 80 connection appears immediately when I'm logging my sessions, whether those connections are from IE, Firefox, Outlook, or any other app.   When I double-click my desktop shortcut, IE opens, but there are NO HTTP requests logged within the log.   This indicates that there is some bug in IE8 that is keeping this from actually attempting any connection whatsoever.

    Does anyone have a solution for this?   I've seen it posted on a ton of forums, with the same basic answers that I've tried.   Within the next year, I intend to roll out about 300 Windows 7 desktops, but I simply cannot without this being fixed.

    Thanks!

    Thursday, August 5, 2010 3:56 PM

Answers

  • This issue occurs if IE is not the default browser. Firefox will automatically change your default browser settings. I suggest you manually set IE to be the default browser. Then please confirm if the issue still occurs. If it does not work, I suggest you temporary remove Firefox as a test. Please check if the issue occurs after removing Firefox.

    If the issue persists after you remove Firefox, I suggest you reset IE settings.

    1. Click Start, please type “inetcpl.cpl” (without quotation marks) in the Start Search bar and press Enter to open the Internet options window.
    2. Switch to the Advanced tab.
    3. Click the "Reset Internet Explorer Settings" button.
    4. Click Reset to confirm the operation.
    5. Click Close when the resetting process has finished.
    6. Uncheck the "Enable third-party browser extensions" option in the Settings box.
    7. Click Apply, click OK.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by Arthur Xie Friday, August 20, 2010 9:50 AM
    Monday, August 9, 2010 6:53 AM
  • The issue may be related to Google Chrome.

    Desktop shortcuts, hyperlinks (in Outlook, etc) not working after uninstalling Google Chrome

    Important Note: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by Arthur Xie Friday, August 20, 2010 9:50 AM
    Friday, August 20, 2010 9:50 AM

All replies

  • This issue occurs if IE is not the default browser. Firefox will automatically change your default browser settings. I suggest you manually set IE to be the default browser. Then please confirm if the issue still occurs. If it does not work, I suggest you temporary remove Firefox as a test. Please check if the issue occurs after removing Firefox.

    If the issue persists after you remove Firefox, I suggest you reset IE settings.

    1. Click Start, please type “inetcpl.cpl” (without quotation marks) in the Start Search bar and press Enter to open the Internet options window.
    2. Switch to the Advanced tab.
    3. Click the "Reset Internet Explorer Settings" button.
    4. Click Reset to confirm the operation.
    5. Click Close when the resetting process has finished.
    6. Uncheck the "Enable third-party browser extensions" option in the Settings box.
    7. Click Apply, click OK.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by Arthur Xie Friday, August 20, 2010 9:50 AM
    Monday, August 9, 2010 6:53 AM
  • No luck.   I've disabled all add-ins, removed Google Chrome (my mistake, Firefox was once on the computer) and verified that IE is the default browser.   What's annoying is that IE DOES open, it just never gets to the page I have the shortcut to.

    Any other ideas?  Remember, this is happening on at least one other computer in my department, so this cannot be simply something wrong with mine.

    Tuesday, August 10, 2010 5:10 PM
  • Please try to temporary disable the antivirus and firewall for test as they may block the connection.

    Have you tried the reset IE steps? Additionally, does the issue occur with Safe Mode with Networking?


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Wednesday, August 11, 2010 3:07 AM
  • I completely uninstalled our av and firewall and the browser still never connects.   I also have done the IE reset to no avail.
    Wednesday, August 11, 2010 12:00 PM
  • The issue may be related to Google Chrome.

    Desktop shortcuts, hyperlinks (in Outlook, etc) not working after uninstalling Google Chrome

    Important Note: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by Arthur Xie Friday, August 20, 2010 9:50 AM
    Friday, August 20, 2010 9:50 AM
  • We have this same issue.  I haven't come up with a solution but have found a work around.  If you run default programs (type def in search and choose default programs), then choose Associate File Types.  Choose .url and change it to open with the iexplore.exe executable.  Go into IE and tell it not to check if it is the default browser.  This will allow your url shortcuts to work.  I am still trying to figure out the root cause since changing this on every win 7 machine we roll out for each user (we have multiple users of machines) will become old really quick.
    Tuesday, August 31, 2010 5:20 PM