none
"Open File - Security Warning" After Windows 7 deployment RRS feed

  • Question

  • Hi,

    I am using MDT 2012 to deploy a vanilla installation of Windows 7 to a client PC, after
    which applications begin to install. This works very well with one hiccup:

    After Windows 7 is deployed I receive 3 warnings, one after another saying "Open
    File - Security Warning". This is only the graphics card software system tray
    icon wanting to load, nothing suspicious. But the Deployment task sequence does
    not resume until these 3 prompts have been acknowledged which is really
    annoying.

    Is there any way I can suppress these (at this stage, the PC is not joined to the domain, so GP is not an option)?

    Thanks

    Matt


    Matt Courtman, Network Manager, Cromwell Community College, UK


    • Edited by mcourtman Wednesday, October 2, 2013 8:43 AM
    Wednesday, October 2, 2013 8:40 AM

Answers

All replies

  • Hi Matt,

    I too ran across this problem, here is the confirmed solution:

    You can comment out the line in the driver INF that places they registry keys in
    start up. I do this with drivers I import into
    WDS to keep the crap out of the
    systray. Here is a snippet of an Intel graphics INF detailing the section.

    Code:

    ; igfxtray.exe execution on
    startup

    ;

    HKLM,Software\Microsoft\Windows\CurrentVersion\Run,IgfxTray,,%11%"\igfxtray.exe"

    HKLM,Software\Microsoft\Windows\CurrentVersion\Run,HotKeysCmds,,%11%"\hkcmd.exe"

    HKLM,Software\Microsoft\Windows\CurrentVersion\Run,Persistence,,%11%"\igfxpers.exe"

    Comment these out in the INF, and you should be all set.


    Wednesday, October 2, 2013 2:43 PM
  • Matt,

    When I receive these, I normally use MS's stream utility to wipe the DATA stream on the file to clear that it was downloaded off the net.  Its a free util and supports recursing a directory tree.

    http://technet.microsoft.com/en-us/sysinternals/bb897440.aspx


    -BrianG (http://supportishere.com)

    • Marked as answer by mcourtman Thursday, October 10, 2013 12:29 PM
    Wednesday, October 2, 2013 3:03 PM
  • Hi,

    Thanks for your suggestion. I commented out the three lines as you suggested and saved the inf file. I then did a deploy and the warning did not appear, however the Graphics driver was not installed.

    Did I do something wrong? I put a semi-colon followed by a space in front of each of the three lines?

    Thanks

    Matt


    Matt Courtman, Network Manager, Cromwell Community College, UK

    Thursday, October 3, 2013 7:42 AM
  • Correct, the semi-colon is used to comment out the lines.  I would look at the bdd.log file to see if the driver was detected. 

    If it was installing it before and it isn't now, there might be something else going on.  Commenting out those three lines should not impede the driver deployment.  They are simply registry entries to run the Intel tools at startup.

    I typically include the driver in the drivers area for winpe support, but install it via setup.exe as an application during the task sequence based on make/model.

    Thursday, October 3, 2013 6:04 PM
  • Hi Brian,

    I found a few spare moments this morning and read-up on Streams; very interesting stuff and I'm pleased to say that setting ZoneID=1 on the driver package has surpressed the warnings and now it's working like a charm.

    Many thanks for your help!

    Best wishes, Matt


    Matt Courtman, Network Manager, Cromwell Community College, UK

    Thursday, October 10, 2013 12:33 PM