locked
Image not accessible when deploying registered ML model RRS feed

  • Question

  • When I tried to deploy a registered ML model using the azureml.core.model.Model 's deploy function, the following error happens:

    {

    "code": "InaccessibleImage", "statusCode": 400, "message": "ACI Service request failed. Reason: The image 'dairydemocde6423a.azurecr.io/azureml/azureml_e6a87c7987b7026b6319d577537e7529' in container group 'estruslocal' is not accessible. Please check the image and registry credential.." }

    From my understanding, the "dairydemocd62..." image is an image automatically generated during the deploy operation, but for some reason the service was not able to access an image it created by itself...

    Interestingly, this same code actually worked a couple weeks, but after our credit expired and our professor reactivated our account two days ago, this error starts showing up. 

    Wondering if it's caused by some back-end error and would appreciate any insight!

    Wednesday, May 6, 2020 12:23 AM

All replies

  • Hello,

    This is most likely an issue with the containers credentials that might have changed. Could you please check cross check your configuration to ensure the right credentials of this container are used to deploy the image?

    -Rohit

    Wednesday, May 6, 2020 12:43 PM
  • Hello,

    Did you get a chance to review the above suggestion and check with correct credentials?

    -Rohit

    Thursday, May 14, 2020 12:15 PM