windows media player choppy at end of songs RRS feed

  • Question

  • I did some searching and didn't find much on this problem.  I recently installed Vista Ultimate and when I'm playing my music in WMP every song gets choppy for about 5 seconds or so at the end of every song. Also, when I manually click to play another song it takes 15-20 seconds to switch to that song, saying "media changing". I see no reason at all for it to be doing this, Vista is running plenty quick and smooth everywhere else.  Here is one thing I tried.  Right click the speaker icon in the tray next to the clock, playback devices, click on speakers/headphones, properties, enhancements, disable all enhancements.  The only problem with that is then I can't use my Creative SoundBlaster HD audio software and am limited to the graphic equalizer in WMP.  I would prefer not to have to do this.  Any help with this problem is appreciated.

    Here is what my computer setup is.

    Dell Inspiron E1505
    Intel Core Duo T2400 1.83GHz (667 MHz FSB)
    Crucial 2GB 667MHz dual-channel RAM
    ATI Mobility Radeon X1400 256MB
    60GB 7200rpm SATA HD
    Wednesday, August 22, 2007 9:36 PM

All replies


    I'm getting similar symptoms -- choppiness at the end of MP3's.

    I don't have a long delay between MP3's, though.

    WMP11, Dell XPS710, Vista Ultimate.


    Friday, August 24, 2007 2:46 AM
  • anyone know another way to fix this or do we just have to wait for sigmatel to come out with a new driver?


    Wednesday, August 29, 2007 12:43 AM
  • I have the exact same problem, and I can't find a single solution. I am also using a Dell Inspiron 9400 (don't know what the US equivalent is) with a SigmaTel sound card and Vista Premium. Really annoying, because I can't play any mp3s. I used iTunes and it was fine, but it ended up causing more problems when I updated it (windows explorer sometimes crahes). I am probably going to contact Dell or Microsoft soon, if I get a solution, i will try to post it here!



    Wednesday, October 24, 2007 8:30 AM
  • I had the same problem and I ran into the follwing post on Nicolas blog. His solution really works and puts the speed back on the audio playback.

    'It’s the audio enhancements I blogged about before. Poopie. If the “Disable all enhancements” checkbox is not checked, my media players will be slow in starting any song. Check that box, and bam, back to normal"


    I.e in the Speaker Properties click the Enhancements tab and check the box that says "Disable all enhancements".

    That's the trick right after you do that you will see the songs change in a flash, no more delays.


    Good luck!



    • Proposed as answer by Vejay S Thursday, May 14, 2009 6:51 PM
    Wednesday, October 31, 2007 8:23 PM
  • Right, but the problem with that is, then you are forced to use only WMP's equalizer and if you have any audio enhancement software like I do (see original post) it won't let you use this.  So it's either crappy sound and fast switching, or good sound and choppyness at end of songs.
    Thursday, November 8, 2007 3:54 AM
  • Make sure you dont just have SRS wow effects turned on in WMP, otherwise this requires an updated sound driver to be able to use enhancements. i dont have a creative card but with sigmatel the updated drivers have been on different manufacturers websites for a few months now. if you have a sony, dell, toshiba etc goto the drivers page for your model on there site to download the new driver. if the problems still there with the newest drivers and disabling system enhancements doesnt fix it seems to be codecs
    Saturday, November 10, 2007 11:28 AM
  • Yeah, I don't ever use the SRS wow effects.  I don't actually have a Creative sound card, I have a Sigmatel card and Creative HD audio software.  And the driver for the Sigmatel card for Vista on Dell's website hasn't been updated since January.  Very lame, they need to update this driver now.
    Saturday, November 10, 2007 9:39 PM
  • Bump.
    Wednesday, November 14, 2007 3:15 PM
  • Anyone know if Dell or anybody is ever going to fix this?  I haven't been searching for fixes for this or anything lately so if there is some kind of fix out there now please let me know.  Thanks.
    Sunday, January 27, 2008 8:33 PM