none
Null-values do not flow when using declarative fim-expression RRS feed

  • Question

  • Hi

    I used the following FIM declarative expression in an outbound-sync-Rule to flow mobile-Number to AD:

    IIF(Eq(EmployeeType,"contractor"),homeMobilePhone,mobilePhone)

    I selected "Allow null value to flow to destination"

    The if homeMobilePhone or mobilePhone is present, the Attribute flows as expected. But when homeMobilePhone or mobilePhone is not present FIM doesn't flow a null value to AD and therfore the attribute is not deleted.

    Of course it's possible to handle this using an AD Management Agent extension - but I'd like handle such easy logic declarative.

    best regards & thanks for any advice

    Pirmin

    Friday, March 22, 2013 12:38 PM

All replies

  • Pirmin-

    What build of FIM are you on? I have a recollection of a bug being fixed that sounds similar to this.


    My Book - Active Directory, 4th Edition
    My Blog - www.briandesmond.com

    Friday, March 22, 2013 4:18 PM
    Moderator
  • Hi Brian

    Ah a bug - that would explain a lot.
    I use FIM 2010 R2 or more accurate Build 4.1.2273.0

    Best regards

    Monday, March 25, 2013 7:21 AM
  • Hi Brian

    Since at the moment FIM is not very critical, I just updated to current Build 4.1.3419.0. After a brief test it looks like the bug hsa gone away...
    I'll give you feedback after a real test - but that may take some days.

    best regards

    Pirmin

    Monday, March 25, 2013 8:38 AM