locked
Skype4Business Skype Directory Search RRS feed

  • Question

  • Dear community,

    we got a skype 4 business infrastructure (updated from Lync 2013 SE) with a s4b Standard Server and a s4b edge Server in the DMZ. we want to use the skype Directory search, but there is no option to select a skype Directory search query on the clientside.

    Should I change some policys to enable skype directory search or are some other settings faulty?

    Kind regards,

    Freddie

    Friday, May 8, 2015 1:33 PM

Answers

  • Hi,

    EnableSkypeIdRouting and EnableSkypeDirectorySearch attributes need to be set to true in the public provider settings (see later instructions) for Search to work. So please make sure you have set them to true.

    Also, make sure Skype for Business client update to the latest version.

    Best Regards,
    Eason Huang


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Eason Huang
    TechNet Community Support

    • Proposed as answer by Eason Huang Monday, May 25, 2015 6:55 AM
    • Marked as answer by Eason Huang Monday, May 25, 2015 8:03 AM
    Thursday, May 21, 2015 9:22 AM

All replies

  • First you have to go through the pic provisioning

    https://pic.lync.com/provision/Logon/Logon.aspx?rret=https%3a%2f%2fpic.lync.com%2fprovision%2fAgreementNumber.aspx

    Than you have to configure the skype search on your S4B server.

    https://technet.microsoft.com/en-us/library/dn705313.aspx


    regards Holger Technical Specialist UC

    Saturday, May 9, 2015 10:28 AM
  • Hi Holger,

    many thanks for your feedback. I got successfully provisioned the lcs request, enabled the Skype-Skype federation in the topology builder (incl. published the topology) and recreated the sip federated Provider....

    Unfortunately I cannot search in skype Directory. If I search for contacts in skype4business Client there are only  the fields 'contacts' and 'chatrooms' existent - no skype Directory.

    Am I missing something or could i analyse some logs for further Details?

    regards
    Freddie

    Wednesday, May 13, 2015 9:09 AM
  • Hi,

    EnableSkypeIdRouting and EnableSkypeDirectorySearch attributes need to be set to true in the public provider settings (see later instructions) for Search to work. So please make sure you have set them to true.

    Also, make sure Skype for Business client update to the latest version.

    Best Regards,
    Eason Huang


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Eason Huang
    TechNet Community Support

    • Proposed as answer by Eason Huang Monday, May 25, 2015 6:55 AM
    • Marked as answer by Eason Huang Monday, May 25, 2015 8:03 AM
    Thursday, May 21, 2015 9:22 AM