locked
Word 2010 Macros won't run after installing Outlook 2013 RRS feed

  • Question

  • Here is something I've never run across before.  I'm hoping someone here knows the answer...

    One of my co-workers has Office 2010 Professional installed and has for a year or more been running Word 2010 using a macro that opens a form for additional user input for the document.

    For some reason that I cannot understand at all, he loaded Outlook 2013 and Lync.  After doing this, his Word document will open but he cannot get the macro to execute the command button in the document.  The macro does not fire, so to speak.  We have checked the Trust Center and the macro settings are at the lowest level.  Still not working!

    I have tried to simulate this by installing Word 2010 on my workstation where I have a full copy of Office 2013 Professional installed.  Interestingly enough, similar results occur.  I get a security warning that even though my Word 2010 instance has macro security set to low, strips out the macro altogether. 

    I'm not all that interested in finding my problem but would like to get some advice on why he is having the problems after just adding Outlook 2013 and Lync.  They may be related .

    Thanks for any assistance.


    Robert Stroud

    Wednesday, April 15, 2015 1:47 PM

Answers

All replies

  • Try repairing the Office 2010 installation.

    Doug Robbins - Word MVP dkr[atsymbol]mvps[dot]org

    Friday, April 17, 2015 8:52 AM
  • Repair did not seem to have any affect on the problem.

    So a bit of clarification - client has 2010 Office Professional including all of the normal packages.  His company updated their machines to Outlook 2013 but did not touch any of the other 2010 packages except Outlook.  They also added Lync. 

    I can duplicate the problem using a 2013 installation of Office Professional and then adding Word 2010 via another installation of Office 2010.  Word 2010 was the only package from 2010 that I installed.

    I have repaired the 2010 installation from the Control Panel.  The Repair Utility does not seem to do anything except force the default .docm to show the Word 2010 icon rather than the 2013 icon.

    If I open my .docm file with Word 2010, I get macro warnings even though the Macro Security is set to enable all macros.

    If I open my .docm in Word 2013, the file executes properly and the macro runs as it should.

    What is it that happens when one or more 2013 packages are installed that breaks the 2010 package macros?


    Robert Stroud

    Monday, April 20, 2015 10:19 PM
  • Is the location of the *.docm a Trusted Location for Office 2010?


    Stefan Blom, Microsoft Word MVP

    Tuesday, April 21, 2015 8:29 AM