none
ADMX Template Backward Compatibility?

    Question

  • How do you determine what the existing version ADMX template is already installed on a domain controller?

    What is the newest version ADMX templates that are compatible with a Server 2008 domain controller and is there different version for Server 2012 domain controllers?

    Wednesday, February 8, 2017 6:37 AM

Answers

  • Hi,
    As a far as I know, ADMX template files are down-version-compatible, so the ADMX template of higher version than window server 2008 will be compatible.
    And you could compare the difference by downloading the ADMX template files for windows server 2008/2012:
    https://www.microsoft.com/en-sg/download/details.aspx?id=14355
    https://www.microsoft.com/en-sg/download/details.aspx?id=41193
    Best regards,
    Wendy

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    • Marked as answer by MyGposts Monday, February 13, 2017 5:02 AM
    Thursday, February 9, 2017 3:29 AM
    Moderator
  • > What is the newest version ADMX templates that are compatible with a Server 2008 domain controller and is there different version for Server 2012 domain controllers?
     
    In 2008R2 and Win7, MS introduced the capability to write REG_MULTI_SZ in ADMX templates. So if you deploy ADMX templates for W7 to a 2008 (non R2) computer, it will throw a handful of error messages because 2008 does not understand REG_MULTI_SZ...
     
    • Marked as answer by MyGposts Monday, February 13, 2017 5:02 AM
    Thursday, February 9, 2017 10:41 AM

All replies

  • Hi,
    As a far as I know, ADMX template files are down-version-compatible, so the ADMX template of higher version than window server 2008 will be compatible.
    And you could compare the difference by downloading the ADMX template files for windows server 2008/2012:
    https://www.microsoft.com/en-sg/download/details.aspx?id=14355
    https://www.microsoft.com/en-sg/download/details.aspx?id=41193
    Best regards,
    Wendy

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    • Marked as answer by MyGposts Monday, February 13, 2017 5:02 AM
    Thursday, February 9, 2017 3:29 AM
    Moderator
  • > What is the newest version ADMX templates that are compatible with a Server 2008 domain controller and is there different version for Server 2012 domain controllers?
     
    In 2008R2 and Win7, MS introduced the capability to write REG_MULTI_SZ in ADMX templates. So if you deploy ADMX templates for W7 to a 2008 (non R2) computer, it will throw a handful of error messages because 2008 does not understand REG_MULTI_SZ...
     
    • Marked as answer by MyGposts Monday, February 13, 2017 5:02 AM
    Thursday, February 9, 2017 10:41 AM