locked
Operations Manager failed to run a WMI query - Object enumeration failed RRS feed

  • Question

  • I'm wading through some alerts that have me puzzled. Several of our Windows 2008 servers are getting alerts like the one below. The same classes too. I can't seem to find the classes on the system when I browse wbemtest so I'm guessing that SCOM is just confirming what I've found. Has anyone dealt with this before?

    Alert: Operations Manager failed to run a WMI query

    Source: Myserver.mydomain.com

    Path: Myserver.mydomain.com

    Last modified by: System

    Last modified time: 11/6/2013 8:55:03 AM Alert description: Object enumeration failed

    Query: 'SELECT PropertyNumValue FROM SQLServiceAdvancedProperty WHERE ServiceName = 'MSSQLSERVER' AND PropertyName = 'SPLEVEL''

    HRESULT: 0x80041010

    Details: Invalid class

    One or more workflows were affected by this.

    Workflow name: Microsoft.SQLServer.2005.DBEngine.Configuration.ServicePackLevel

    Instance name: MSSQLSERVER

    Instance ID: {28B8E9DC-C0A5-AB5E-68E7-C8AABC113891}

    Management group: MYSCOMSERVER


    Orange County District Attorney

    Wednesday, November 6, 2013 7:26 PM

Answers

  • Hi,

    Based on my research, this issue may occur if Namespace was missing from the WMI Repository in SQL.

    If so, please try to run this command:

    mofcomp "c:\program files (x86)\microsoft sql server\100\Shared\sqlmgmproviderxpsp2up.mof"

    Then, run the WBEMTest again and the namespace should be returned successfully. The databases will successfully discovered after restarting the health service on agent.

    Thanks.


    Niki Han
    TechNet Community Support

    • Marked as answer by Niki Han Wednesday, November 20, 2013 6:40 AM
    Sunday, November 10, 2013 6:34 PM

All replies

  • Hi,

    Based on my research, this issue may occur if Namespace was missing from the WMI Repository in SQL.

    If so, please try to run this command:

    mofcomp "c:\program files (x86)\microsoft sql server\100\Shared\sqlmgmproviderxpsp2up.mof"

    Then, run the WBEMTest again and the namespace should be returned successfully. The databases will successfully discovered after restarting the health service on agent.

    Thanks.


    Niki Han
    TechNet Community Support

    • Marked as answer by Niki Han Wednesday, November 20, 2013 6:40 AM
    Sunday, November 10, 2013 6:34 PM
  • Thanks for the note back Niki. I'll try that and see if it fixes it.

    Orange County District Attorney

    Thursday, November 14, 2013 4:53 PM