Infopath form open triggers Access denied on web service call...but works in preview mode?


  • I really don't understand what's going on. I've created an Infopath form that talks to a web service for its information. When I am in design mode and preview the form it works like a charm.

    But when I open it normally I get the message: "InfoPath cannot create a new, blank form. InfoPath cannot open the form. To fix this problem, contact your system administrator."

    Show Details revelas:

    "Form template: ------.xsn
    The following DataObject either cannot be created or cannot be initialized: Users
    The query cannot be run for the following DataObject: Users
    InfoPath cannot run the specified query.
    Access is denied."

    Any idea why this might be??
    Wednesday, November 19, 2008 6:54 PM

All replies

  • try giving the Full trust to form. Tools->form options->Security and trust..
    Friday, February 27, 2009 5:38 AM
  • If setting Full Trust on the form doesn't work, you could be running into the issue described here:
    (Many reports I've seen attribute the onset of the problem to ".NET Framework 3.5 SP1" being installed.)

    Jason Barron
    • Proposed as answer by Jason Barron Tuesday, June 09, 2009 1:28 AM
    • Unproposed as answer by Mike Walsh FIN Saturday, April 24, 2010 5:28 AM
    Saturday, February 28, 2009 8:16 PM
  • Confirm the problem. 3.5 SP1 installed. Same behaviour: Fine in edit mode, access denied at runtime. BTW: There is no real HTTP request leaving the machine.
    Wednesday, March 11, 2009 8:14 PM
  • One of our users was getting this error when opening an InfoPath form from a SharePoint site.   He had some of our web servers listed in his IE trusted sites, as soon as we removed them the infopath form opened but he was prompted with a warning which he was able to click through and access the form.   We also checked the 3 "Include all...." check boxes for the Local Intranet zone sites.

    Also make sure Allow Data Access Across Domains is enabled for the Intranet/Trusted Sites zones.  He had it set to prompt which may have been the real problem.

    Friday, April 23, 2010 7:41 PM
  • None of the IE tweaks made a difference in our environment. What did make a difference was going to the SP server, opening the Forms Library and clicking New Document. InfoPath immediately worked fine. The browser that fails is on a machine in a different domain than the browser that worked. Specifically, the failing browser is on a host O/S (WS2K8R2) on a corporate domain and the SP 2010 server is on a Private network VM for Dev/testing purposes (along with a DC VM as well).

    It's a Trust issue, I agree; but, I don't think it's in the browser...

    Monday, November 07, 2011 5:22 AM
  • Have you checked the security settings of the InfoPath form?  In InfoPath go to Tools --> Form Options --> Security and Trust.   The form may need full trust (which requires it to be digitally signed with a certificate).

    Phil Shisbey
    Monday, November 07, 2011 2:34 PM
  • For InfoPath 2010, setting Full Trust worked for me:

    File >> Advanced form options >>Security and Trust >> Full Trust.  Its not the "option" from left column,  "Advanced form options" on middle column.


    Monday, March 05, 2012 4:02 AM