none
Users reporting poor performance RRS feed

  • Question

  • I am trying to diagnose an issue logged to do with slow access to a customers Exchange 2010 server.  Exchange BPA and Performance don't show anything obvious but it does mention that 6 users are responsible for 60% of the MAPI CPU load.  To investigate this I downloaded ExMon but when I run it I get...

    ---------------------------
    Error
    ---------------------------
    Exchange is not running on this machine!
    To view an ETL file, pass the filename as a command line argument
    ---------------------------
    OK  
    ---------------------------

    The site does mention Exchange 2010 is supported but there is no mention that Windows 2008 R2 is supported.  Any ideas?

    Monday, April 18, 2011 1:05 PM

Answers

  • I have some update here !

    Its true that ExMon can not run on Windows 2008 R2, you can run it over Windows 2000 Server;Windows Server 2003;Windows Server 2008. When you run it over 2003 (Exchange should be installed) then i also got same error "To view an ETL file, pass the filename as a command line argument". To reolve this i ran Exmon file by right click and run as administrator and its fine now.

     


    Anil
    Tuesday, April 19, 2011 10:32 AM

All replies

  • Also if anyone can help answer the following...

    Log Name:      Application
    Source:        ESE
    Date:          18/04/2011 12:57:31
    Event ID:      906
    Task Category: Performance
    Level:         Warning
    Keywords:      Classic
    User:          N/A
    Computer:      SERVER
    Description:
    Information Store (10212) A significant portion of the database buffer cache has been written out to the system paging file.  This may result in severe performance degradation.
    See help link for complete details of possible causes.
    Resident cache has fallen by 17522 buffers (or 13%) in the last 4015 seconds.
    Current Total Percent Resident: 69% (116964 of 168161 buffers)

    I also need to know if a server is significantly slower than a server than the active server in a DAG will it slow down also the active server?  The active server has two databases which are both active, these are seeded onto a second server.  The secondary server is running with at least 1/4 less resources than the primary active server.  The copy queue length shows no issues.

    Monday, April 18, 2011 2:36 PM
  • Hi
       1. No official document tells that Exmon supports windows 2008 R2 . Someone try to modify registry and I never do test for it.
       2. Event 906 only shows the servers lack of memory. As you know, it is not valuable clue to determine your thread.
       3. I haven’t met similar situation. So I can’t offer any suggestion.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, April 19, 2011 3:54 AM
    Moderator
  • I have some update here !

    Its true that ExMon can not run on Windows 2008 R2, you can run it over Windows 2000 Server;Windows Server 2003;Windows Server 2008. When you run it over 2003 (Exchange should be installed) then i also got same error "To view an ETL file, pass the filename as a command line argument". To reolve this i ran Exmon file by right click and run as administrator and its fine now.

     


    Anil
    Tuesday, April 19, 2011 10:32 AM
  • Great stuff.  I can confirm this works also.
    Tuesday, April 19, 2011 11:40 AM
  • You can too run this on Server 2008 R2. I just did. I did the run as administrator and sure enough it ran.
    Thursday, August 4, 2011 4:21 PM