none
Unable to create project based on sample proposal. RRS feed

  • Question

  • Hi Folks,

    I have a small issue where I cannot create a new project based on the default sample proposal project (using project server 2010).  Initially it was because there was no workflow but after removing and re-creating the 'Sample Proposal Workflow' I am getting a callback error  (callback.96|/wEWCAK......).  From memory this is because there is no project detail page associated.  

    When I try and open the proposal project I am getting the error: "Unable to open project, no valid Project Detail Page could be found for the project'.

    Does anyone have any information on how to reset (or create) the default project detail page(s) for the sample proposal site?    I am able to create basic sites just fine.

    Regards

    Andy



    • Edited by AndyW2007 Sunday, October 28, 2012 8:35 PM
    Sunday, October 28, 2012 8:20 PM

Answers

  • In the end I resolved it by creating a new development VM and doing a new SharePoint installation, then a clean install of Project Server.  There were no issues during installation this time, and everything appears to be working. 


    • Edited by AndyW2007 Tuesday, November 20, 2012 10:33 PM
    • Marked as answer by AndyW2007 Tuesday, November 20, 2012 10:33 PM
    Tuesday, November 20, 2012 10:32 PM

All replies

  • HI,

    Go to Server settings --> go to Enterprise Project Types, click on the project type and check if you have added the project details page at section "New Project Page/Project Detail Pages". 

    Monday, October 29, 2012 3:07 AM
  • Hi,

    It had 'Project Information' as the setting, I changed it to project details to see if it made a difference but still getting the error.  

    The ULS Log just has a single entry  PSI: Invalid PDP encountered.  This is followed by an id.


    • Edited by AndyW2007 Monday, October 29, 2012 7:09 PM
    Monday, October 29, 2012 6:58 PM
  • Hello AndyW2007,

    Did you delete any PDP? Check in Server Settings -> Project Detail Pages and check if you have "Project Information" PDP and it has the property for (2) New Project.

    If you indeed deleted it, maybe its quicker to check in that library if it's still in the recycle bin and you can restore items from there.

    If not, you still can create a new PDP. Just make sure to set it as a PDP to create new projects and include all Custom Fields named "Sample..." something.

    Best regards,

    Rene Alvarez

    Tuesday, October 30, 2012 2:16 AM
  • Hi Rene,

      I still have the Project Information PDP and it is correctly set to (2) New Project.

    For additional testing I created a new Enterprise Project Type called 'New Proposal'.  I copied all of the settings from the sample proposal template with the exception of Using the sample proposal workflow.  Instead I just chose to display the project information PDP.   I could then create a new project.

    Next, I modified the new EPT so that it used the Sample Proposal Workflow, I now get the CallBack error when I try and create a new project.


    Update:  When I look at the workflow stages such as 'Initial Proposal Details'  I see that there are no PDPs selected in the 'Visible Project Detail Pages' section.   Are these required to be populated?
    • Edited by AndyW2007 Tuesday, October 30, 2012 7:42 PM
    Tuesday, October 30, 2012 7:29 PM
  • Andy,

    Yes, you will need to have some PDP's configured in the stage to show, otherwise PS will throw an error.

    Out of the box, PS will create the various components needed for the Sample Proposal workflow, including stages, phases and the PDP's. Have you deleted the contents of or changed the security on the PDP library? The usual reason for the error you are seeing is that the workflow is looking for stages / phases or PDP's that haven't been set up or changed in the PWA instance.


    Alex Burton
    www.epmsource.com | Twitter
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page

    Tuesday, October 30, 2012 8:20 PM
    Moderator
  • Hi Alexander,

    I encountered an issue during the installation of Project Server, the end result that it appears to have created all of the PDPs but had not created the Sample Proposal process correctly.   So far I have found that in the Workflow stages, no PDPs have been assigned (I am trying to get a list of what PDPs need to be in which stage), and I have found that it is not creating any approvals (no entries appearing in the workflow approval list - even though I am a member of the appropriate groups).

    Regards

    Andy

    • Proposed as answer by matty13 Thursday, January 2, 2014 11:51 AM
    Wednesday, October 31, 2012 6:20 PM
  • Your best bet might be to spin up another PWA instance and then duplicate the settings across.

    Alex Burton
    www.epmsource.com | Twitter
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page

    Wednesday, October 31, 2012 6:37 PM
    Moderator
  • In the end I resolved it by creating a new development VM and doing a new SharePoint installation, then a clean install of Project Server.  There were no issues during installation this time, and everything appears to be working. 


    • Edited by AndyW2007 Tuesday, November 20, 2012 10:33 PM
    • Marked as answer by AndyW2007 Tuesday, November 20, 2012 10:33 PM
    Tuesday, November 20, 2012 10:32 PM
  • I had exact same error. Found that PDP's were not assigned in the Stage (even though they were displaying as set in the Stages page!). Fix was to open each Stage again and reset the required PDP's per stage. You can get the list from a New Clean Instance.

    Thursday, January 2, 2014 11:57 AM