locked
MSN Weather tile not updating RRS feed

  • Question

  • Ever since upgrading to Windows 10 from Windows 7, the MSN Weather (or BING Weather) tile does not update even though the app is working correctly. That is, the tile just shows the static icon. I am now on Build 10586.17 and this problem is still there.

    I have searched the Internet and found many suggestions but none so far works.

    I also noticed, on the same machine, the weather tile updates on a user I created after I upgraded to Windows. But for my own user, upgraded from Windows 8.1, the weather tile does not update.

    I think this is a common problem and wonder if Microsoft is aware of it and currently working on it?

    Friday, December 4, 2015 1:51 AM

All replies

  • Check : https://social.technet.microsoft.com/Forums/en-US/c2767e97-422f-47ee-b199-aec4da852aea/bing-weather-app-large-live-tile-not-updating-after-closing-the-app?forum=w8itprogeneral


    Arnav Sharma | http://arnavsharma.net/ Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Proposed as answer by arnavsharma Friday, January 8, 2016 2:21 AM
    Friday, December 4, 2015 2:34 AM
  • The link you provided does NOT help. First it was a Windows 8.1 thread. Mine worked fine with Windows 8.1 and only have problem with Windows 10. Second, the thread towards the end, due to a lack of satisfactory solution, actually suggests to install another weather app instead of the Bing Weather!!

    Any other suggestions? Or, this is an issue that Microsoft is currently working on??

    Thanks.

    Friday, December 4, 2015 11:30 PM
  • Hi,

    You could list what you have tried so we won’t offer that as a solution again.

    Try following command in PowerShell as administrator window

    Get-AppxPackage -AllUsers| Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml”}

    If the issue still persists, try uninstall “weathers” then reinstall that again by following instructions as mentioned below.

    http://www.howtogeek.com/224798/how-to-uninstall-windows-10s-built-in-apps-and-how-to-reinstall-them/

    Please note: Since the websites are not hosted by Microsoft, the links may change without notice. Microsoft does not guarantee the accuracy of this information.

    Since you mentioned it works under new user account, try create a new account to fix current account.

    Fix a corrupted user profile (also applies Windows 10)

    http://windows.microsoft.com/en-us/windows/fix-corrupted-user-profile#1TC=windows-7

    Please backup current user profile before taking any action, and create another administrator account in case you have boot issue.

    Regards,

    D. Wu


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Proposed as answer by arnavsharma Friday, January 8, 2016 2:21 AM
    Tuesday, December 8, 2015 8:31 AM
  • Your first suggestion, running PowerShell in admin mode, have you tried it before suggesting?? It renders all my apps inoperable! Even the Windows store is inoperable!. Luckily I have a backup of my system and am able to restore from a backup. Otherwise I probably need to re-install Windows. Very bad suggestion!

    I don't need you to provide a solution per se. I just want to know if this is a KNOWN Windows 10 problem as of today and if it is being worked on. I can live with it and wait when the updates come. Just tell me if this is a work in progress.

    By the way, uninstalling and reinstalling does not help.

    Monday, December 14, 2015 5:56 AM
  • I just want to know if this is a KNOWN Windows 10 problem as of today and if it is being worked on

    Known problem : No

    Arnav Sharma | http://arnavsharma.net/ Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Monday, December 14, 2015 6:03 AM
  • Hi,

    I need to apologize about that, I should let you only register the weather app so it wouldn't affect all others. As mentioned by arnavsharma, we haven’t recived any report about similar issue.

    Regards,

    D. Wu


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Proposed as answer by arnavsharma Friday, January 8, 2016 2:21 AM
    Thursday, December 17, 2015 1:51 AM
  • With the register command, the weather tile now only shows a blue tile, even without the static "sun" picture. At the bottom of the tile it displays @{Microsoft.BingWeather_4.7.118.0_x86... When I click on it, nothing happens. I cannot even use the Remove-AppxPackage to remove it. Any help to uninstall and reinstall the weather app. I really like the app and hate to see it renders useless. The worst case, which I am still avoiding, is to create another user account or to refresh the system.

    Thanks for your help.

    Saturday, December 19, 2015 6:22 PM