locked
Cannot install SCCM TP3 application catalog web service role or application catalog role because of IIS version check error RRS feed

  • Question

  • Just wanted to post this to see if anyone was able to solve this problem.  I know that it is the technical preview versions of System Center and Windows Server 2016, but it seems like this can be fixed and should be in the newest versions.  The problem is when attempting to install the Application Catalog Web Service and Application Catalog roles in SCCM 2016 tp3, the installation fails because of IIS being version 10, as the logs and error messages state that IIS v7 or above is necessary to install these roles.  I am not sure if this is a problem with my server or if this error is happening on all instances of SCCM.  It may be a Y2K problem since I definitely have IIS 10 installed as well as all of the required prerequisites.  So the installation MSI is checking version of IIS and incorrectly thinking that v10 is less than v7.
    Saturday, November 14, 2015 4:57 PM

Answers

  • The problem still exists with WS 2016 TP4 and SCCM 1511..

    Did you find a workaround ?

    Thanks

    EDIT : Just found a solution : edit msi files (awebsvc.msi and portalweb.msi in C:\Program Files\Microsoft Configuration Manager\bin\X64) using Orca and change the

    InstallExecuteSequence / CcmCheckIISVersion from (NOT REMOVE) AND (IISVERSION < "#7") to (NOT REMOVE) AND (IISVERSION < "#10")

    And it works

    I've made a blog post about it : How To Install SCCM 1511 on Windows Server 2016 TP4

    • Edited by Tof006 Friday, December 11, 2015 6:51 PM
    • Marked as answer by JGNetworkSecurity Monday, December 14, 2015 9:55 AM
    Friday, December 11, 2015 3:08 PM

All replies

  • Hi JGNetworkSecurity,

    Thanks for your post.

    Before further troubleshooting, please insure your system has installed all the related hotfix.

    May I ask what's the sepcific error you get? And is there any other event in the event log?

    What do the app catalog related logs say: ServicePortalWebSite.log, ServicePortalWebService.log, portlwebMSI.log, awebsvcMSI.log? Also, have you looked at the IIS logs?

    And for now, I haven't find the related article about Deploying the Application Catalog in SCCM 2016 tp3, there's only some tips about sccm 2012. You may have a reference.

    http://blogs.technet.com/b/configmgrteam/archive/2012/07/05/tips-and-tricks-for-deploying-the-application-catalog-in-system-center-2012-configuration-manager.aspx

    Besides, since the question may related to the instances of SCCM, you could also try to confirm in the SCCM Forum.

    Here is the thread discussed before, you could take a look.

    https://social.technet.microsoft.com/Forums/windowsserver/en-US/1e4b19eb-b046-4820-96cc-ae4444895938/application-catalog-roles-unable-to-install

    Best Regards,

    Mary Dong


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, November 16, 2015 7:03 AM
  • After noticing that the SCCM TP 4 was released, I uninstalled TP3 and now am attempting to install the SCCM TP4. With regard to your questions about the logs and about installing the application catalog the correct way. I have installed the application catalog several times, with no issues. However on WIndows Server 2016 technical preview 3, the error is that IIS v7 or above must be installed, and when attempting to install the web portal, with the portlweb.msi by itself, it pops up that error that IIS v7 or above must be installed. THat is why I feel that the error is related to the version checking and it seems to think that v10 of iis is not greater than v7, which is a common error in software. 

    I actually watched the logs line by line as the Application Catalog attempted to install and when checking for IIS version 7, the installs would fail.  However, IIS was definitely installed and functioning for the rest of COnfiguration Manager TP3 roles.

    NOw I am working on installing the 4th technical preview and if I find that this problem still exists, I will update my post as needed.

    Monday, November 16, 2015 7:55 AM
  • The problem still exists with WS 2016 TP4 and SCCM 1511..

    Did you find a workaround ?

    Thanks

    EDIT : Just found a solution : edit msi files (awebsvc.msi and portalweb.msi in C:\Program Files\Microsoft Configuration Manager\bin\X64) using Orca and change the

    InstallExecuteSequence / CcmCheckIISVersion from (NOT REMOVE) AND (IISVERSION < "#7") to (NOT REMOVE) AND (IISVERSION < "#10")

    And it works

    I've made a blog post about it : How To Install SCCM 1511 on Windows Server 2016 TP4

    • Edited by Tof006 Friday, December 11, 2015 6:51 PM
    • Marked as answer by JGNetworkSecurity Monday, December 14, 2015 9:55 AM
    Friday, December 11, 2015 3:08 PM
  • I haven't tried this personally yet, but I am trusting you that this works, and want to thank you for the blogpost and response to my question. I just haven't had time to reinstall Configuration Manager yet since I posted this, but now I will.

    I marked your answer as the solution thanks, if anything else happens related to this issue or the workaround is not working please repost.

    Cheers

    James

    Monday, December 14, 2015 9:58 AM
  • I'm now trying to find a way to make SCUP 2011 compatible with WS2016...
    Monday, December 14, 2015 10:37 AM
  • It is time for Microsoft to fix this problem, Is there any information or documentation anywhere on TechNet that Microsoft even knows about this problem, anyone with info please comment.

    I have not been able to file any bugs for some reason on SCCM connect. 

    MICROSOFT< SCCM TP4 and 1511 both still will not install on Server 2016 TP4 because of IIS 10.0 version check not working correctly, SCCM checks for IIS version 7 or above but if it sees version 10, it thinks that IIS is not installed.  Please fix the awebsvc.msi file in a future update~!

    this causes lots of grief for anyone trying to install the Application Catalog Web service point and the APplication Catalog website on any system with IIS 10

    Thanks, It would be great if someone could comment and say yes Microsoft knows about this, but I have not heard anything yet.

    Thursday, January 28, 2016 2:07 PM
  • Hi,

    According to MS, it's not a problem.

    I've asked the question here :

    Now Available: System Center Configuration Manager Technical Preview 4

    You can read Yvette's answer...

    I made available the 2 MSI I modified on my blog : How to install SCCM 1511 on Windows Server 2016 TP4


    • Edited by Tof006 Thursday, January 28, 2016 3:23 PM
    Thursday, January 28, 2016 2:25 PM