none
Urgent help required !! - user profile takes very long time to load and the screen stays with the message "please wait loading the user Profile service"

    Question

  •   

    HI

    Whenever we login to servers in TS farm, the user profile loads for a long time and it stays with a message  "please wait for the user profile service" for more than 5 - 6 mins. We are working in two domains which is configured as "one way transitive forest trust". The domain (domain A) with TS farms from which we login has cross forest roaming profile disabled so we cannot load roaming profile in that domain, wheareas other domain's (domain B) user profile is roaming profile.

    Also in the Active directory of  domain B, the TS/RDS settings is enabled  for the problematic profile.

    TS/RDS --> Roaming profile path and TS Home Folder is configured. The TS/RDS settings is been configured becasue we use other citrix machines/TS farms other than the one in which we have issue.

    When we disable the TS/RDS settings from the active directory of Domain B then there is improvement in the time taken. But we are in a situation were we cannot disable TS/RDS settings as we use other Citrix machines also. So we tried configuring GPOs in Domain A TS like

    Enabling "only allow local user profile"

    Enabling "Prevent Roaming Profile changes from Propagating to server"

    Enabling "Allow asynchronous user Group Policy processing when logging on through Terminal Services"

    But still there was no improvement in the time taken by the server to login. What is the setting to be done in Domain A's TS, such that it will not attempt to load the Domain B users' roaming profile, even if TS/RDS settings for the user profile are configured?

    Tuesday, June 16, 2015 10:48 AM

Answers

  • Hi,

    Thanks for posting. I'd like to confirm with you if the settings you configured above got applied or not? Please run a RSOP report and then have a check.

    Basicly, We could divided to two conditions to disable roaming profile: 1.    The roaming profile is configured by the group policy “Set roaming profile path for all users logging onto this computer” under computer configuration, administrative templates, system, user profile.  In this condition, we should at first disable the policy. Also enable the policy “Only allow local user profile”. 2.    If the roaming profile path is configured under ADUC user properties profile tab, we should clear the Profile path.

    Best Regards,

    Elaine


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, June 18, 2015 3:08 AM
    Moderator

All replies

  • Hi,

    Thanks for posting. I'd like to confirm with you if the settings you configured above got applied or not? Please run a RSOP report and then have a check.

    Basicly, We could divided to two conditions to disable roaming profile: 1.    The roaming profile is configured by the group policy “Set roaming profile path for all users logging onto this computer” under computer configuration, administrative templates, system, user profile.  In this condition, we should at first disable the policy. Also enable the policy “Only allow local user profile”. 2.    If the roaming profile path is configured under ADUC user properties profile tab, we should clear the Profile path.

    Best Regards,

    Elaine


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, June 18, 2015 3:08 AM
    Moderator
  • Hello, 

    I had a similar problem in my corporate PC, after many days on several search engines and many attempts the one solution that worked was quite simple, I'm not the author so here goes the link were I found it

    https://modem7.wordpress.com/2013/11/04/fixing-the-windows-7-slow-logon-waiting-for-the-user-profile-service/

    Hope it helps

    BR

    Rui

    Thursday, September 10, 2015 8:23 AM