locked
Software Packages and Verification of file signature failed for file error RRS feed

  • Question

  • I just installed SCE 2007 with SP1 about a week ago. 
    Yesterday I just attempted to create a software package for Office 2007 to get used to the process and push to a few test clients.  The process took about 15-20 minutes and then I received the following error message:

    Date: 10/20/2008 3:30:23 PM
    Application: System Center Essentials
    Application Version: 6.0.1885.0
    Severity: Error
    Message: Verification of file signature failed for file: \\SHOCKWAVE\UpdateServicesPackages\4e575786-ab78-45f5-a200-24b75ee0b762\e992170c-8e8b-4cdc-ba3a-b51cd8d43cf3_1.cab

    System.InvalidOperationException: Verification of file signature failed for file: \\SHOCKWAVE\UpdateServicesPackages\4e575786-ab78-45f5-a200-24b75ee0b762\e992170c-8e8b-4cdc-ba3a-b51cd8d43cf3_1.cab
       at Microsoft.UpdateServices.Internal.BaseApi.Publisher.VerifyAndPublishPackage()
       at Microsoft.UpdateServices.Internal.BaseApi.Publisher.PublishPackage(String sourcePath, String additionalSourcePath, String packageDirectoryName)
       at Microsoft.UpdateServices.Internal.BaseApi.Publisher.PublishPackage(String sourcePath, String packageDirectoryName)
       at Microsoft.EnterpriseManagement.SCE.Internal.UI.NewUpdatePackageWizard.PreparingPackagePage.PreparePackageBackgroundWorkerDoWork(Object sender, DoWorkEventArgs e)

    At first I thought this was related to Office 2007, but then noticed I got it with other applications such as Firefox.
    I am running Windows 2003 Server Standard Edition SP2. I checked this forum and others with no success.  Does anyone know what is causing this and how to resolve it?


    Tuesday, October 21, 2008 10:15 PM

Answers

  • Hi,

     

    Perform folllowing steps:

     

    =Added the SCE server to SCE Managed Server Group

    = Run gpupdate /force command to update the Group Policy.

    = The following registry entries should be set to https://SCEServerFQDN:8531 on SCE server


    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\windows\WindowsUpdate\WUServer
    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\windows\WindowsUpdate\WUStatusServer

    After that, try to re-create software to see if it works.

     

    HTH.

     

    Thursday, October 23, 2008 2:49 AM

All replies

  • Everett,

    It looks like you are experiencing the same issue that is discussed  and solved here:

    http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=3255244&SiteID=17

    Let me know if it doesn't work for you.

    Thanks,

    Tim

     

    Tuesday, October 21, 2008 10:25 PM
  • Tim,

    I looked at this posting and it seems like the two fixes did not apply to me.
    One was a hotfix that, if I'm not mistaken, only seems to apply to SP1.  I am currently running SP2.
    The other fix had to do with re-installing the remote console, but I am not using a remote console.
    I just logged in directly to the management server and ran the process from the console.

    Any other suggestions?

    Thanks.
    Wednesday, October 22, 2008 5:05 PM
  • Hi,

     

    Perform folllowing steps:

     

    =Added the SCE server to SCE Managed Server Group

    = Run gpupdate /force command to update the Group Policy.

    = The following registry entries should be set to https://SCEServerFQDN:8531 on SCE server


    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\windows\WindowsUpdate\WUServer
    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\windows\WindowsUpdate\WUStatusServer

    After that, try to re-create software to see if it works.

     

    HTH.

     

    Thursday, October 23, 2008 2:49 AM
  • this one i already did... server is already a member of the SCE security group but still same error... i also tried doing c:\Program Files\System Center Essential 2007\SCECertPolicy... but still it says verifiction of signature failed... can you give any other ideas i can use?

     

    many thanks.. eman

    Thursday, April 29, 2010 7:54 AM
  • Hi,

     

    Perform folllowing steps:

     

    =Added the SCE server to SCE Managed Server Group

    = Run gpupdate /force command to update the Group Policy.

    = The following registry entries should be set to https://SCEServerFQDN:8531  on SCE server


    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\windows\WindowsUpdate\WUServer
    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\windows\WindowsUpdate\WUStatusServer

    After that, try to re-create software to see if it works.

     

    HTH.

     

    I checked all of these settings, and everything checked out ok, but I went ahead and forced a GP update...still no dice...I get the same validation error.

    Newbie
    Sunday, June 13, 2010 4:25 AM
  • I am using SCE 2010 and I do not see a SCE Managed Server group. Is this manually created? I have a SCE Managed Computers Group Policy and System Center Essentials All Computers Policy. I have tried all other solutions out there and found none, from the registry entry to certificates. Most packages are fine, some aren't.
    Friday, May 13, 2011 2:29 PM