locked
Media Player 12 won't play *.wmv in IE8 RRS feed

  • Question

  • When I attempt to play a *.wmv on a webpage, rather than Media Player opening the file (as it does in IE7 and Media Player 11) it simply gives an error message that the page can't be accessed. It doesn't do this with MPEG or other video file types. I have done everything, including reestablishing Media Player as the default program. Still nothing. The files will play if I download them onto my harddrive and watch offline, but that shouldn't be necessary. I now understand why every time I have tried to download IE8 I end up restoring IE7. IE8 is not working as well as IE7 does.

    Tuesday, May 12, 2009 2:12 PM

Answers

  • I had this same issue on my 64-bit, Windows 7 machine, but the guy next to me did not. I compared our HKEY_CLASSES_ROOT\.wmv and the only piece that was different was my default was set to WMVFile (like yours) and his was set to WMP11.AssocFile.WMV. After changing the default value to what he showed in his registry instead of what I had, wmv files would open for me. From what you describe, it sounds like we had the exact same experience, so I hope this can help resolve your issue.
    • Proposed as answer by Barleone Friday, May 29, 2009 5:49 PM
    • Marked as answer by dwoltersEditor Saturday, May 30, 2009 4:50 PM
    Thursday, May 14, 2009 5:59 PM

All replies

  • Why is IE7 on the mix on a Windows 7 system.... ?
    Is it one particular web page with WMVs or any page?
    What steps did you perform to set WMP as the default again?

    What are the values under:
    HKEY_CLASSES_ROOT\.wmv
    ?
    Is this a 64bit or 32bit system?
    Wednesday, May 13, 2009 6:05 AM
  • 1. The reference to IE7 is that IE7/WMP never conflicted before on these video files.

    2. WMV's do not stream on ANY webpage using WMP through IE8. I get an error page and option to diagnose the problem which comes up empty-handed. However... MPEGs DO stream using WMP in IE8... so the problem is restricted to WMVs/WMP/IE8. Both Realplayer and Quicktime operate normally without conflict. AND I can play WMV's with WMP if I download the file to my harddrive and click to play (It will play using WMP by default)

    3. By going into Change Default Programs and selecting Windows Media Player as the default for WMV's.

    4. Under HKEY_CLASSES_ROOT\.wmv  it has:
    a. Default: WMVfile    Content Type: video x-ms-wmv
    b. OpenWithList:    Default: Value Not Set
    c. OpenWithProgIDs:   Default: Value Not Set    WMP11.assocfile.WMV (WindowsLive.MovieMaker.Video14.0 and WindowsLive.PhotoGallery.video.14.0 are both blank)
    d. PersistentHandler and ShellEX both have AlphaNumeric coding

    4. I am running a 64-bit,  2.0 ghz Dual Core System with 4.0 Gig Memory and nearly a Terabyte of harddrive space.

    So here's a summary of Details:
    1. WMP plays all WMV's downloaded to my harddrive by default.
    2. IE8 will NOT open WMP to stream WMV's online, but IE8 WILL open WMP to stream MPEGs online (This problem did not exist with IE7 and since IE8 DOES stream MPEGs using WMP this indicates problem with file type and not an indication that the programs are not working together)
    3. IE8 still uses and streams REALplayer and Quicktime type files by default. No conflict there.
    4. Using Trend Micro Internet Security for Windows 7 as antivirus and firewall. Settings are fine on that.
    5. Upgraded to Windows 7-64bit from Windows Vista 64-bit

    Since WMP opens any WMV downloaded to my harddrive by default, but will not stream ANY WMV file through IE8 it's not an indication that the program doesn't work... just not for streaming WMVs online.
    Wednesday, May 13, 2009 2:11 PM
  • I had this same issue on my 64-bit, Windows 7 machine, but the guy next to me did not. I compared our HKEY_CLASSES_ROOT\.wmv and the only piece that was different was my default was set to WMVFile (like yours) and his was set to WMP11.AssocFile.WMV. After changing the default value to what he showed in his registry instead of what I had, wmv files would open for me. From what you describe, it sounds like we had the exact same experience, so I hope this can help resolve your issue.
    • Proposed as answer by Barleone Friday, May 29, 2009 5:49 PM
    • Marked as answer by dwoltersEditor Saturday, May 30, 2009 4:50 PM
    Thursday, May 14, 2009 5:59 PM
  • This bug should have been caused by the Windows Live Photo Gallery installer, of all strange things.

    To fix this at this point, go to the Default Programs:Set Program Access and Computer Defaults control panel and set WMP as default again - this will get it to fix the progid (from WMVFile to WMP11.AssocFile.WMV, plus undoing two other changes WLPG did).

    The WL team is aware of this bug and it should be addressed previous to the release version of Windows 7.
    • Proposed as answer by Gordon228 Thursday, July 16, 2009 12:42 AM
    Thursday, May 14, 2009 6:08 PM
  • Yes! This helped me solve the problem. Unfortunately, the answer below above (what happened??) of zachd[msft] does not solve my problem.
    • Edited by Barleone Tuesday, June 2, 2009 9:25 AM
    Friday, May 29, 2009 5:51 PM
  • Did you use SPACD as advised?  That forces the WMP's SPACD component to go rewrite the correct settings that Windows Live Photo Gallery stomped upon.  There are other apps in the "Default Programs" gallery - those will not and can not work to fix this.  Only the SPACD control panel lets you fix this "automatically". :)

    If you want to do it manually via regedit, set:
    ===
    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\.avi]
    @="WMP11.AssocFile.AVI"

    [HKEY_CLASSES_ROOT\.asf]
    @="WMP11.AssocFile.ASF"

    [HKEY_CLASSES_ROOT\.wmv]
    @="WMP11.AssocFile.WMV"

    ===
    Friday, May 29, 2009 7:37 PM
  • This bug should have been caused by the Windows Live Photo Gallery installer, of all strange things.

    To fix this at this point, go to the Default Programs:Set Program Access and Computer Defaults control panel and set WMP as default again - this will get it to fix the progid (from WMVFile to WMP11.AssocFile.WMV, plus undoing two other changes WLPG did).

    The WL team is aware of this bug and it should be addressed previous to the release version of Windows 7.

    Thankyou! Thankyou Zachd! I have been trying to figure this out for too long. I sure appreciate the education!
    Thursday, July 16, 2009 12:44 AM
  • To close this out more fully:

    There are generally two aspects to this. 

    1: The WLPG installer issue.  This was fixed in their August 19 2009 release.  Upgrading to that ( http://download.live.com ) will ensure that that doesn't happen again.
    2: WMP not handling this scenario more cleanly.  It's a broken scenario, but KB974817 improves WMP's handling of this.  KB974817 is included in the updates available via Windows Update, so if your system is up to date, you should already have it.

    These combined should ensure that going forward this issue slowly fades away.

    Friday, December 4, 2009 9:16 PM
  • OK, I had an issue with media player 12, for some reason it quit playing every type of file. I spent countless hours trying to figure it out. I am not bill gates or a computer whiz by any stretch of the imagination, but i like a good challenge. OK, when I tried to play a file on media player it gave me a error code ( C00D1199 ) and it told me it didnt support the file. Well, after reading countless forums and blogs I finally came across something on this site that corrected everything and my media player works like it should. So here we go, click start, type in troubleshoot, a window should come up with multiple choices pertaining to what you want to troubleshoot, like programs, hardware and sound etc.  in the search box type in windows media player, you should see 2 to 3 items related to the media player, windows media library ( make media files show up ) windows media player settings (reset windows media player) click every item you see related to the media player and let the troubleshooting device take it's course. After you are done, go back to media player and start playing your files. It worked for me and I hope it works for you. 
    • Proposed as answer by hery syahrial Sunday, November 28, 2010 5:16 PM
    Friday, January 8, 2010 9:34 PM
  • and the solution?
    Saturday, December 11, 2010 4:19 AM