none
Renaming Device During Autopilot OOBE Not Working

    Question

  • This one ought to be simple but I'm not seeing an obvious reason for it.  I've set the 'Enter a name' field under the OOBE settings for Autopilot enrollment using the NAME-%SERIAL% format but for some reason the devices come up with the standard DESKTOP-NUMBER naming format.  The total device name length is not more than 15 chars.  

    I've assigned the profile to my ZTDID devices, and it looks to be targeting them correctly because the other OOBE settings (like the EULA being hidden) are all taking correctly.  

    Anyone know what might cause this, or what logs could indicate what's happening here?  


    Thursday, May 16, 2019 1:54 PM

Answers

  • Hello,

    Firstly, device name template requires Windows 10 1809 or later, and please make sure the version of Windows 10 meets the requirement.

    It works for me, and I configured it as below.

    Best regards,

    Andy Liu


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by pfarahi Friday, May 17, 2019 3:22 PM
    Friday, May 17, 2019 2:21 AM

All replies

  • Is it happening on just one model or all models? Do you have other Autopilot profiles assigned to the device in addition to the one with the NAME-%SERIAL%?

    If you go to Device enrollment - Windows enrollment
    Windows Autopilot devices, and select the device, can you see the profile assigned to it?

    Thursday, May 16, 2019 10:09 PM
  • Hello,

    Firstly, device name template requires Windows 10 1809 or later, and please make sure the version of Windows 10 meets the requirement.

    It works for me, and I configured it as below.

    Best regards,

    Andy Liu


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by pfarahi Friday, May 17, 2019 3:22 PM
    Friday, May 17, 2019 2:21 AM
  • Ah, that's it, these are 1803 devices that I'm firing these to.  I'll test again with 1809.  
    Friday, May 17, 2019 3:23 PM