none
Outlook 2016 trusted sender list overwritten by Exchange

    Question

  • Hi...one of the complaints in our organization is that regular communication from the business is blocked from downloading pictures automatically. I tried to add our internal email domain to trusted sender lists via GPO in Outlook. It works great and the pictures are downloaded automatically...however, the list is soon overwritten by the -MailboxJunkEmailConfiguration list in Exchange.

    This would be fine except that when you try to add your internal domain to the "TrustedSendersAndDomains" list, Exchange throws an error stating that you cannot add your own domain to the list.

    So...I'm at a loss as to what needs to be done to allow internal communications to automatically download pictures in Outlook. Any help would be greatly appreciated.

    Monday, April 24, 2017 5:51 PM

All replies

  • Hi Erik,

    Blocking pictures can help protect your computer. Microsoft Outlook is configured by default to block automatic picture downloads from the Internet.

    To be honest, it's not a good idea to add your internal domain to the safe sender list as the "domain" you are referring to can be easily spoofed. Adding your own domain to the Safe Senders list would bypass all Outlook client-side anti-spam checks, dumping that message from the spoofed domain into your users’ Inboxes. 

    It's recommended to add the users' contacts who communicate regularly to the safe sender list instead.

    Besides, you may also consider to enable the anti-spam agent on the hub transport (or an edge server), and then add the IP addresses of internal servers to the IP allow list and disable all other features. For your convenience:

    https://technet.microsoft.com/en-us/library/bb125225.aspx

    Regards,

    Steve Fan


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.



    Friday, April 28, 2017 8:58 AM
    Moderator