none
project server 2010 - publishing tasks one at a time RRS feed

  • Question

  • Dale Howard answered another question regarding emails which are sent when a project is published (the emails should only be sent to resources for those tasks which are updated but unfortunately emails are sent to every resource.....as Dale explained and I think we all agree this is a bug which Microsoft should fix).  

    I have 2 related questions which were not answered but may provide a workaround to this bug for the mgrs here who are very frustrated by this bug?

    1.  Is there a way to select a TASK in project professional and only publish that one task?  If not, how about PWA?

    2.   If I go into a project plan and  insert the column for 'PUBLISH' ....and then I set the value to 'N' for all tasks in the project plan (after the initial publish is done)......can I set the value to YES on a task by task basis as I update each task so that only emails for those tasks go out????......as a work around to the bug?

    Thanks.

    Kellie


    KMillerIC

    Wednesday, June 20, 2012 10:19 PM

Answers

  • Yes, you are on the right track.

    "Publish" yes/no can help you to perform selective publishing of the plan.


    Hrishi Deshpande – DeltaBahn Senior Consultant
    Blog | < | LinkedIn

    • Marked as answer by KMillsIC Wednesday, June 27, 2012 1:45 PM
    Wednesday, June 20, 2012 11:28 PM
    Moderator
  • Kellie --
     
    In addition to Hrishi�??s excellent answer, I do not believe your approach will solve the problem of too many e-mails being sent by Project Server.  But I am willing to be totally wrong.  Try an experiment by publishing only one task at a time with the Publish value set to Yes for only one task.  Make sure that your team members in the project have the My Project Tasks Are Modified option ENABLED on the Manage My Alerts and Reminders page in PWA.  And then determine whether they all got an e-mail each time you published...or not.  And then please let us know the results of your experiment.

    Dale A. Howard [MVP]
    VP of Educational Services
    msProjectExperts
    http://www.msprojectexperts.com
    http://www.projectserverexperts.com
    "We write the books on Project Server"

    Thursday, June 21, 2012 1:44 AM
    Moderator

All replies

  • Yes, you are on the right track.

    "Publish" yes/no can help you to perform selective publishing of the plan.


    Hrishi Deshpande – DeltaBahn Senior Consultant
    Blog | < | LinkedIn

    • Marked as answer by KMillsIC Wednesday, June 27, 2012 1:45 PM
    Wednesday, June 20, 2012 11:28 PM
    Moderator
  • Kellie --
     
    In addition to Hrishi�??s excellent answer, I do not believe your approach will solve the problem of too many e-mails being sent by Project Server.  But I am willing to be totally wrong.  Try an experiment by publishing only one task at a time with the Publish value set to Yes for only one task.  Make sure that your team members in the project have the My Project Tasks Are Modified option ENABLED on the Manage My Alerts and Reminders page in PWA.  And then determine whether they all got an e-mail each time you published...or not.  And then please let us know the results of your experiment.

    Dale A. Howard [MVP]
    VP of Educational Services
    msProjectExperts
    http://www.msprojectexperts.com
    http://www.projectserverexperts.com
    "We write the books on Project Server"

    Thursday, June 21, 2012 1:44 AM
    Moderator
  • Hi Kellie

    the way you mentioned is the only way i know to publish few tasks and not to publish all of them.

    You should use the Publish column and select 'YES' for the tasks you want to publish.

    These changes only will be published to PWA but i'm not sure about the bug about e-mails, i think that if e-mails that are sent to all users doesn't relate to how many tasks are published but to what project is published...

    you can try it but i'm not sure if it will disable the too much e-mails notifications problem.

     


    Ofir Marco , MCTS P.Z. Projects

    Thursday, June 21, 2012 7:08 AM
  • Dale and Ofir and Hrishi - Thank you all for the great information you provided.

    The project managers are somewhat happy to have a solution until bug fixed (they don't like having to continually mess with the PUBLISH column values but they are happy for workaround).

    I did test to verify the email notification in relation to the PUBLISH column values.  When the PUBLISH  column value is set to NO email notifications do not appear to be sent (good news)

    Here are the tests I ran:

    Test #1

    • inserted the PUBLISH column into my project plan
    • set PUBLISH column value to NO for all tasks in project plan
    • inserted 2 new tasks and set PUBLISH value = NO for  1 task and YES for one task and assigned myself to both tasks
    • Published the project plan
    • I received an email regarding just the one task where PUBLISH column was set to YES

    Test #2

    • I then went back to project plan and set PUBLISH value to NO for all tasks
    • I inserted a new task and set Publish to NO
    • I updated an "existing" task where PUBLISH was set to NO
    • I was assigned to both tasks
    • I published the project plan
    • I did not receive any email notifications

    Hope this helps and thank you all again for your detailed explanations and suggestions!

    -Kellie


    KMillerIC

    Wednesday, June 27, 2012 1:44 PM
  • Hi Kellie,

    Happy to see that, I could help.


    Hrishi Deshpande – Senior Consultant DeltaBahn
    Blog | < | LinkedIn

    Wednesday, June 27, 2012 2:35 PM
    Moderator