none
I use WSUS for patching and I never want to see "Install Updates and Shut down"

    Question

  • Hi,

    I use WSUS to patch my Win 7 and Win 10 machines and I control the Windows Update settings with GP.  I have enabled both of these settings in my workstation GP which is deployed to all workstations - verified using GPRESULTS:

    Do not adjust default option to 'Install Updates and Shut Down' in Shut Down Windows dialog box
    Do not display 'Install Updates and Shut Down' option in Shut Down Windows dialog box

    On Friday night, at the end of the day, everyone in the office got the "Install Updates and Shut Down" option before they could leave.  And on Saturday, I got the option again working at home.  Why doesn't the workstation respect the GP setting?  And how can I insure that 100% of the time, my users will never, never ever see the option to "Install Updates and Shut Down"?  Updates are configured to install automatically at 3 am so my users have no need to install updates at the end of their day.  

    Thanks.  


    • Edited by SeaGreg Monday, October 24, 2016 11:47 PM
    Monday, October 24, 2016 11:44 PM

All replies

  • Hello,

    Which version of WSUS ? Also, Do you have any errors messages in System Event Log regarding GPOs ?

    Regards,


    Gilles Tremblay
    MCSE Server | Desktop | Messaging | Collaboration | Productivity | Mobility | Cloud Platform and Infrastructure

    Dont forget to mark as Answered if you found this post helpful.

    DISCLAIMER: This post is provided "AS IS" with no warranties of any kind, either expressed or implied, and confers no rights. Always test before!

    Tuesday, October 25, 2016 12:16 AM
  • Hi SeaGreg,

    What are the detailed AU settings do you configure in the GPO?

    Please check the registry keys in HKLM\Software\Policies\Microsoft\Windows\WindowsUpdate\AU

    If you don't want to see "Install Updates and Shut Down", you may create the registry keys in the above registry path:

    NoAUAsDefaultShutdownOption = 1;

    NoAUShutdownOption =1;

    If you don't want the computer to be restart when uses logon, we may create registry key:

    NoAutoRebootWithLoggedOnUsers =1

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, October 25, 2016 6:40 AM
    Moderator
  • Hi, thanks from the responses.  Gilles, the version of WSUS is 4.x. My WSUS server is a Win 2012 R2 server and the version of WSUS is 6.3 which equals 4.x.  No GP errors in my event logs.

    Anne -
      I checked my registry and I already have all of the keys you mentioned and they are set to "1" (Enabled) already. 
    Looking in GPRESULT, Updates are set to Auto download from my WSUS server and then be installed at 3 AM every day. GPRESULT settings for my workstation under Computer Details, "Workstation Policy" is the name of my computer policy and is the Winning GPO:

    Defer Upgrades and Updates  / Enabled / Workstation Policy
      Defer upgrades for the following duration (months):  4
      Defer updates for the following duration (weeks):  0
    Pause Upgrades and Updates Disabled
     
    Do not adjust default option to 'Install Updates and Shut Down' in Shut Down Windows dialog box   / Enabled  / Workstation Policy
    Do not display 'Install Updates and Shut Down' option in Shut Down Windows dialog box /  Enabled / Workstation Policy
    Enabling Windows Update Power Management to automatically wake up the system to install scheduled updates / Enabled / Workstation Policy
    No auto-restart with logged on users for scheduled automatic updates installations / Enabled / Workstation Policy
    Re-prompt for restart with scheduled installations / Enabled / Workstation Policy

    Under User Details in GPRESULT, I have these settings from my "User Policy" GP:
     Do not adjust default option to 'Install Updates and Shut Down' in Shut Down Windows dialog box / Enabled / User Policy
     Do not display 'Install Updates and Shut Down' option in Shut Down Windows dialog box  / Enabled / User Policy

    Tuesday, October 25, 2016 9:55 PM