locked
WSUS Server 2012 to 2016 RRS feed

  • Question

  • So I may have done something daft, I did a in place server upgrade from 2012 to 2016 upgrading WSUS along the way to 10.0.14393.0.

    Now nothing seems broken and its working as it should (no event error etc) but I'm nervous, what should I look out for and what can I check to take away the doubt?

    Should note its not the end of world if I need to restore from backup or even bin the server and start again.

    Monday, January 16, 2017 7:02 PM

Answers

  • Sorry for such a late reply.  

    The upgrade did work and every seemed fine but then machines weren't checking in amongst other problems so I ended up rebuilding the server and separating out the DB to SQL.

    Thanks for the responses.

    • Marked as answer by Citizen0100 Tuesday, July 4, 2017 7:11 AM
    Tuesday, July 4, 2017 7:11 AM

All replies

  • Not knowing other details about your network, in general you should be OK. Just take the usual precautions like monitoring your event logs, etc.

    Is the server a DC? Physical server? VM? What other roles is it running? Do you have more than one DC?

    Thanks

    Ed

    Monday, January 16, 2017 7:34 PM
  • Hi Citizen,

    >Now nothing seems broken and its working as it should (no event error etc) but I'm nervous, what should I look out for and what can I check to take away the doubt?

    After you upgrade the WSUS server form server 2012 to server 2016, could clients get and install updates from the WSUS server correctly?

    Please check WSUS event log in event viewer, check if there are errors;

    Also recommended to install the latest monthly rollup for server 2016:

    https://support.microsoft.com/en-us/help/4000825/windows-10-update-history

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, January 17, 2017 3:22 AM
  • Hi,

    Just to check if you got any progress with the issue, welcome to feedback.

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, January 27, 2017 7:58 AM
  • Sorry for such a late reply.  

    The upgrade did work and every seemed fine but then machines weren't checking in amongst other problems so I ended up rebuilding the server and separating out the DB to SQL.

    Thanks for the responses.

    • Marked as answer by Citizen0100 Tuesday, July 4, 2017 7:11 AM
    Tuesday, July 4, 2017 7:11 AM