locked
Extended Desktop and Alt-Tab RRS feed

  • Question

  • This may be working as designed but it is frustrating. When using extended desktop on notebook + external monitor, pressing Alt-Tab and holding Alt clears both desktops. Not sure it needs to clear either but it would be nice if it left the secondary as-is.  Further, selecting the desktop from the Alt-Tab rotation clears both desktops. It would be nice here also if it just cleared primary or even if it gave primary and secondary as two separate choices in the rotation.
    Thursday, December 17, 2009 4:44 PM

Answers

  • Sounds like it's working just as designed.

    Why do you consider the two monitors as holding separate desktops?

    It's an EXTENDED desktop, which means it's logically ONE big desktop.  Surely you've noticed that windows can be dragged across from one to the other and even have parts displayed on both monitors simultaneously.

    Windows can't really know which application you're seeking when you Alt-Tab.  Which desktop would it blank?  The one on which the cursor is sitting currently?  I suppose that could work, but I think folks would find it confusing.  What would it do if an application were partly on both desktops?

    I believe you can disable Aero Peek, and just use Alt-Tab the traditional way.  I'll look up the specifics if you'd like.

    -Noel

    Thursday, December 17, 2009 7:06 PM

All replies

  • Sounds like it's working just as designed.

    Why do you consider the two monitors as holding separate desktops?

    It's an EXTENDED desktop, which means it's logically ONE big desktop.  Surely you've noticed that windows can be dragged across from one to the other and even have parts displayed on both monitors simultaneously.

    Windows can't really know which application you're seeking when you Alt-Tab.  Which desktop would it blank?  The one on which the cursor is sitting currently?  I suppose that could work, but I think folks would find it confusing.  What would it do if an application were partly on both desktops?

    I believe you can disable Aero Peek, and just use Alt-Tab the traditional way.  I'll look up the specifics if you'd like.

    -Noel

    Thursday, December 17, 2009 7:06 PM
  • Hi Scott,

    As my test, once we disable the "Enable Aero Peek" option, you would be able to keep your second monitor without changing. You can try the following steps.

    1. Click start, and type sysdm.cpl in the start search bar, then press Enter.
    2. Change to the Advanced tab.
    3. click on Settings button under Performance section:
    4. Now uncheck "Enable Aero Peek" option.
    5. Click OK to save the setting.



    John
    Friday, December 18, 2009 7:08 AM