none
SCCM 2012 Reporting point server instance blank

    Question

  • I have installed SCCM 2012 With remote SQL database server successfully, at the time of Reporting service point role installation, its verified the SCCm database successfully but SQL server service instance is blank, what would be the reason....

    Below my SCCM architecture:

    1. Created one Database in Remote server SQL server is in failover cluster active passive mode

    2. Configured Reporting services in active mode.

    3. at the time of reporting point role installed failover cluster database name given and its successfully verified with SCCM_123 database.

    4. on the instance name showing blank.

    Please help me if anyone facing this type of problem.

    Thanks in advance.

    Rishi!!


    Regards, Rishi

    Saturday, May 19, 2012 6:33 PM

Answers

All replies

  • What version of SQL Server Reporting Services?

    Note that SSRS is not a cluster aware application so installing it on a cluster node is not a good practice because SSRS cannot failover.

    Have you verified that SSRS is accessible by going to http://hostname/reports ?

    Final note is that when installing the reporting point, you are not specifying the SQL server instance, you are specifying the SSRS instance -- these are two different things.

    Is the site server's computer account a local admin on the system where SSRS is hosted? Remeber that because SSRS is not a cluster aware application, you cannot specify the name of the cluster.


    Jason | http://blog.configmgrftw.com | Twitter @JasonSandys

    Saturday, May 19, 2012 8:32 PM
  • It is not totally intuitive when installing the Reporting Point role with a cluster.  When installing a Failover Cluster, SSRS can only get put on one node or on its own box, as it uses NLB for scale-out not FoC.  SSRS is also not configured by default if you use it with a clustered SQL instance, so you have to open SSRS Configuration Tool and make sure the ReportServerDB is created, and that the URLs can be browsed.  Once that is done, then try adding it in CfgMgr:

    In CfgMgr, In the Administration workspace, expand Site Configuration, and then click Servers and Site System Roles.

    Select the node that has SSRS installed on it (not the Failover Cluster virtual computer account).  If SSRS is on its own box, first you have to go to New site system and add the SSRS box.

    Then, on the Home tab, in the Server group, click Add Site System Role. The Add Site System Roles Wizard opens.  Choose Reporting Point, and after verifying the connection to the CfgMgr DB, the instance name should populate.

    http://technet.microsoft.com/en-us/library/gg712698#BKMK_InstallReportingServicesPoint

    http://social.technet.microsoft.com/Forums/en-HK/configmanagerdeployment/thread/390a6ea8-8a24-47d0-b6ad-2e1063bbc72d

    Tuesday, May 22, 2012 5:58 PM
  • Hello! Should I install Reporting Services point on site server or Database server?


    • Edited by Olegrik Thursday, May 24, 2012 6:17 AM
    Thursday, May 24, 2012 5:04 AM
  • You mean to say the report is accessable through URL from CM servers? But not from other servers?

    Anoop C Nair - @anoopmannur

    MY BLOG:  http://anoopmannur.wordpress.com

    User Group:  ConfigMgr Professionals

    This posting is provided AS-IS with no warranties/guarantees and confers no rights.

    Thursday, May 24, 2012 5:30 AM
  • Hello! Should I install Reporting Services point on site server or Database server?



    It need to be installed on a SQL server.

    http://www.enhansoft.com/

    Thursday, May 24, 2012 10:57 AM
    Moderator
  • Hello! Should I install Reporting Services point on site server or Database server?



    It need to be installed on a SQL server.

    http://www.enhansoft.com/

    Thanks!
    Thursday, May 24, 2012 11:28 AM
  • Hi all,

    I was wondering if someone could help me with the same issue. My Reporting Services server instance remains blank when I am trying to install the Rpoerting Services role and I don't know how to over come this.

    My situation is:

    Remote SQL Server

    Reporting services is running in Native Mode

    Not sure what I'm missing or how I can troubleshoot?

    Thanks,

    Jay

    Friday, June 15, 2012 2:26 PM
  • OK so after reading this I now think the issue may be Firewall. Can anyone confirm that port 135 needs to be open between site server and SQL server when adding the Reporting Services Role?

    securitySecurity Note
    System Center 2012 Configuration Manager makes a connection in the context of the current user to Windows Management Instrumentation (WMI) on the selected site system to retrieve the instance of SQL Server for Reporting Services. The current user must have Read access to WMI on the site system, or the Reporting Services instances cannot be retrieved.
    • Proposed as answer by huw shields Thursday, September 20, 2012 1:26 PM
    • Unproposed as answer by huw shields Thursday, September 20, 2012 1:26 PM
    Friday, June 15, 2012 2:38 PM
  • I am having the same issue. My SQL and reporting services instance is on the same machine as SCCM. I can access the report url's just fine and I have verified that the correct accounts are local administrators on the machine. What else can I check?
    Tuesday, August 7, 2012 12:31 AM
  • I am having the same issue in this config as well.

    Here are some notes I made>  SRS is up and configured.  If I process URL HTTP://SRSServer:80/Reports I get to the website, however  if I try to process URL HTTP://SRSServer.mydomain.com:80/Reports I get prompted for username and password.  If I enter appropriate user credentials, I do get into SRS.

    Problem i beleive is that when you configure a new Site system in SCCM 2012, and you enter the server name, it automatically enters it as a FQDN.

    thoughts??

    I confirmed that I have SPN's defined for the service account that is running MSSQL Service.  Same account is running SRS


    Wednesday, September 5, 2012 7:26 PM
  • Within IE, add your server to the list of Trusted Sites, then you will not get prompted for a password.


    http://www.enhansoft.com/

    • Proposed as answer by DTMT27 Monday, January 14, 2013 5:32 PM
    • Unproposed as answer by DTMT27 Monday, January 14, 2013 5:33 PM
    Wednesday, September 5, 2012 8:02 PM
    Moderator
  • Hello All,

    I know this is a little old but I had the same issue, this is what I did to fix the issue.

    I did what Jason Sandys requested by trying to get to the URL of http://hostname/reports, once I was able to do that I changed the name of the site by going into site settings from the default name to something that matched my site.  Then I started the add role wizard again and on the first page I checked the box next to 'Require the site server to initiate connections to this site system'  Once I did that I was able to choose my reporting service instance.

    Hope this helps

    DT

    Monday, January 14, 2013 5:36 PM
  • In a single site server scenario, where SQL lies on the same box with ConfMgr, I solved the same issue by enabling both URL configurations in Reporting Services console. By doing that, the RSS instance came visible on add-roles-wizard on ConfMgr.
    Wednesday, September 11, 2013 7:49 AM
  • Hello
    I solved the problem by enabling port 1433 on the firewall server SQL. If you have further questions, disable the firewall (which is not recommended) and test.
    Wednesday, October 9, 2013 5:47 PM
  • http://www.microtom.net/microsoft-system-center/software-distribution/sccm-2012-reporting-services-do-not-install

    I faced issue in install of SCCM reporting then i used mofcomp.exe to register the SQL MOF Files as follows:

    Open an elevated command prompt and type

    For SQL Server 2008 R2

    mofcomp.exe "C:\Program Files (x86)\Microsoft SQL Server\100\Shared\sqlmgmproviderxpsp2up.mof"

    wait for 1 hr max... and it fixed


    Kirpal Singh

    Thursday, June 12, 2014 4:56 PM
  • I can get to the reports OK but cannot run any of them, the option to add criteria doesn't work. Have a picture but this site won't allow me to add it.
    Tuesday, September 23, 2014 5:52 PM
  • I know this is an OLD post but I just wanted to share my experience on how I was able to resolve this issue in my Test Environment. to help others who may be in the same situation. 

    I am a relatively new to SCCM and SQL and Believe I didnt setup "Reporting Services Configuration Manager".

    So, here's how I fixed it.

    Start-->Search and launch "Reporting Services Configuration Manager"--> On the left menu click Web Service URL

    -->Virtual Directory = ReportServer

    --> IP Address = All Assigned

    --> TCP Port = 80

    --> SSL Certificate = ConfigMgr SQL Server Identification Certificate

    --> SSL Port = 443

    --> Apply (Wait for a few mins while the URL is reserved)

    Then go back into SCCM and add the reporting Role. Hope I was able to help someone with these steps.

    PS: I also read somewhere that even if the reporting is already configured, SCCM 2012 doesnt populate the Reporting Services Server Instance. In this case, a few people were able to resolve the issue by making a fake change in Reporting Services Configuration Manager and reapplying the changes.

    • Proposed as answer by Ayaz Tutla Monday, June 1, 2015 7:38 PM
    Monday, June 1, 2015 7:38 PM
  • Thanks for this info. It helped me to configure the role successfully after a couple of days searching.

    Babu

    Tuesday, September 20, 2016 4:13 AM