locked
Windows Internal Database MSDB Recovery Pending RRS feed

  • Question

  • Hello,

    I have a kind of problem - or question: I didn't realize that I have to cleanup the WSUS database regularly and so there were a lot of entries and the known "timeout error" if I tried to run the cleanup tool. To fix that, I logged into the WID with SSMS and tried to change the timeout setting. But I only got a lot of 945 (file not found/denied) errors. After a lot of tries, i managed that instead with the WID properties with

    USE SUSDB ;
    GO
    EXEC sp_configure 'remote query timeout', 2400 ;
    GO
    RECONFIGURE ;
    GO

    and that worked. My question / problem is the cause of the errors: The WID MSDB database is "recovery pending" and the Windows\WID\Data\msdbdata.mdf file has a last changed timestamp of two years ago. Is that a problem I should address or - because I don't see any external problems - should I simply ignore that error? And if I have to attempt a recovery, how do I do that? All the information  could find about msdb recovery is for regular SQL Servers, not the WID Instance and almost everything I try fails with these 945 errors. (I checked and I do have sysadmin role).

    Friday, June 7, 2019 8:26 AM