locked
WSS 3.0: Compressed C: Rebooted, Sharepoint down RRS feed

  • Question

  • TL:DR I ran the Cleanup Utility, Compressed files and now Sharepoint is dead

    I've been running WSS 3.0 on an old 2003 server for years. It's really just a dev machine that was doing nothing so I created a basic Intranet on it. This server is from 1999 and I want to decommision it so I recreated the site on a much newer 2003 server from 2006.

    My employees have fallen in love with it and become quite dependent on it. :D

    The C drive was getting low on space, just a couple hundred MB so I ran Disk Cleanup with the Compress option checked. I've done this many times on my 2 Dev servers and never had any issues. Reboot server: SERVICE UNAVAILABLE.

    Login to server. Go to Central Admin 3.0: Service Unavailable. Event Viewer is flooded. One error mentioned 'Compressed files' so I went in to MSSQL\Data and decompressed everything in there. This did not fix it. I'm thinking there may be another file somewhere that still needs decompressed. Does anyone know how I can find out exactly what it is?

    Current Evt Viewer errors:

    RPC Server is too busy to complete this operation ID 6398 / 7076

    SSPI Handshake Failed 17806 Source MSSQLSERVER

    Login failed for user ". Not associated with a trusted SQL server connection ID 18452

    Database error occured again: Failed with user ".

    Error in mapping sql server perf id: 8313

    SQL Database "Sharepoint_Config on SQL Server instance SERVER not found

    Obviously this is not mission critical...I will rebuild again if I have to. But that was a lot of work recreating it. We are currently back on the old server which has never had one issue. Even compressing old files (which NO I will not do again LOL).

    Of course not 100% sure compress caused it but it is odd that it started right after that.

    Friday, August 5, 2016 8:01 PM

All replies

  • Hi Tony

    Are you able to bring SQL server up and running first? It seems that SQL itself is not available.


    Thanks
    Mohit

    Saturday, August 6, 2016 6:34 AM
  • Yes, Mohit.

    Tried to attach a Screenshot but apparently my account has not been verified yet.

    I am able to bring up: MS SQL Server Management Studio Express 9.0.5000

    Monday, August 8, 2016 3:51 PM
  • Source: Windows SS Service

    Category: Gatherer

    Event id: 2424

    The update cannot be started because the contenet sources cannot be accessed.

    Todays repeated error.

    Monday, August 8, 2016 4:06 PM
  • Hi Tony

    Can you un-compress directory C:\Program Files\Common Files\Microsoft\Web Server Extensions\12 and then give server a reboot. Let us know any error messages after this.


    Thanks
    Mohit

    Monday, August 8, 2016 5:09 PM
  • Thanks, Mohit.

    I ran: Compact /u /s

    It did not uncompress everything, although it did do quite a few. Most of the still compressed files in there are 8-10 years old.

    I think this might be the most telling current error from the System log:

    Source W3SVC Event id: 1057

    The identity of application pool 'Sharepoint Central Admin v3' is invalid so the WWW publishing service cannot create a worker process. Therefore the ap pool has been disabled.

    Most of the application log errors are from 'Gatherer' id 10036

    Code 2812 occured 1 time

    Could not find procedure dbo.Profile_GetAliasList

    Also

    Source mssqlserver Event id 18456

    Login failed for user 'NT Authority\System'

    Monday, August 8, 2016 8:59 PM
  • Hi Tony

    It seems that login process is not working. You have many errors related to the same. 

    Login failed for user ". Not associated with a trusted SQL server connection ID 18452

    Login failed for user 'NT Authority\System'

    The identity of application pool 'Sharepoint Central Admin v3' is invalid so the WWW publishing service cannot create a worker process. Therefore the ap pool has been disabled.This is weird as some of these accounts are system accounts.

    Please check this event once for mssqlserver error:

    http://stackoverflow.com/questions/24822076/sql-server-login-error-login-failed-for-user-nt-authority-system/24822077

    Do you have DC installed on this server or its on another server? Also how are you logging in, using a local account or domain account.

    Also run this command SFC /verifyonly, and let us know the results, if you see any errors.


    Thanks
    Mohit


    • Edited by mohit.goyal Tuesday, August 9, 2016 4:38 AM
    Tuesday, August 9, 2016 4:21 AM
  • Went to SQL M-Studio. NT Authority\System is already listed. Server Roles> sysadmin assigned. Public is not an option as seen on the link you posted.

    This server is a BDC.

    Logging in as Domain Admin.

    SFC /verifyonly would not run. It kept returning as if I were doing a /?. So I just went ahead and did a SCANNOW. Reboot. No change.

    Then I went to IIS (per another link I found) > App Pools > SP Cent Admin> Prop> Identity. Switched to Predefind > Network Service. Restart IIS.

    To my shock and amazement The Central Admin page loaded. However clicking on Ops or App Managment just gives ERROR: unknown error

    Clicking Shared Services takes me to my Search Admin page. Looks like last nights crawl ran fine. The search page loads with no search box.

    App log now filled with WSS Services errors of Insufficient SQL perms. id: 5214 Select permission was denied 'Docs'and other objects.

    I appreciate you trying to help. Is it time to throw in the towel?


    • Edited by Tony Argh Tuesday, August 9, 2016 7:28 PM
    Tuesday, August 9, 2016 7:28 PM
  • Can I backup the SQL DB or the WSS site itself from the working server to the newer (now broken) one?

    Can't really break it worse, as my favorite college teacher used to say. :D

    Tuesday, August 9, 2016 7:54 PM
  • Hi Tony

    This is because it SP is unaware of app pool changes made directly at IIS. If CA is up, try changing web application pool accounts to local system accounts using this method:

    https://technet.microsoft.com/en-in/library/cc263279%28v=office.12%29.aspx?f=255&MSPPError=-2147217396

    Also give the same as dbowner perms on all dbs and securityadmin server role. 

    If nothing works, you can always backup SP content databases and restore on another server.


    Thanks
    Mohit

    Wednesday, August 10, 2016 4:17 AM
  • CA is not up. :(

    Wednesday, August 10, 2016 6:21 PM
  • Thanks for trying to help, Mohit. I am just going to uninstall the whole shebang and start over.

    Wish I could mark an An swer for you! :D

    Wednesday, August 10, 2016 7:47 PM
  • Hi Tony

    Sorry, I wish I could help. Some times you need more in-person analysis than forums. :(


    Thanks
    Mohit


    • Edited by mohit.goyal Thursday, August 11, 2016 4:17 AM
    Thursday, August 11, 2016 4:16 AM