none
Edge server 2010 _ single user is not able to receive email from external domains RRS feed

  • Question

  • Hi There,

    We have Exchange 2010 Edge server and only one single user "username@domain.com" not able to receive email from external domains.

    Error message copied from Event log:
    recipient with routing address "username@domain.com" from the Active Directory failed with data validation error. The detail of the error is Microsoft.Exchange.Data.Directory.Recipient.NonUniqueProxyAddressError

    Test-EdgeSynchronization -VerifyRecipient "Username@domain.com"
    SyncStatus : Inconclusive
    RecipientStatus : NotSynchronized - More than one recipient found in target Edge Server and may cause NDR on Edge server. RecipientStatus.ConflictO

    1. We have used LPD.exe tool and did not find any duplicate email address in AD.
    2. Also checked in through adsiedit.msc and found no duplicate email address.

    After we modified the email address of that user "username1@domain.com"  that works fine, but if I modify it back to old email address issues again reoccur.

    guys please help, I believe there is a stale entry in Edge server which is creating the issue, but we are unable to locate it and remove that.


    Tuesday, December 13, 2016 9:58 AM

All replies

  • Hi,

    try get-recipient *Username@domain.com*

    This cmdlet will find all recipients with required address.

    Tuesday, December 13, 2016 10:13 AM
  • is there a disabled account with the affected email address in your AD?
    Tuesday, December 13, 2016 2:32 PM
  • Hi Magudeeswaran,

    If all above suggestion cannot resolve the issue, I recommend you remove the current edge subscription and recreate it, then force EdgeSync synchronization via the following command and check the result:

    Start-EdgeSynchronization -Server HubServer -TargetServer EdgeServer -ForceFullSync

    Best Regards,


    Niko Cheng
    TechNet Community Support


    Please remember to mark the replies as answers.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, December 14, 2016 10:01 AM
    Moderator
  • is there a disabled account with the affected email address in your AD?
    No
    Thursday, December 22, 2016 8:37 AM
  • Hi Magudeeswaran,

    If all above suggestion cannot resolve the issue, I recommend you remove the current edge subscription and recreate it, then force EdgeSync synchronization via the following command and check the result:

    Start-EdgeSynchronization -Server HubServer -TargetServer EdgeServer -ForceFullSync

    Best Regards,


    Niko Cheng
    TechNet Community Support


    Please remember to mark the replies as answers.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    This is what I tried long back and there was no error returned by this command.

    Thursday, December 22, 2016 8:38 AM