locked
Service Registration Is Missing Or Corrupt. RRS feed

  • Question

  • I hadn't used my laptop 8.1 for a couple of weeks and then went to use it and couldn't get the office apps to work. After researching for hours on line I ran a trouble shoot report.

    It came up with the message that the Service Registration is Missing Or Corrupt. But no message on how to fix it. What do I do?

    Wednesday, September 17, 2014 8:22 AM

All replies

  • Same here on Windows 10
    Tuesday, June 23, 2015 8:49 AM
  • Same issue on Win10...
    Friday, August 7, 2015 12:08 AM
  • I had a similar issue in Win 8.1 and I was hopping Win 10 will fixed but not. In my case windows freeze for a few seconds every 15 seconds. really annoy.

    I found the fix below:

    https://support.microsoft.com/en-us/gp/windows-update-issues?wa=wsignin1.0

    But I need to run it every time I start windows to fix the issue again and again. Is any more permanent solution out there?

    Saturday, August 29, 2015 11:16 PM
  • same issue on Windows 7 . Seems to start after SP 1 is installed . Updates worked just fine till then . Now nothing . Got 26 installed . then nothing .
    Wednesday, February 3, 2016 8:27 PM
  • I was able to get a few updates then Windows Update (WU) would hang. I ran the Fixit tool and the same message calliekt1960 got. I have a feeling I am going to have to follow some or most of the steps the first past of FixIt recommended. Ugh.
    Saturday, May 14, 2016 1:51 PM
  • Same here on Windows 10

    • Proposed as answer by franclim50 Thursday, December 21, 2017 4:27 PM
    Wednesday, June 15, 2016 11:55 AM
  • troubleshooter said they fixed it but that's a lie

    Friday, July 22, 2016 8:07 AM