none
exchange server 2007 から exchange Server 2010へのデータベース移動 RRS feed

  • Question

  • 開発環境で、以下のサーバを立てています。
    サーバPC1台目:ドメインコントローラサーバ、Windows Server 2008 R2
    サーバPC2台目:Exchange2007サーバ、Windows Server 2008 R2、Exchange Server 2007 SP2
    サーバPC3台目:exchange2010サーバ、Windows Server 2008 R2、Exchange Server 2010

    1台目と2台目の構成時では、クライアントPCでOutlookを使用すると当然2台目のExchangeサーバにアクセスします。
    今後、Exchangeサーバのバージョンアップをしたいので、3台目として、2010をインストールしました。

    メールボックスはインストール時に出来上がっていて、アカウント名もActiveDirectoryとの関連で見えたのですが、クライアントPCでOutlookのメールアカウントを新規に作成しても
    新しいExchange2010を見ようとはしません。

    以下の質問をさせていただきます。

    ①Outlookでメール設定をするときに、3台目(つまりExchange2010)のサーバ名を指定しても、問題なくアクセスしたいのですが設定方法が分かりません。
    ②2台目のメールボックスおよびパブリックフォルダのデータベースを3台目のExchange2010に移動したいのですが、移動方法が分かりません。コマンドレットでの実施でしょうか??

    ど素人同様に試験を実施していますので、知識が非常に乏しいです。
    ご教示のほど、よろしくお願いいたします。

    Thursday, January 7, 2010 12:07 PM

Answers

  • 島根の星さん、

    ~~
    メールボックスはインストール時に出来上がっていて、アカウント名もActiveDirectoryとの関連で見えたのですが、
    クライアントPCでOutlookのメールアカウントを新規に作成しても新しいExchange2010を見ようとはしません。
    ~~
    このあたり どういう意図だったのかよくわかりませんが、、、

    Exchange Server 2007 側に 既にメールボックスがある既存ユーザを Exchange Server 2010へ移行するという事で
    間違いありませんでしょうかね?


    何はともあれ、Exchange Server 2010をインストールしているサーバを操作してください。

    1. "Exchange Management Console"を起動します。
    Exchange Server 2007で言うところの「Exchange管理コンソール」です。
    Exchange Server 2007と同様に起動できます。

    2. [Microsoft Exchange]-[Microsoft Exchange On-Premise]-[受信者の構成]-[メールボックス] と展開します。
    既定では、各ユーザのメールボックスがどのサーバの℃のデータベースにあるかが表示されていませんので、
    右ペインの「表示>」から「列の追加/削除」を選択して「データベース」列を追加してください。
    表示されたデータベース名が、おそらく すべて Exchange 2007のファイル名になっていると思います。

    ※ Exchange Server 2010のデータベースは[組織の構成]-[メールボックス]で確認できます。
    パブリックフォルダデータベースが見当たらなかったら作成してください。

    3. メールボックスを移動したいユーザ名を選択して右クリックし、「ローカル移動要求の新規作成」を選択します。
    後は見たまま操作してください。 Exchange 2010のメールボックスデータベースを指定します。

    4. 移動要求を作成すると、[受信者の構成]-[移動要求]のところに状態が表示されます。
    「完了」のステータスになるまで待ってください。
    なお、移動中はそのユーザアカウントはOutlookなどでメールを送受信してはいけません。
    Outlookを閉じておくことが推奨されます。
    ※ Exchange 2010同士間の移動時は問題ない模様ですが、それ以前のバージョン間の移動は移動中のメール操作に対応できません。

    5. 完了になった後、ユーザのOutlookを起動し直します。
    きっと多分 あら不思議 自動的に Exchange 2010を参照しています。

    6. このままだと移動したユーザは空のパブリックフォルダを見る羽目になるので、
    パブリックフォルダのレプリケーションを実施します。
    ちょっと今画面が見れないので 正確性を欠きますが、 Exchange Server 2007側を操作します。
    「Exchange 管理コンソール」を起動し、[ツールボックス]の中に「パブリックフォルダ管理ツール」があると思うのでそれを起動します。

    パブリックフォルダの フォルダ名が見えると思いますので、最上位のフォルダで右クリックからプロパティを開きます。
    多分「レプリケーション」か「複製」か「レプリカ」的な名前のタブがあると思いますので、そこを開きます。
    多分 Exchange 2007のパブリックフォルダデータベースしか表示されていないので、
    「追加」ボタンをクリックして Exchange Server 2010のパブリックフォルダデータベースを選択します。
    すべてのフォルダで同じ事をやってください。

    ※ もし手順2の途中で Exchange 2010のパブリックフォルダデータベースを手動で作ったとしたら、
    Exchange 2010のメールボックスデータベースのユーザの参照するパブリックフォルダデータベースが指定されていないかもしれません。
    データベースのプロパティを開いて設定してください。

    7. 先ほどの移動したユーザでパブリックフォルダがだんだんと見えてきたりするのではないでしょうかね???
    データ量や複製の設定によると思いますが、じょじょに複製されてきて見えるようになると思いますよ。えぇ。
    見えてこなかったら 済みません。



    Thursday, January 7, 2010 1:26 PM
  • SHIMSOFT 様

    いつも的確なアドバイスをいただきまして、本当にありがとうございます。

    私の質問が悪く申し訳ございませんでした。SHIMSOFT様のおっしゃる通り
    『Exchange Server 2007 側に 既にメールボックスがある既存ユーザを Exchange Server 2010へ移行する』という内容で
    間違いありません。

    詳細なアドバイスの通りに実施しましたところ、無事に反映されました。

    これにて、本質問は解決となります。
    この質問を閲覧されている方にもご活用されるよう、以下の情報を記載させていただきます。

    Outlook2007では、メールやり取りとパブリックフォルダ読み書きともに正常に稼働しました。
    しかし、Outlook2003(もしかするとoutlook2003以前を含むかもしれません)については、
    Outlookを起動するとエラー表示されて、勝手に終了されてしまいます。
    これの解決方法については、なんとSHIMSOFT様の質問内容にありました。

    http://social.technet.microsoft.com/Forums/ja-JP/exchangeserver2010ja/thread/67b12c3f-55ca-4145-9244-d1a3a1b60bad

    皆様ご活用ください。

    ありがとうございました!!
    Friday, January 8, 2010 7:23 AM

All replies

  • 島根の星さん、

    ~~
    メールボックスはインストール時に出来上がっていて、アカウント名もActiveDirectoryとの関連で見えたのですが、
    クライアントPCでOutlookのメールアカウントを新規に作成しても新しいExchange2010を見ようとはしません。
    ~~
    このあたり どういう意図だったのかよくわかりませんが、、、

    Exchange Server 2007 側に 既にメールボックスがある既存ユーザを Exchange Server 2010へ移行するという事で
    間違いありませんでしょうかね?


    何はともあれ、Exchange Server 2010をインストールしているサーバを操作してください。

    1. "Exchange Management Console"を起動します。
    Exchange Server 2007で言うところの「Exchange管理コンソール」です。
    Exchange Server 2007と同様に起動できます。

    2. [Microsoft Exchange]-[Microsoft Exchange On-Premise]-[受信者の構成]-[メールボックス] と展開します。
    既定では、各ユーザのメールボックスがどのサーバの℃のデータベースにあるかが表示されていませんので、
    右ペインの「表示>」から「列の追加/削除」を選択して「データベース」列を追加してください。
    表示されたデータベース名が、おそらく すべて Exchange 2007のファイル名になっていると思います。

    ※ Exchange Server 2010のデータベースは[組織の構成]-[メールボックス]で確認できます。
    パブリックフォルダデータベースが見当たらなかったら作成してください。

    3. メールボックスを移動したいユーザ名を選択して右クリックし、「ローカル移動要求の新規作成」を選択します。
    後は見たまま操作してください。 Exchange 2010のメールボックスデータベースを指定します。

    4. 移動要求を作成すると、[受信者の構成]-[移動要求]のところに状態が表示されます。
    「完了」のステータスになるまで待ってください。
    なお、移動中はそのユーザアカウントはOutlookなどでメールを送受信してはいけません。
    Outlookを閉じておくことが推奨されます。
    ※ Exchange 2010同士間の移動時は問題ない模様ですが、それ以前のバージョン間の移動は移動中のメール操作に対応できません。

    5. 完了になった後、ユーザのOutlookを起動し直します。
    きっと多分 あら不思議 自動的に Exchange 2010を参照しています。

    6. このままだと移動したユーザは空のパブリックフォルダを見る羽目になるので、
    パブリックフォルダのレプリケーションを実施します。
    ちょっと今画面が見れないので 正確性を欠きますが、 Exchange Server 2007側を操作します。
    「Exchange 管理コンソール」を起動し、[ツールボックス]の中に「パブリックフォルダ管理ツール」があると思うのでそれを起動します。

    パブリックフォルダの フォルダ名が見えると思いますので、最上位のフォルダで右クリックからプロパティを開きます。
    多分「レプリケーション」か「複製」か「レプリカ」的な名前のタブがあると思いますので、そこを開きます。
    多分 Exchange 2007のパブリックフォルダデータベースしか表示されていないので、
    「追加」ボタンをクリックして Exchange Server 2010のパブリックフォルダデータベースを選択します。
    すべてのフォルダで同じ事をやってください。

    ※ もし手順2の途中で Exchange 2010のパブリックフォルダデータベースを手動で作ったとしたら、
    Exchange 2010のメールボックスデータベースのユーザの参照するパブリックフォルダデータベースが指定されていないかもしれません。
    データベースのプロパティを開いて設定してください。

    7. 先ほどの移動したユーザでパブリックフォルダがだんだんと見えてきたりするのではないでしょうかね???
    データ量や複製の設定によると思いますが、じょじょに複製されてきて見えるようになると思いますよ。えぇ。
    見えてこなかったら 済みません。



    Thursday, January 7, 2010 1:26 PM
  • SHIMSOFT 様

    いつも的確なアドバイスをいただきまして、本当にありがとうございます。

    私の質問が悪く申し訳ございませんでした。SHIMSOFT様のおっしゃる通り
    『Exchange Server 2007 側に 既にメールボックスがある既存ユーザを Exchange Server 2010へ移行する』という内容で
    間違いありません。

    詳細なアドバイスの通りに実施しましたところ、無事に反映されました。

    これにて、本質問は解決となります。
    この質問を閲覧されている方にもご活用されるよう、以下の情報を記載させていただきます。

    Outlook2007では、メールやり取りとパブリックフォルダ読み書きともに正常に稼働しました。
    しかし、Outlook2003(もしかするとoutlook2003以前を含むかもしれません)については、
    Outlookを起動するとエラー表示されて、勝手に終了されてしまいます。
    これの解決方法については、なんとSHIMSOFT様の質問内容にありました。

    http://social.technet.microsoft.com/Forums/ja-JP/exchangeserver2010ja/thread/67b12c3f-55ca-4145-9244-d1a3a1b60bad

    皆様ご活用ください。

    ありがとうございました!!
    Friday, January 8, 2010 7:23 AM
  • こんにちは、フォーラムオペレーターの三沢健二です。

    SHIMSOFT さん、ご丁寧な回答ありがとうございます。

    島根の星 さん、結果のご報告ありがとうございます。

    それでは、案内いただいた内容で解決できたとの事ですので、私の方で [回答としてマーク] のチェックを付けさせていただきますね。


    今後とも TechNet Forum をよろしくお願いします。

    ______________________________________
    マイクロソフト株式会社 フォーラム オペレーター 三沢健二

    Tuesday, February 2, 2010 8:38 AM
    Moderator