locked
Error installing MSI RRS feed

  • Question

  • Hello, I am having a problem getting one program that we use in house to install. The file is a .msi file and I have it set with the msiexec command that I can use to install the program using the /quiet function and I keep getting a return code of 1603 at the end of my deployment. Other msi files install just fine using the same commands I can run from the command prompt. I am stumped. I downloaded trace32 to see if I can find the problem but the only thing I get is that the program returned an unexpected return code: 1603. I have the pre-requisites for the program installed with it's own Install Application task sequence, and even a reboot to ensure that it was installed like it should and still get the error. This is the last step I have to get past so I can use the deployment completely.

    Thanks

     
    Monday, September 19, 2016 7:09 PM

All replies

  • Are you able to manually run the MSI install through command line exactly as you have it in MDT?  Have you verified either through the documentation for the Application or use of ORCA that the command line switches you are using are valid?
    Monday, September 19, 2016 7:27 PM
  • I have ran it command line after deployment exactly like it is in MDT and it installs correctly. I just had someone in the office suggest to try and install using a run command line task sequence since it will install that way to see if it works or not.

    • Edited by pickeringw Monday, September 19, 2016 7:35 PM
    Monday, September 19, 2016 7:35 PM
  • Try doing some logging of the install. Something like 

    Msiexec /i blah.msi /lvx* %LogDir%\blah.log


    Many questions such as where do I find logs and what logs are interesting are found in: MDT TechNet Forum - FAQ & Getting Started Guide Please take the time to read it. Also if you don't post logs your problem won't be easily solved.

    Monday, September 19, 2016 9:47 PM
  • Well, I finally found out what was going on. apparently this app needs to be pretty much the final thing that is installed using MDT. It works like a charm now, thanks for the help with it. 
    Tuesday, September 20, 2016 11:53 AM