Exchange 2010 received message problems RRS feed

  • Question

  • Hello,

    I really need help because didnt know what to do with my exchange 2010 server. I have identified few of domains I

    cant receive message from. I mean logs show that message is quered but it did not reach the users mailbox.

    I'll try to give all the information about my infrostructure.

    I have two servers connected to the cluster. My DC and Exchange servers are Hyper-V virtual servers with Windows

    Server 2008 R2 operating system. All the system is firewalled with fortigate 60C firewall. All spam and mail

    filtering is disabled on it. All firewalls are disabled on both servers. My exchange server have all main exchange

    server roles installed. I have no edge server.

    Few days ago I recognised that mails from some domains, cant reach my domain. After some anallysis I find that

    thease mails reach my exchange server but I dont know why they didnt fall in to the users mailbox. Users cant see

    them. I have looked up throught the message flow log and there is the line:

    <8235D40BC99E1F46A7D7C0F391107CEA47FE53FF @ SENDERSDOMAIN. DM> Queued mail for delivery;250 2.6.0

    <8235D40BC99E1F46A7D7C0F391107CEA47FE53FF @ SENDERSDOMAIN. DM> Queued mail for


    log finishes. I dont know where to look for the problem. I think my server received that message but cant direct

    them to the users mailbox.

    Please guys, help me. I'll be fired :)

    Please guys, help me. I'll be fired :)

    Saturday, February 23, 2013 7:29 AM


  • You can see from the agent log that Sender ID Agent is causing this issue. I assume you have configured this and all is working now.


    Monday, February 25, 2013 8:59 AM

All replies

  • & check.

    Check queue viewr & see what the reason it states.

    Also look at the events in MT.

    If you have any antispam agents on Exch make sure they are disabled.  Run Get-Transportagent &


    • Edited by Sukh828 Sunday, February 24, 2013 12:50 AM
    Sunday, February 24, 2013 12:47 AM
  • Thanks for your reply,

    I have checked the queue viewer but i see nothing, or maybe I have no experiance to see it :( Then I'm opening the queue viewer I have no data on it, so I have pushed the connect to server button...It founds my server, I pushed on it, but I got no info after I filtered the data. Looks like it didnt connect :(

    Events on MT? there I can found it. Sorry I'm very new on exchange, just 2 months I got it.

    Do I need to disable the agent using:

    Set-ContentFilterConfig -Enabled $false

    Sunday, February 24, 2013 8:26 AM
  • I think this would disable anti-spam agents globally (content filter is just one element among others):

    Set-TransportServer –Identity 'YourServerName' –AntispamAgentsEnabled $false


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you.

    Sunday, February 24, 2013 12:54 PM
    1. Have you checked message tracking? What  do the events say?
    2. Did you run Get-Transportagent ? Any Anti-spam agents listed?


    Sunday, February 24, 2013 1:05 PM
  • message tracking didnt find any message that fails. And Event viewer have no logs about that sender.

    What I know and didnt mentioned before, that the sender didnt got any error messages. He think that all users in my domain got his mail.

    Get-transportagent results: 

    Identity                                           Enabled         Priority
    --------                                           -------         --------
    Connection Filtering Agent                    True            1
    Transport Rule Agent                           True            2
    Text Messaging Routing Agent              True            3
    Text Messaging Delivery Agent             True            4
    Content Filter Agent                            False           5
    Protocol Analysis Agent                        True            6
    Sender Id Agent                                 True            7
    Sender Filter Agent                              True            8
    Recipient Filter Agent                          True            9

    Sunday, February 24, 2013 6:10 PM
  • What does message tracking show ? Dont look for failed messages , look for all in that time frame.The message tracking will show events that took place. I wasn't referring to the Event Viewer.

    Also have a look at the Agent logs.


    Sunday, February 24, 2013 6:24 PM
  • message tracking found thease messages. Here I see event details:

    Delivery Report for 

    2/22/2013 1:25 PM

    The message couldn't be

    250 2.6.0
    Queued mail for delivery

    How can I see Agent logs?

    Sunday, February 24, 2013 8:05 PM
  • Can you do the below and then ask the sender to send again?

    Set-ContentFilterConfig -BypassedSenders Sender@sender.com

    Agent logging http://technet.microsoft.com/en-us/library/bb124795(v=exchg.141).aspx


    Sunday, February 24, 2013 8:38 PM
  • I have just did the command you told me, and the sender resends test message, Message fails :(

    this is what the agent log tells:


    sender@domain.com,sender@domain.com;,my@mail.com,1,Sender Id Agent,OnEndOfHeaders,DeleteMessage,,Fail_NotPermitted,sender@domain.com,

    Monday, February 25, 2013 7:06 AM
  • Hi ,

    Please check if configure Sender Filtering for anti-spam.

    Configure Sender Filtering Properties:


    Wendy Liu
    TechNet Community Support

    Monday, February 25, 2013 7:21 AM
  • Thanks to you all guys. I have learned a lot this weekend. Configured spam filter propertly and now everything look ok. Thanks a lot!!!
    Monday, February 25, 2013 8:03 AM
  • You can see from the agent log that Sender ID Agent is causing this issue. I assume you have configured this and all is working now.


    Monday, February 25, 2013 8:59 AM
  • hi

    i have the same probelm here

    where i can check to know that sender ID is causing the problem do you mean from receive connector log file

    please help.

    Tuesday, April 16, 2013 8:26 AM