locked
Using UAG to send Custom Request Headers to Applications RRS feed

  • Question

  • Has anyone been able to successfully pass through custom headers through to Applications?

    I have followed the sample site http://www.pubsub.com/events/26d5a4f80c3ce5c23f8c259c80f8bb49 however when I view the Request variables on the Portal page, the two new custom elements are not present.

    CustomUpdate\WhlFiltAppWrap_HTTP.xml - have added this block in down the bottom

    <APPLICATION>
       <APPLICATION_TYPE>AppLeg</APPLICATION_TYPE>
       <URL>
        <URL_NAME>.*</URL_NAME>
        <ADD>
         <HEADER>
          <NAME>customname</NAME>
          <VALUE encoding="" using_variables="true">Hybrid_WhlStatusFlagX</VALUE>
         </HEADER>
        </ADD>
       </URL>
      </APPLICATION>
      <APPLICATION>
       <APPLICATION_TYPE>AppLeg</APPLICATION_TYPE>
       <URL>
        <URL_NAME>.*</URL_NAME>
        <ADD>
         <HEADER>
          <NAME>CustomHeader2</NAME>
          <VALUE encoding="" using_variables="true">Hybrid_WhlStatusFlagY</VALUE>
         </HEADER>
        </ADD>
       </URL>
      </APPLICATION>

     

    CustomUpdate\External0postpostvalidate.inc (extract)

    SetSessionParamWithType g_cookie,"Hybrid_WhlStatusFlagX","Value","AppLegacy"

    SetSessionParamWithType g_cookie,"Hybrid_WhlStatusFlagY","Value2","AppLegacy"

     

    I have tried both the Application name and the Trunk name in the 4th parameter (above).

    Any ideas?

    Wednesday, February 23, 2011 5:13 AM

Answers