none
Sharepoint 2013 On Premise WFE1 Unable to view excel file in browser RRS feed

  • Question

  • Hi, 

    Good day. I am new to the sharepoint. Currently I have an existing sharepoint farm with 2 WFE (WFE1 & WFE2), 1 App, and 1 SQL Servers, using Network Load Balancing feature with 1 WFE as primary role, another as backup role.

    My sharepoint site is tested all working so far.

    Besides, I have setup my sharepoint site with https secure connection as well, and tested workable.

    However, there is 1 issue i am currently facing in my WFE1 server, where using WFE1 as primary role, I am not able to view my excel files in browsers, whereas there is no issue to view excel file in browsers when using WFE2 as primary.

    All my sharepoint servers are currently installed and running with CU update of August (KB4484485)

    Hi, 

    Good day. I am new to the sharepoint. Currently I have an existing sharepoint farm with 2 WFE (WFE1 & WFE2), 1 App, and 1 SQL Servers, using Network Load Balancing feature with 1 WFE as primary role, another as backup role.

    My sharepoint site is tested all working so far.

    Besides, I have setup my sharepoint site with https secure connection as well, and tested workable.

    However, there is 1 issue i am currently facing in my WFE1 server, where using WFE1 as primary role, I am not able to view my excel files in browsers, whereas there is no issue to view excel file in browsers when using WFE2 as primary.


    Appreciate if have any ideas to fix this issue.

    Steps has been taken so far to try fix this but still no luck

    1. Restarted Excel Calculation Service in App server, no luck
    2. IISReset WFE1, APP Server, no luck
    3. Checked Excel Service Application is assigned to my application proxy
    4. Checked both my WFE1 & WFE2 IIS's identity is using my domain admins account, with permission granted, however WFE1 still getting the issue, where no problem with using my WFE2.
    5. Restarted my WFE1, App Server, but still getting the same issue.
    6. Lastly, I do tried remove and resetup Excel Service Application in my App server, and still no luck WFE1 still getting the same issue.









    Sunday, October 11, 2020 10:17 AM

All replies

  • Hi, 

    Good day. I am new to the sharepoint. Currently I have an existing sharepoint farm with 2 WFE (WFE1 & WFE2), 1 App, and 1 SQL Servers, using Network Load Balancing feature with 1 WFE as primary role, another as backup role.

    My sharepoint site is tested all working so far.

    Besides, I have setup my sharepoint site with https secure connection as well, and tested workable.

    However, there is 1 issue i am currently facing in my WFE1 server, where using WFE1 as primary role, I am not able to view my excel files in browsers, whereas there is no issue to view excel file in browsers when using WFE2 as primary.

    All my sharepoint servers are currently installed and running with CU update of August (KB4484485)

    Hi, 

    Good day. I am new to the sharepoint. Currently I have an existing sharepoint farm with 2 WFE (WFE1 & WFE2), 1 App, and 1 SQL Servers, using Network Load Balancing feature with 1 WFE as primary role, another as backup role.

    My sharepoint site is tested all working so far.

    Besides, I have setup my sharepoint site with https secure connection as well, and tested workable.

    However, there is 1 issue i am currently facing in my WFE1 server, where using WFE1 as primary role, I am not able to view my excel files in browsers, whereas there is no issue to view excel file in browsers when using WFE2 as primary.


    Appreciate if have any ideas to fix this issue.

    Steps has been taken so far to try fix this but still no luck

    1. Restarted Excel Calculation Service in App server, no luck
    2. IISReset WFE1, APP Server, no luck
    3. Checked Excel Service Application is assigned to my application proxy
    4. Checked both my WFE1 & WFE2 IIS's identity is using my domain admins account, with permission granted, however WFE1 still getting the issue, where no problem with using my WFE2.
    5. Restarted my WFE1, App Server, but still getting the same issue.
    6. Lastly, I do tried remove and resetup Excel Service Application in my App server, and still no luck WFE1 still getting the same issue.









    Below here are the ULS log found in my WFE1 server

    ULS Log 1
    ServerSession.ProcessServerSessionException: An exception during ExecuteWebMethod has occurred for server: http://SHAREPOINTCA:32843/76e63675276b41768f66a12df79c8378/ExcelService*.asmx, method: GetHealthScore, ex: Microsoft.Office.Excel.Server.CalculationServer.Proxy.ServerSessionException: We don't know what happened, but something went wrong. ---> System.ServiceModel.Security.MessageSecurityException: An unsecured or incorrectly secured fault was received from the other party. See the inner FaultException for the fault code and detail. ---> System.ServiceModel.FaultException: An error occurred when verifying security for the message.     -
     -- End of inner exception stack trace ---    Server stack trace:     
     at System.ServiceModel.Channels.SecurityChannelFactory`1.SecurityRequestChannel.ProcessReply(Message reply, SecurityProtocolCorrelationState correlationState, TimeSpan timeout)    
     at System.ServiceModel.Channels.SecurityChannelFactory`1.SecurityRequestChannel.Request(Message message, TimeSpan timeout)    
     at System.ServiceModel.Dispatcher.RequestChannelBinder.Request(Message message, TimeSpan timeout)    
     at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)    
     at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)    
     at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)    Exception rethrown
     at [0]:     
     at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)    
     at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)    
     at Microsoft.Office.Excel.Server.CalculationServer.Proxy.IExcelServiceSoap.GetHealthScore()    
     at Microsoft.Office.Excel.Server.CalculationServer.Proxy.ServerSession.GetServerHealthScore()    
     at Microsoft.Office.Excel.Server.CalculationServer.Proxy.ServerSession.<>c__DisplayClass1d9.<ExecuteWithSecurityContext>b__1d8()    
     at Microsoft.Office.Excel.Server.CalculationServer.Proxy.ServerSession.ExecuteWithSecurityContext(Boolean forceRevert, CoreWebMethod coreWebMethod, CommandParameter parameter)    
     at Microsoft.Office.Excel.Server.CalculationServer.Proxy.ServerSession.GetHealthScoreCallback(Object state)     - -- End of inner exception stack trace ---.

    ULS Log 2

    There was an error in communicating with Excel Calculation Services http://SHAREPOINTCA:32843/76e63675276b41768f66a12df79c8378/ExcelService*.asmx exception: We don't know what happened, but something went wrong. 

    Sunday, October 11, 2020 10:22 AM
  • hi, is there any advise or solution which can fix this issue?

    Sunday, October 18, 2020 3:03 AM