none
DPM 2012 - Can't Create New-DPMRecoveryOption - The recovery point location that you have passed is invalid. RRS feed

  • Question

  • I am trying to write a script to export a Hyper-V backup from my DPM server (DPM 2012 - no service pack).  It is my understanding that, in order to do this, I need to create a New-DPMRecoveryOption (which is then passed to Recover-RecoverableItem to export the backup).  When I try to create a New-DPMRecoveryOption, I get the following error:

    New-DPMRecoveryOption : The recovery point location that you have passed is invalid. Please try again with a different value. (ID: 31050)
    At C:\Users\administrator\Desktop\backup-export.ps1:15 char:29
    + $ROP = New-DPMRecoveryOption <<<<  -TargetServer host01.domain.local -RecoveryLocation CopyToFolder -HyperVDatasource -RecoveryType Recover -TargetLocation "C:\temp"
        + CategoryInfo          : NotSpecified: (:) [New-DPMRecoveryOption], DlsEx
       ception

        + FullyQualifiedErrorId : InvalidRecoveryLocation,Microsoft.Internal.EnterpriseStorage.Dls.UI.Cmdlet.RecoveryCmdLets.NewRecoveryOption

    Here is the statement that is throwing the error:

    $ROP = New-DPMRecoveryOption -TargetServer host01.domain.local -RecoveryLocation CopyToFolder -HyperVDatasource -RecoveryType Recover -TargetLocation "C:\temp"

    I have searched and searched - every blog I come across says that this is the way to do it.  The error isn't very helpful either.  There is no "recovery point location" specified.  There is a recovery location, but according to Microsoft documentation and all of the blogs that I have read, the value that I am providing for this argument is the only value that can be provided when attempting to recover a HyperVDatasource.

    For the -TargetServer argument, I have tried multiple servers (including the local server and invalid server names) but I keep getting the same error.  This leads me to believe that this is not the issue.

    I have confirmed that the -TargetLocation exists.

    The -RecoveryType should be correct - according to Microsoft documentation, the "Recover" value is required for reovering a HyperVDatasource.

    I have tried this on one of our other DPM servers (DPM 2012 SP1) - I get the same exact error.

    I am at my wits end on this issue.  I have been researching for days and cannot find a thing on Google.  When I search the error, I get 4 or 5 results and they are all useless.  What is more frustrating is I'm pretty sure it's something simple that I haven't caught yet.  Any insight would be greatly appreciated.


    • Edited by aeyler Monday, September 2, 2013 7:34 AM
    Monday, September 2, 2013 5:32 AM

Answers

  • OK. I figured out what was happening.  Here is the command that I was using:

    $ROP = New-DPMRecoveryOption -TargetServer host01.domain.local -RecoveryLocation CopyToFolder -HyperVDatasource -RecoveryType Recover -TargetLocation "C:\temp"

    The issue was with the -RecoveryLocation argument.  When I change it from CopyToFolder to AlternateHyperVServer, I no longer get the error.  I have no idea why this is... for multiple reasons:

    1) Every Microsoft resource and (almost) every blog I checked said to use CopyToFolder.

    2) The AlternateHyperVServer option isn't even listed as an option in the Microsoft documentation for the DPM 2012 New-DPMRecoveryOption cmdlet[1]. This documentation also says to use CopyToFolder.

    I finally got lucky and ran across this blog post[2] today which has a script that uses AlternateHyperVServer instead of CopyToFolder. The blog post is actually about DPM 2010. This makes me wonder if AlternateHyperVServer is being deprecated since I never saw it in 2012 documentation.

    So, here is my new command that works:

    $rop = New-DPMRecoveryOption -Targetserver host01.domain.local -RecoveryLocation AlternateHyperVServer -HyperVDatasource -RecoveryType Recover -TargetLocation "C:\Users\aeyler\Desktop"

    TechNet won't let me embed links because my account "isn't verified" and they offer no instructions on how to verify my account. So, here are the URLs:

    [1]: http://technet.microsoft.com/en-us/library/hh881592.aspx

    [2]: http://msgroups.net/microsoft.public.dataprotectionmanager/dpm-2010-powershell-sc/40111





    • Edited by aeyler Monday, October 21, 2013 10:22 PM
    • Marked as answer by aeyler Monday, October 21, 2013 10:22 PM
    Monday, October 21, 2013 10:19 PM