none
Windows server 2016 NPS not sending Accounting-response msgs

    Question

  • Hi all,

    I'm having an issue with NPS Radius accounting for a RRAS PEAP-TLS connection.

    Authentication works fine but when accounting should start the only thing I receive are 4 Accounting-Request packets and can't see any Accounting-Response packets.

    Following RFC2866 this is normal behaviour if it fails to record the accounting packet:

    << Upon receipt of an Accounting-Request, the server MUST transmit an

          Accounting-Response reply if it successfully records the
          accounting packet, and MUST NOT transmit any reply if it fails to
          record the accounting packet.

    >>

    Going of this I looked at the accounting config on NPS, which was set to SQL logging. Which is working fine.

    To be on the safe side I just went back to local file logging.

    This still works as expected.


    <Event><Timestamp data_type="4">07/05/2018 14:10:02.265</Timestamp><Computer-Name data_type="1">NPS1</Computer-Name><Event-Source data_type="1">IAS</Event-Source><NAS-Identifier data_type="1">VPN1</NAS-Identifier><Service-Type data_type="0">2</Service-Type><Framed-Protocol data_type="0">1</Framed-Protocol><NAS-Port data_type="0">410</NAS-Port><NAS-Port-Type data_type="0">5</NAS-Port-Type><Tunnel-Type data_type="0">9</Tunnel-Type><Tunnel-Medium-Type data_type="0">1</Tunnel-Medium-Type><Called-Station-Id data_type="1">x.x.x.x</Called-Station-Id><Tunnel-Server-Endpt data_type="1">x.x.x.x</Tunnel-Server-Endpt><Calling-Station-Id data_type="1">x.x.x.x</Calling-Station-Id><Tunnel-Client-Endpt data_type="1">x.x.x.x</Tunnel-Client-Endpt><Framed-MTU data_type="0">1400</Framed-MTU><Class data_type="1">311 1 x.x.x.x 07/05/2018 12:09:13 11</Class><Acct-Session-Id data_type="1">116</Acct-Session-Id><User-Name data_type="1">Username@domain</User-Name><Framed-IP-Address data_type="3">x.x.x.x</Framed-IP-Address><Port-Limit data_type="0">1</Port-Limit><Acct-Multi-Session-Id data_type="1">350</Acct-Multi-Session-Id><Acct-Link-Count data_type="0">1</Acct-Link-Count><Event-Timestamp data_type="4">07/05/2018 12:09:47</Event-Timestamp><Acct-Authentic data_type="0">3</Acct-Authentic><Acct-Status-Type data_type="0">1</Acct-Status-Type><Client-IP-Address data_type="3">x.x.x.x</Client-IP-Address><Client-Vendor data_type="0">311</Client-Vendor><Client-Friendly-Name data_type="1">VPN1</Client-Friendly-Name><Proxy-Policy-Name data_type="1">Virtual Private Network (VPN) Connections</Proxy-Policy-Name><Acct-Interim-Interval data_type="0">60</Acct-Interim-Interval><MS-RAS-Vendor data_type="0">311</MS-RAS-Vendor><MS-RAS-Version data_type="1">MSRASV5.20</MS-RAS-Version><MS-RAS-Correlation-ID data_type="1">{68CA818A-185C-3906-273D-31FBF10DB1AF}</MS-RAS-Correlation-ID><MS-Network-Access-Server-Type data_type="0">2</MS-Network-Access-Server-Type><MS-RAS-RoutingDomain-ID data_type="1">{00000000-0000-0000-0000-000000000000}</MS-RAS-RoutingDomain-ID><Packet-Type data_type="0">4</Packet-Type><Reason-Code data_type="0">9</Reason-Code></Event>

    Any help would be gratefull as i'm at a loss


    Thursday, July 05, 2018 12:41 PM

All replies