none
Receive connector sending bulk emails having issue

    Question

  • Hi All,<o:p></o:p>

    We have an Oracle ERP application which sends out bulk emails, I have created a separate receive connector for this , this application sends our bulk notification to all users, but we have found out after sending 10 to 20 emails it stops sending emails and throws our error<o:p></o:p>

    On the oracle application this is the error which shows on logs <o:p></o:p>

    SMTP transient error: 421 Service not available<o:p></o:p>

    i am really confused of where to start from, is the problem from Oracle side or Exchange side? ,i feel it’s from the exchange side because the same application was working fine when we were in exchange 2010 now we have migrated to exchange 2013.<o:p></o:p>



    TechGUy,System Administrator.

    Monday, December 12, 2016 10:41 AM

Answers

  • Yes, but you can recreate a connector on mailbox server instead.
    • Marked as answer by ITSysGuy Wednesday, December 21, 2016 5:01 PM
    Wednesday, December 14, 2016 11:12 AM
  • If application connects to cas, connector should exist on cas server.
    Then this connector will proxy smtp connections to mailbox's connector, so you should check settings on mailbox server's connector too
    • Marked as answer by ITSysGuy Wednesday, December 21, 2016 5:01 PM
    Wednesday, December 14, 2016 11:52 AM
  • I got an response form the application team,they have confirmed the bulk emails are working fine now,they have set an automated bulk emails which goes every night,it was failing to complete from all these days, after i created the receive connector on the Mailbox server, this issue if resolved now.

    A very big thanks to BearEater and David you too.

    Regards

    TechGuy


    TechGUy,System Administrator.

    • Marked as answer by ITSysGuy Wednesday, December 21, 2016 5:00 PM
    Wednesday, December 21, 2016 5:00 PM

All replies

  • Hi,

    try to increase 'maxinboundconnactionpersource' value on your receive connector. (The MaxInboundConnectionPerSource parameter specifies the maximum number of inbound connections that this Receive connector serves at the same time from a single IP address.)
    Set-ReceiveConnector - Identity YourConnector -MaxInboundConnectionPerSource 200

    Monday, December 12, 2016 10:50 AM
  • Thanks for your reply but when i type Set-ReceiveConnector - Identity YourConnector -MaxInboundConnectionPerSource 200 i get the below screen.


    TechGUy,System Administrator.

    Monday, December 12, 2016 12:10 PM
  • Remove space between '-' and 'Identity', and add "" to connector's name
    Monday, December 12, 2016 12:13 PM
  • now i get the above error although the connector name is right.


    TechGUy,System Administrator.

    Monday, December 12, 2016 12:17 PM
  • Try this : -identity "SERVERNAME\for compass apps exchange 2013"
    Replace SERVERNAME with server's name, where you created this connector
    Monday, December 12, 2016 12:28 PM
  • this worked thanks a lot but how do i check the status now for only that connector is it 

    Get-receiveconnector ConnetorName | fl MaxInboundConnectionPerSource ?


    TechGUy,System Administrator.

    Monday, December 12, 2016 12:47 PM
  • yes, connectorname in form servername\connectorname, or
    get-receiveconnector | ?{$_.name -like '*for compass*'} | select name,MaxInboundConnectionPerSource
    Monday, December 12, 2016 12:50 PM
  • please see that is it ok now?


    TechGUy,System Administrator.

    Monday, December 12, 2016 12:58 PM
  • It is ok if you do not see error during bulk email send
    There is another parameter - MaxInboundConnectionPercentagePerSource, but to be honest- I don't know how MaxInboundConnectionPercentagePerSource and MaxInboundConnectionPerSource correlate with each other. You can try to increase it too.
    Monday, December 12, 2016 1:08 PM
  • Thanks,for your help,will ask the application team to recheck sending email and update you.

    TechGUy,System Administrator.

    Monday, December 12, 2016 2:21 PM
  •  i think i need to make changes also to the timeout session for this connector from that application to the exchnage server,is there any kind of settings for that?because still the issue is not resolved.

    TechGUy,System Administrator.

    Wednesday, December 14, 2016 5:46 AM
  • Yes, there are following parameters:
    ConnectionInactivityTimeout
    ConnectionTimeout
    If you haven't decommissioned  your exchange 2010 server, where it was working, you can check all settings on old receive connector.
    All connector's parameters with description you can find here:
    Set-ReceiveConnector 
    Wednesday, December 14, 2016 9:04 AM
  • HI mate ,

    i also found the bellow link,do i need to make change on the mailbox server ,but my connector are created on CAS server  

     http://www.itsolutionbraindumps.com/2015/11/messageratelimit-on-exchange-2013.html


    TechGUy,System Administrator.

    Wednesday, December 14, 2016 11:02 AM
  • Yes, but you can recreate a connector on mailbox server instead.
    • Marked as answer by ITSysGuy Wednesday, December 21, 2016 5:01 PM
    Wednesday, December 14, 2016 11:12 AM
  • should connector exist on both the CAS and mailbox server the application is connecting to the CAS server?


    TechGUy,System Administrator.

    Wednesday, December 14, 2016 11:21 AM
  • If application connects to cas, connector should exist on cas server.
    Then this connector will proxy smtp connections to mailbox's connector, so you should check settings on mailbox server's connector too
    • Marked as answer by ITSysGuy Wednesday, December 21, 2016 5:01 PM
    Wednesday, December 14, 2016 11:52 AM
  • my connector setting on the mailbox server where the mailbox reside shows like this,is thi setting ok?


    TechGUy,System Administrator.

    Wednesday, December 14, 2016 12:15 PM
  • Try to increase messageratelimit on 'Client proxy %servername%' connector, as it described in article above.
    Wednesday, December 14, 2016 12:29 PM
  • changed it to 800 now lets see.


    TechGUy,System Administrator.

    Wednesday, December 14, 2016 12:56 PM
  • Hi,

    How about the issue after increasing messageratelimit on 'Client proxy %servername%' connector?


    Best Regards,
    David Wang
    TechNet Community Support


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, December 21, 2016 1:40 AM
    Moderator
  • Hi David,

    That did not help too,i opened a case with Microsoft they asked to create the connector on Mailbox server,after doing that, we tested sending out some 200 emails it was working fine,now i have asked the application team to try sending bulk emails,i am still waiting for their full update,once i get an update i will post it here.

    Regards

    TechGuy



    TechGUy,System Administrator.

    Wednesday, December 21, 2016 3:21 AM
  • Glad to hear it.

    Best Regards,
    David Wang
    TechNet Community Support


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, December 21, 2016 5:37 AM
    Moderator
  • I got an response form the application team,they have confirmed the bulk emails are working fine now,they have set an automated bulk emails which goes every night,it was failing to complete from all these days, after i created the receive connector on the Mailbox server, this issue if resolved now.

    A very big thanks to BearEater and David you too.

    Regards

    TechGuy


    TechGUy,System Administrator.

    • Marked as answer by ITSysGuy Wednesday, December 21, 2016 5:00 PM
    Wednesday, December 21, 2016 5:00 PM