none
Unable to see Exchange Online Archive – Autodiscover issue? RRS feed

  • Question

  • Dear All,

    Sorry to put down two issues into one post but I think they may be related…..I want to concentrate on being able to view online archive mailboxes in Outlook 2010 but thought I should also make you aware that our external autodiscover has stopped working……

    Our setup is Windows 2008 R2 & Exchange 2010 (version 14.1 build 218.15). After we installed the original setup back in May 2010 everything was working fine, specifically autodiscovery internally and externally (we run split DNS, internal = company.internal, external = company.co.uk). Some time ago (I can’t remember the exact date) I noticed that the external autodiscovery had stopped working. At this point I wasn’t overly concerned as we were about to install SP1 and also enable online archiving features……I was hoping that the Exchange SP1 may reset the autodiscover virtual directories and basically iron out any existing problems. Although the SP1 upgrade went fine it didn’t sort out the external autodiscover issue. I have since enabled online archive mailboxes for a couple of users and although I can see the online archive mailboxes OK in webmail they don’t show in the full Outlook 2010 client. So, my two issues are:

     

    1.     1. Unable to see online archive mailboxes in Outlook 2010

    2.     2. External autodiscover not working (internal autodiscover working OK)

    The main issue that I would like to get resolved is being able to see the online archive mailboxes. My troubleshooting steps so far for this issue are listed below:

    1. Enabled Online Archive Mailbox via EMC, checked settings - OK
    2. Checked I can see online archive mailbox within OWA – All OK
    3. Setup new Windows 7 VM, connected the Windows 7 VM to the AD domain and installed Outlook 2010 standard using Microsoft Open License key. Setup mail profile using autodiscover settings – All settings downloaded and the profile setup correctly but unable to see online archive mailbox
    4. Ran the Outlook 2010 ‘Test E-Mail Autoconfiguration’ – log results below:

    Attempting URL https://mail.company.co.uk/autodiscover/autodiscover.xml found through SCP

    Autodiscover to https://mail.company.co.uk/autodiscover/autodiscover.xml starting

    Autodiscover to https://mail.company.co.uk/autodiscover/autodiscover.xml succeeded (0x00000000)

     

    Any other help to try and resolve this issue would be greatly appreciated.

     

    Thanks,

     

     

     

    Saturday, September 3, 2011 3:36 PM

All replies

  • External Autodiscover wants to use an A record named autodiscover.company.co.uk assuming your e-mail address is something@company.co.uk, or an SRV record corresponding to company.co.uk.  Every customer of mine has chosen the A record method.

    I doubt that's related to your inablility to see the online archive mailboxes.  I don't have anything to offer on that, sorry.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Sunday, September 4, 2011 4:51 AM
    Moderator
  • Hi,
    Office 2010 Standard Edition does not support Online Archive and that is why you are not able to see the Online Archive in Outlook.
    You need Office 2010 Professional Plus.


    Martina Miskovic
    Sunday, September 4, 2011 8:25 AM
  • OWA will see the online archive even though outlook not showing it.

     


    lasse at humandata dot se, http://anewmessagehasarrived.blogspot.com
    Sunday, September 4, 2011 10:38 AM
  • Just to add the official URL:

    License requirements for Personal Archive and retention policies
    http://office.microsoft.com/en-us/outlook-help/license-requirements-for-personal-archive-and-retention-policies-HA102576659.aspx?redir=0


    MCTS: Messaging | MCSE: S+M
    • Proposed as answer by Jerome Xiong Monday, September 5, 2011 7:24 AM
    Sunday, September 4, 2011 6:27 PM
  • Martina has pinpointed the reason why you don't see your Personal Archive in Outlook. Now your external Autodiscover issue remains.

    A good starting point is to use the Remote Connectivity Analyzer
    https://www.testexchangeconnectivity.com/


    MCTS: Messaging | MCSE: S+M
    Monday, September 5, 2011 1:32 AM
  • Hi Everyone,

    Thank you all for your replies so far.

    I can't believe that you need Office 2010 Professional Plus to view the personal archive! We have obviously purchased Exchange Enterprise CAL's and from my research I knew that you needed Outlook 2010 to view the personal archive but not specifically Outlook 2010 that is part of the Office 2010 Professional Plus package! Is there a technical reason that you are unable to view the personal archive from other versions of Outlook? All seems very odd or is that just me?

    Jon - Below is the results of the remote connectivity analyzer in relation to the external autodiscover issue:

    ExRCA is attempting to test Autodiscover for test@company.co.uk.

    Autodiscover was tested successfully.

    Test Steps

    Attempting each method of contacting the Autodiscover service.

    The Autodiscover service was tested successfully.

    Test Steps

    Attempting to test potential Autodiscover URL https://company.co.uk/AutoDiscover/AutoDiscover.xml

    Testing of this potential Autodiscover URL failed.

    Test Steps

    Attempting to resolve the host name company.co.uk in DNS.

    The host name resolved successfully.

    Additional Details

    IP addresses returned: 213.210.6.59

    Testing TCP port 443 on host company.co.uk to ensure it's listening and open.

    The port was opened successfully.

    Testing the SSL certificate to make sure it's valid.

    The SSL certificate failed one or more certificate validation checks.

    Test Steps

    ExRCA is attempting to obtain the SSL certificate from remote server company.co.uk on port 443.

    ExRCA wasn't able to obtain the remote SSL certificate.

    Additional Details

    The certificate couldn't be validated because SSL negotiation wasn't successful. This could have occurred as a result of a network error or because of a problem with the certificate installation.

    Attempting to test potential Autodiscover URL https://autodiscover.company.co.uk/AutoDiscover/AutoDiscover.xml

    Testing of this potential Autodiscover URL failed.

    Test Steps

    Attempting to resolve the host name autodiscover.company.co.uk in DNS.

    The host name couldn't be resolved.

     Tell me more about this issue and how to resolve it

    Additional Details

    Host autodiscover.company.co.uk couldn't be resolved in DNS InfoDomainNonexistent.

    Attempting to contact the Autodiscover service using the HTTP redirect method.

    The attempt to contact Autodiscover using the HTTP Redirect method failed.

    Test Steps

    Attempting to resolve the host name autodiscover.company.co.uk in DNS.

    The host name couldn't be resolved.

    Tell me more about this issue and how to resolve it

    Additional Details

    Host autodiscover.company.co.uk couldn't be resolved in DNS InfoDomainNonexistent.

    Attempting to contact the Autodiscover service using the DNS SRV redirect method.

    ExRCA successfully contacted the Autodiscover service using the DNS SRV redirect method.

    Test Steps

    Attempting to locate SRV record _autodiscover._tcp.company.co.uk in DNS.

    The Autodiscover SRV record was successfully retrieved from DNS.

    Additional Details

    The Service Location (SRV) record lookup returned host mail.company.co.uk.

    Attempting to test potential Autodiscover URL https://mail.company.co.uk/Autodiscover/Autodiscover.xml

    Testing of the Autodiscover URL was successful.

    Test Steps

    Attempting to resolve the host name mail.company.co.uk in DNS.

    The host name resolved successfully.

    Additional Details

    IP addresses returned: 83.244.149.4

    Testing TCP port 443 on host mail.company.co.uk to ensure it's listening and open.

    The port was opened successfully.

    Testing the SSL certificate to make sure it's valid.

    The certificate passed all validation requirements.

    Test Steps

    ExRCA is attempting to obtain the SSL certificate from remote server mail.company.co.uk on port 443.

    ExRCA successfully obtained the remote SSL certificate.

    Additional Details

    Remote Certificate Subject: CN=mail.company.co.uk, O=mail.company.co.uk, OU=Domain Control Validated, C=GB, Issuer: CN=GlobalSign Domain Validation CA, O=GlobalSign nv-sa, OU=Domain Validation CA, C=BE.

    Validating the certificate name.

    The certificate name was validated successfully.

    Additional Details

    Host name mail.company.co.uk was found in the Certificate Subject Common name.

    Certificate trust is being validated.

    The certificate is trusted and all certificates are present in the chain.

    Test Steps

    ExRCA is attempting to build certificate chains for certificate CN=mail.company.co.uk, O=mail.company.co.uk, OU=Domain Control Validated, C=GB.

    One or more certificate chains were constructed successfully.

    Additional Details

    A total of 1 chains were built. The highest quality chain ends in root certificate CN=GlobalSign Root CA, OU=Root CA, O=GlobalSign nv-sa, C=BE.

    Analyzing the certificate chains for compatibility problems with versions of Windows.

    No Windows compatibility problems were identified.

    Additional Details

    The certificate chain has been validated up to a trusted root. Root = CN=GlobalSign Root CA, OU=Root CA, O=GlobalSign nv-sa, C=BE.

    Testing the certificate date to confirm the certificate is valid.

    Date validation passed. The certificate hasn't expired.

    Additional Details

    The certificate is valid. NotBefore = 6/22/2010 8:17:55 AM, NotAfter = 5/14/2012 2:51:55 PM

    Checking the IIS configuration for client certificate authentication.

    Client certificate authentication wasn't detected.

    Additional Details

    Accept/Require Client Certificates isn't configured.

    Attempting to send an Autodiscover POST request to potential Autodiscover URLs.

    ExRCA successfully retrieved Autodiscover settings by sending an Autodiscover POST.

    Test Steps

    ExRCA is attempting to retrieve an XML Autodiscover response from URL https://mail.company.co.uk/Autodiscover/Autodiscover.xml for user administrator@company.co.uk.

    The Autodiscover XML response was successfully retrieved.

    Additional Details

    Autodiscover Account Settings

    XML response:

    <?xml version="1.0"?>

    <Autodiscover xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">

     <Response xmlns="http://schemas.microsoft.com/exchange/autodiscover/outlook/responseschema/2006a">

     <User>

     <DisplayName>Administrator</DisplayName>

     <LegacyDN>/o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=Administrator</LegacyDN>

     <DeploymentId>9323b4c1-2757-400d-b034-fb741cff70b3</DeploymentId>

     </User>

     <Account>

     <AccountType>email</AccountType>

     <Action>settings</Action>

     <Protocol>

     <Type>EXCH</Type>

     <Server>COMPANY-EX1-VM.company.internal</Server>

     <ServerDN>/o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=COMPANY-EX1-VM</ServerDN>

     <ServerVersion>738180DA</ServerVersion>

     <MdbDN>/o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=COMPANY-EX1-VM/cn=Microsoft Private MDB</MdbDN>

     <ASUrl>https://mail.company.co.uk/ews/exchange.asmx</ASUrl>

     <OOFUrl>https://mail.company.co.uk/ews/exchange.asmx</OOFUrl>

     <OABUrl>https://mail.company.co.uk/oab/cad6693a-6c76-4fbc-b34b-51600d062893/</OABUrl>

     <UMUrl>https://mail.company.co.uk/ews/UM2007Legacy.asmx</UMUrl>

     <Port>0</Port>

     <DirectoryPort>0</DirectoryPort>

     <ReferralPort>0</ReferralPort>

     <PublicFolderServer>COMPANY-EX1-VM.company.internal</PublicFolderServer>

     <AD>COMPANY-EX1-VM.company.internal</AD>

     <EwsUrl>https://mail.company.co.uk/ews/exchange.asmx</EwsUrl>

     <EcpUrl>https://company-ex1-vm.company.internal/ecp/</EcpUrl>

     <EcpUrl-um>?p=customize/voicemail.aspx&amp;exsvurl=1</EcpUrl-um>

     <EcpUrl-aggr>?p=personalsettings/EmailSubscriptions.slab&amp;exsvurl=1</EcpUrl-aggr>

     <EcpUrl-mt>PersonalSettings/DeliveryReport.aspx?exsvurl=1&amp;IsOWA=&lt;IsOWA&gt;&amp;MsgID=&lt;MsgID&gt;&amp;Mbx=&lt;Mbx&gt;</EcpUrl-mt>

     <EcpUrl-ret>?p=organize/retentionpolicytags.slab&amp;exsvurl=1</EcpUrl-ret>

     <EcpUrl-sms>?p=sms/textmessaging.slab&amp;exsvurl=1</EcpUrl-sms>

     </Protocol>

     <Protocol>

     <Type>EXPR</Type>

     <Server>mail.company.co.uk</Server>

     <ASUrl>https://mail.company.co.uk/ews/exchange.asmx</ASUrl>

     <OOFUrl>https://mail.company.co.uk/ews/exchange.asmx</OOFUrl>

     <OABUrl>https://mail.company.co.uk/OAB/cad6693a-6c76-4fbc-b34b-51600d062893/</OABUrl>

     <UMUrl>https://mail.company.co.uk/ews/UM2007Legacy.asmx</UMUrl>

     <Port>0</Port>

     <DirectoryPort>0</DirectoryPort>

     <ReferralPort>0</ReferralPort>

     <SSL>On</SSL>

     <AuthPackage>Ntlm</AuthPackage>

     <CertPrincipalName>msstd:mail.company.co.uk</CertPrincipalName>

     <EwsUrl>https://mail.company.co.uk/ews/exchange.asmx</EwsUrl>

     <EcpUrl>https://mail.company.co.uk/ecp/</EcpUrl>

     <EcpUrl-um>?p=customize/voicemail.aspx&amp;exsvurl=1</EcpUrl-um>

     <EcpUrl-aggr>?p=personalsettings/EmailSubscriptions.slab&amp;exsvurl=1</EcpUrl-aggr>

     <EcpUrl-mt>PersonalSettings/DeliveryReport.aspx?exsvurl=1&amp;IsOWA=&lt;IsOWA&gt;&amp;MsgID=&lt;MsgID&gt;&amp;Mbx=&lt;Mbx&gt;</EcpUrl-mt>

     <EcpUrl-ret>?p=organize/retentionpolicytags.slab&amp;exsvurl=1</EcpUrl-ret>

     <EcpUrl-sms>?p=sms/textmessaging.slab&amp;exsvurl=1</EcpUrl-sms>

     </Protocol>

     <Protocol>

     <Type>WEB</Type>

     <Port>0</Port>

     <DirectoryPort>0</DirectoryPort>

     <ReferralPort>0</ReferralPort>

     <Internal>

     <OWAUrl AuthenticationMethod="Basic, Fba">https://company-ex1-vm.company.internal/owa/</OWAUrl>

     <Protocol>

     <Type>EXCH</Type>

     <ASUrl>https://mail.company.co.uk/ews/exchange.asmx</ASUrl>

     </Protocol>

     </Internal>

     <External>

     <OWAUrl AuthenticationMethod="Fba">https://mail.company.co.uk/owa/</OWAUrl>

     <Protocol>

     <Type>EXPR</Type>

     <ASUrl>https://mail.company.co.uk/ews/exchange.asmx</ASUrl>

     </Protocol>

     </External>

     </Protocol>

     </Account>

     </Response>

    </Autodiscover>

     

    Look forward to you response. Thanks

    Monday, September 5, 2011 10:50 AM
  • Autodiscover was tested successfully. So your external Auto Configuration does work.

    * https://company.co.uk/AutoDiscover/AutoDiscover.xml could have worked, but your SAN certificate does not support it.
    * https://autodiscover.company.co.uk appears to be supported with your SAN certificate, but no DNS A or CNAME record.
    * Redirection is not of interest here.
    * Autodiscover service using the DNS SRV redirect method does work.

    Everything is fine for your Outlook clients, but in the event you have other mobile devices than Windows Mobile, you should add a CNAME record in your external DNS for autodiscover.company.co.uk and point it to mail.company.co.uk.


    MCTS: Messaging | MCSE: S+M
    Monday, September 5, 2011 8:10 PM
  • Hi Jon,

    Sorry for the late reply. I've added autodiscover.company.co.uk and pointed it to mail.company.co.uk. Once the DNS has propagated I will re-test the autodiscover and let you know how I get on.

    Thanks,

     

    Chris 

    Thursday, September 8, 2011 3:40 PM
  • Hi Jon,

    I've tested the external autodiscover after adding 'autodiscover.company.co.uk' but it still doesn't work. The Outlook client times out and the message is as follows:

    An encrypted connection to your mail server is not available. Click next to attempt using an unencryted connection.

    Any other suggestions?

    Thanks,

    Chris 

    Tuesday, September 13, 2011 2:23 PM