none
Missing "New User" button RRS feed

  • Question

  • Hi -

    We have come across an issue which appears to be a bug.

    We have setup a user account that is specifically tasked with creating users in Project Server.

    The account has the following permissions directly assigned to it:

    Manage Security, Manage Users and Groups, Log on, Log on from Project Pro, New resource, View resource Center

    and with the following category permissions (via its own custom category)

    Edit Enterprise Resource Data and View Enterprise Resource Data

    All other permissions are denied.

    This was working in 2007 but not in 2010

    The net result is that on the Manage Users screen, the New User button is not shown

    Additionally, if the user tries to create a new resource with Admin permissions, the access to create is denied citing denied permissions.

    =================================================

    The resource could not be saved due to the following reasons:

    • You do not have sufficient permission to perform this update.

    ==================================================

    We are using Project Server 2010 + April CU (No Sp1 yet but soon)

    Thanks in advance for all your input

    Regards,

    Shane

     

    Is there a permission missing or something else perhaps we need to consider in 2010?


    Shane...OH
    Friday, September 2, 2011 11:27 AM

Answers

  • Here is the answer:

     

    You need to add the permission to Manage Site Services.

     

    I had misread your original post and thought the user was trying to add Resources from the Resource Center.  That will work with the settings you described.  But in fact, you said they were trying to add Users from Server Settings > Manage Users page.  To enable the button there, you need Manage Site Services.


    Reid McTaggart Partner DeltaBahn LLC

    Friday, September 2, 2011 3:31 PM

All replies

  • The category must include at least one Resource Center view, or you will get an Access Denied message when you navigate to the Resource Center.  In that case, all of the ribbon would be grayed out, not  just the New User button.

    Making the user a member of the Administrator's Group did not have any effect because you set all other permissions to Deny.  It is unusual to need to Deny so many permissions. Deny is generally used very rarely.

    I have tested your scenario with all other permissions set to not allow (neither box checked) and it works as expected.

    Perhaps there are some other settings settings you did not mention in your original post?  For example, your description of the Category you creatred for this user - in addition to not including any views - did not mention any Resources.  If no resources are included in the category, then the Edit Enterprise Resource Data permission has no effect.


    Reid McTaggart Partner DeltaBahn LLC
    Friday, September 2, 2011 2:25 PM
  • Hi Reid,

    Sorry - I should have mentioned that we have added the category to the Resource Center view so we dont get access denied on resource Center.

    The category includes "All current and future resources"

    I have tried removing all of the denied checks to leave as "not granted" but the problem remains.

    Could it be related to the service pack/build level?

    Thanks,

    Shane


    Shane O'Hanlon (Accenture)
    Friday, September 2, 2011 2:42 PM
  • Thanks, Shane.  I do not think it is SP or CU related.  The image I tested on does not have SP1 or any of the recent CUs.

    Have you tried having the user log in from a different computer?

    Have you tried setting the same permissions for another user?


    Reid McTaggart Partner DeltaBahn LLC
    Friday, September 2, 2011 2:53 PM
  • are you sure that you have not added this user to another group  that still has a deny somewhere?  You may also want to check to make sure that there is not a deny somewhere specifically for that user.
    Friday, September 2, 2011 3:19 PM
  • Here is the answer:

     

    You need to add the permission to Manage Site Services.

     

    I had misread your original post and thought the user was trying to add Resources from the Resource Center.  That will work with the settings you described.  But in fact, you said they were trying to add Users from Server Settings > Manage Users page.  To enable the button there, you need Manage Site Services.


    Reid McTaggart Partner DeltaBahn LLC

    Friday, September 2, 2011 3:31 PM
  • BINGO Reid

    Thank you so much!!

    Cheers,

    Shane


    Shane O'Hanlon (Accenture)
    Friday, September 2, 2011 3:53 PM