none
IE 11 on Windows 10 1703 - Your current security settings do not allow this file to be downloaded RRS feed

  • Question

  • When attempting to download files, I'm getting the message

    Your current security settings do not allow this file to be downloaded

    in a pop-up dialog.  Then the download manager pops up and the file is listed with Retry.  I Retry and the file downloads properly.  I have computer GPOs in place the allow file downloads on all Zones and can't figure out which setting is causing this message to appear.

    Tuesday, September 19, 2017 9:18 PM

Answers

  • I found the issue.  The setting Show security warning for potentially unsafe files did the trick.
    • Marked as answer by AdamGrossTX Wednesday, September 20, 2017 8:15 PM
    Wednesday, September 20, 2017 8:15 PM

All replies

  • Hi,

    guess - unsafe files. (you did not mention the file types that you are trying to download.)

    To avoid confusion please include links to website(s) that you are having problems with your questions. If it is an internal site (intranet) please mention such in your questions, include also the IE emulation mode that you have set for the intranet domain using Enterprise MOde Site lists.

    From your description, it sounds like you are trying to download an embed pdf document from a website that is missing the type attribute in a embed or object tag. F12>Networking tab should show you two requests for the file...contact the programmers of the website and have them add a type attribute to their object or embed elements.

    You can find out which IE security zone a website has been mapped to from the File>Properties menu in IE.

    The default Security zone settings for IE are optimized for public internet use, it would be unwise to allow downloads from the restricted zone. It would be unwise to allow user configuration and access to the IE security zone settings on a public access machine or a centrally managed network.

    Regards.


    Rob^_^


    Tuesday, September 19, 2017 10:02 PM
  • Any file from any source has the issue.  Here's the latest one.

    Source Article:

    https://blogs.technet.microsoft.com/ausoemteam/2017/04/06/download-windows-adk-for-windows-10-version-1703/

    File Link from the article:

    https://go.microsoft.com/fwlink/p/?LinkId=845542

    These same exact settings work just fine for IE11 on Windows 7.  Just not in Windows 10.

    Wednesday, September 20, 2017 1:09 PM
  • File Link from the article:

    https://go.microsoft.com/fwlink/p/?LinkId=845542

    That does an immediate redirect

    http://download.microsoft.com/download/5/D/9/5D915042-FCAA-4859-A1C3-29E198690493/adk/adksetup.exe

    What happens if you go there directly?

    In fact, I think I see a problem with it.  The protocol prefix changed.  Assuming the download site supports HTTPS you could also try changing the protocol prefix for a direct attempt and compare results that way.  In fact, that might be preferred.  Heh.  And changing the protocol prefix of the "link from the article" results in a completely different sequence.  Use the Developer Tools (F12) to see this.  YMMV.



    Robert Aldwinckle
    ---

    Wednesday, September 20, 2017 2:46 PM
    Answerer
  • Same results with the direct link with HTTP and HTTPS.

    The thing that's really odd is that regardless of what it is, I always get the popup but then if I click OK I get the file download dialog.  When I retry the download, I can always get the file.  I suspect that I have a GPO messed up somewhere but just can't pinpoint it.

    Wednesday, September 20, 2017 3:03 PM
  • I found the issue.  The setting Show security warning for potentially unsafe files did the trick.
    • Marked as answer by AdamGrossTX Wednesday, September 20, 2017 8:15 PM
    Wednesday, September 20, 2017 8:15 PM