none
FIM Synchronization Engine error RRS feed

  • Question

  • Hi ,

    I have exported and imported my SQL agents from ILM SP1 to FIM 2010 R2 Sp1 and rebuiled my dll using .net framework 4. Whenever i execute SQL full sync,FIM sych server stopped and throws below error

    Faulting application name: miiserver.exe, version: 4.1.3419.0, time stamp: 0x511d9c79

    Faulting module name: clr.dll, version: 4.0.30319.17929, time stamp: 0x4ffa59b1

    Exception code: 0xc0000005

    Fault offset: 0x00000000004e5900

    Faulting process id: 0x1904

    Faulting application start time: 0x01ce246d7f4278a2

    Faulting application path: C:\Program Files\Microsoft Forefront Identity Manager\2010\Synchronization Service\Bin\miiserver.exe

    Faulting module path: C:\Windows\Microsoft.NET\Framework64\v4.0.30319\clr.dll

    Report Id: 12e2e619-9061-11e2-92bd-0050562905b3

     

    What would be the problem?

    Thanks in advance

    Sridhar R

    Tuesday, March 19, 2013 7:11 AM

Answers

  • hi Bob,

    Sorry for delay reply, Thanks Bob!.. issue was solved after increasing the RAM and  hard disk space. When Sharepoint Health status throws issue for low disk space its stop the service and restart automatically.During that session FIM sychronization service also gets stops.

    I had only 4Mb space in my hard disk,now i have added 100GB and change the sharepoint log path..So issue gone


    Tuesday, March 26, 2013 12:40 PM

All replies

  • Have you checked your .Net binding redirects in miiserver.exe.config?

    Bob Bradley (FIMBob @ TheFIMTeam.com) ... now using Event Broker 3.0 for just-in-time delivery of FIM 2010 policy via the sync engine, and continuous compliance for FIM

    Tuesday, March 19, 2013 8:25 AM
  • hi bob,

    Please find the .net bindings of my miiserver.exe.config

    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
          <dependentAssembly>
            <assemblyIdentity name="Microsoft.MetadirectoryServicesEx" publicKeyToken="31bf3856ad364e35" />
            <bindingRedirect oldVersion="3.3.0.0" newVersion="4.1.0.0" />
            <bindingRedirect oldVersion="4.0.0.0" newVersion="4.1.0.0" />
            <bindingRedirect oldVersion="4.0.1.0" newVersion="4.1.0.0" />
            <bindingRedirect oldVersion="4.0.2.0" newVersion="4.1.0.0" />
            <bindingRedirect oldVersion="4.0.3.0" newVersion="4.1.0.0" />
          </dependentAssembly>
          <probing privatePath="Assemblies" />
        </assemblyBinding>

    Regards,

    Sridhar R

    Tuesday, March 19, 2013 10:10 AM
  • I think that is probably OK. Have you got your SQL MA running in a separate process or NOT the same thread setting that is the new default for a SQL MA? Lastly you may want to try installing the latest patch (build 4.0.3684.2).

    Bob Bradley (FIMBob @ TheFIMTeam.com) ... now using Event Broker 3.0 for just-in-time delivery of FIM 2010 policy via the sync engine, and continuous compliance for FIM

    Tuesday, March 19, 2013 10:23 AM
  • hi Bob, I have installed FIM 2010 R2 SP1 (4.1.3419). And I have 3 custom SQL management agent create using ECMA 1.0 and 2 inbulit SQL agent.None of the agent is running as separte process. So i need to change my all SQL management agent as separate process. if you have any link related to SQL agent should run as separate process ,please share Thanks, Sridhar
    Tuesday, March 19, 2013 10:50 AM
  • No just checking you were NOT running them in a separate process :). The above patch is for FIM R1 sorry. There may be a more recent R2 patch because your problem sounds like a bug and there have been a few R2 patches lately.

    Bob Bradley (FIMBob @ TheFIMTeam.com) ... now using Event Broker 3.0 for just-in-time delivery of FIM 2010 policy via the sync engine, and continuous compliance for FIM

    Tuesday, March 19, 2013 10:54 AM
  • hi have a look at the 'Known Issues' section of the following KB Atrticle as well

    http://support.microsoft.com/kb/2772429



    Regards Furqan Asghar

    Tuesday, March 19, 2013 11:29 AM
  • Did you solve the problem and if so what was the eventual fix please?

    Bob Bradley (FIMBob @ TheFIMTeam.com) ... now using Event Broker 3.0 for just-in-time delivery of FIM 2010 policy via the sync engine, and continuous compliance for FIM

    Wednesday, March 20, 2013 9:05 PM
  • hi Bob,

    Sorry for delay reply, Thanks Bob!.. issue was solved after increasing the RAM and  hard disk space. When Sharepoint Health status throws issue for low disk space its stop the service and restart automatically.During that session FIM sychronization service also gets stops.

    I had only 4Mb space in my hard disk,now i have added 100GB and change the sharepoint log path..So issue gone


    Tuesday, March 26, 2013 12:40 PM
  • Nice get - add this to the list of causes :)

    Bob Bradley (FIMBob @ TheFIMTeam.com) ... now using Event Broker 3.0 for just-in-time delivery of FIM 2010 policy via the sync engine, and continuous compliance for FIM

    Tuesday, March 26, 2013 12:42 PM