none
MDT 2013 Update 1 - Unable to find rules INI file, rc = 1 RRS feed

  • Question

  • Hello,

    I just built a brand new server and loaded MDT 2013 Update 1 to start pushing out Windows 10 clients. After I PXE boot, the program processes the bootstrap.ini file, then flashes saying that it cannot locate the CustomSettings.ini file. It is in the correct location (deploymentshare\control\customsettings.ini), I have tried giving new permissions, declaring the file in the gather ts, moving the file to the scripts root, a full reinstall, even a new server, nothing works. Below is the BDD.log file from a failed deployment.


    Property LogPath is now = X:\MININT\SMSOSD\OSDLOGS LiteTouch 12/2/2015 6:21:18 AM 0 (0x0000)
    Microsoft Deployment Toolkit version: 6.3.8298.1000 LiteTouch 12/2/2015 6:21:18 AM 0 (0x0000)
    Property Debug is now = FALSE LiteTouch 12/2/2015 6:21:18 AM 0 (0x0000)
    ZTIUtility!GetAllFixedDrives (False) LiteTouch 12/2/2015 6:21:18 AM 0 (0x0000)
    ZTIUtility!GetAllFixedDrives = LiteTouch 12/2/2015 6:21:18 AM 0 (0x0000)
    No task sequence is in progress. LiteTouch 12/2/2015 6:21:18 AM 0 (0x0000)
    New ZTIDisk : \\MININT-B04TLBT\root\cimv2:Win32_DiskDrive.DeviceID="\\\\.\\PHYSICALDRIVE0" LiteTouch 12/2/2015 6:21:18 AM 0 (0x0000)
    Found Possible OS TargetDisk: \\MININT-B04TLBT\root\cimv2:Win32_DiskDrive.DeviceID="\\\\.\\PHYSICALDRIVE0" LiteTouch 12/2/2015 6:21:18 AM 0 (0x0000)
    GetPartitions: 0 LiteTouch 12/2/2015 6:21:18 AM 0 (0x0000)
    Did not find disk. LiteTouch 12/2/2015 6:21:18 AM 0 (0x0000)
    Property SMSTSLocalDataDrive is now = LiteTouch 12/2/2015 6:21:18 AM 0 (0x0000)
    Unable to connect to BCDStore. LiteTouch 12/2/2015 6:21:25 AM 0 (0x0000)
    Not running within WinPE or WinRE. LiteTouch 12/2/2015 6:21:25 AM 0 (0x0000)
    Property DeploymentMethod is now = UNC LiteTouch 12/2/2015 6:21:25 AM 0 (0x0000)
    DeploymentMethod = UNC LiteTouch 12/2/2015 6:21:25 AM 0 (0x0000)
    Property DeployRoot is now = X:\Deploy LiteTouch 12/2/2015 6:21:25 AM 0 (0x0000)
    Using a local or mapped drive, no connection is required. LiteTouch 12/2/2015 6:21:25 AM 0 (0x0000)
    DeployRoot = X:\Deploy LiteTouch 12/2/2015 6:21:25 AM 0 (0x0000)
    Property DeployDrive is now = X: LiteTouch 12/2/2015 6:21:25 AM 0 (0x0000)
    DeployDrive = X: LiteTouch 12/2/2015 6:21:25 AM 0 (0x0000)
    Property PHASE is now = PREINSTALL LiteTouch 12/2/2015 6:21:25 AM 0 (0x0000)
    Property DeploymentType is now = NEWCOMPUTER LiteTouch 12/2/2015 6:21:25 AM 0 (0x0000)
    Phase = PREINSTALL LiteTouch 12/2/2015 6:21:25 AM 0 (0x0000)
    About to run command: wscript.exe "X:\Deploy\Scripts\ZTIGather.wsf" /inifile:Bootstrap.ini LiteTouch 12/2/2015 6:21:25 AM 0 (0x0000)
    Property inifile is now = Bootstrap.ini ZTIGather 12/2/2015 6:21:25 AM 0 (0x0000)
    Microsoft Deployment Toolkit version: 6.3.8298.1000 ZTIGather 12/2/2015 6:21:25 AM 0 (0x0000)
    ------------------------- Object Initialization ------------------------- ZTIGather 12/2/2015 6:21:25 AM 0 (0x0000)
    ------------------------- Initialization ------------------------- ZTIGather 12/2/2015 6:21:25 AM 0 (0x0000)
    Synchronizing the environments. ZTIGather 12/2/2015 6:21:25 AM 0 (0x0000)
    Property DeployRoot is now = X:\Deploy ZTIGather 12/2/2015 6:21:25 AM 0 (0x0000)
    Property DeployDrive is now = X: ZTIGather 12/2/2015 6:21:25 AM 0 (0x0000)
    Finished synchronizing the environments. ZTIGather 12/2/2015 6:21:25 AM 0 (0x0000)
    Getting OS info ZTIGather 12/2/2015 6:21:25 AM 0 (0x0000)
    Property OSCurrentVersion is now = 10.0.10586 ZTIGather 12/2/2015 6:21:26 AM 0 (0x0000)
    Property OSCurrentBuild is now = 10586 ZTIGather 12/2/2015 6:21:26 AM 0 (0x0000)
    Property OSVersion is now = WinPE ZTIGather 12/2/2015 6:21:26 AM 0 (0x0000)
    Property IsServerOS is now = False ZTIGather 12/2/2015 6:21:26 AM 0 (0x0000)
    Property IsServerCoreOS is now = False ZTIGather 12/2/2015 6:21:26 AM 0 (0x0000)
    Finished getting OS info ZTIGather 12/2/2015 6:21:26 AM 0 (0x0000)
    Getting HAL information ZTIGather 12/2/2015 6:21:26 AM 0 (0x0000)
    Property HALName is now = acpiapic ZTIGather 12/2/2015 6:21:26 AM 0 (0x0000)
    Finished getting HAL information ZTIGather 12/2/2015 6:21:26 AM 0 (0x0000)
    Getting network info ZTIGather 12/2/2015 6:21:26 AM 0 (0x0000)
    Checking network adapter: [00000000] Intel(R) Ethernet Connection (3) I218-LM ZTIGather 12/2/2015 6:21:26 AM 0 (0x0000)
    Property definition is now = BDD_Welcome_ENU.xml Wizard 12/2/2015 6:21:26 AM 0 (0x0000)
    Microsoft Deployment Toolkit version: 6.3.8298.1000 Wizard 12/2/2015 6:21:26 AM 0 (0x0000)
    MAC address = 34:E6:D7:5F:D3:49 ZTIGather 12/2/2015 6:21:26 AM 0 (0x0000)
    IP Address = 10.73.25.38 ZTIGather 12/2/2015 6:21:26 AM 0 (0x0000)
    IP Address = fe80::e040:6e76:a8b2:5d03 ZTIGather 12/2/2015 6:21:26 AM 0 (0x0000)
    Default Gateway = 10.73.24.254 ZTIGather 12/2/2015 6:21:26 AM 0 (0x0000)
    Property IPAddress001 is now = 10.73.25.38 ZTIGather 12/2/2015 6:21:26 AM 0 (0x0000)
    Property IPAddress002 is now = fe80::e040:6e76:a8b2:5d03 ZTIGather 12/2/2015 6:21:26 AM 0 (0x0000)
    Property MacAddress001 is now = 34:E6:D7:5F:D3:49 ZTIGather 12/2/2015 6:21:26 AM 0 (0x0000)
    Property DefaultGateway001 is now = 10.73.24.254 ZTIGather 12/2/2015 6:21:26 AM 0 (0x0000)
    Finished getting network info ZTIGather 12/2/2015 6:21:26 AM 0 (0x0000)
    Getting DP info ZTIGather 12/2/2015 6:21:26 AM 0 (0x0000)
    Unable to determine ConfigMgr distribution point ZTIGather 12/2/2015 6:21:26 AM 0 (0x0000)
    Finished getting DP info ZTIGather 12/2/2015 6:21:26 AM 0 (0x0000)
    Getting WDS server info ZTIGather 12/2/2015 6:21:26 AM 0 (0x0000)
    Property WDSServer is now = xxxxxxxx ZTIGather 12/2/2015 6:21:26 AM 0 (0x0000)
    Finished getting WDS server info ZTIGather 12/2/2015 6:21:26 AM 0 (0x0000)
    Property HostName is now = MININT-B04TLBT ZTIGather 12/2/2015 6:21:26 AM 0 (0x0000)
    Getting asset info ZTIGather 12/2/2015 6:21:26 AM 0 (0x0000)
    Unable to determine asset tag via WMI. ZTIGather 12/2/2015 6:21:26 AM 0 (0x0000)
    Not Wizard = False Wizard 12/2/2015 6:21:27 AM 0 (0x0000)
    Property WizardComplete is now = N Wizard 12/2/2015 6:21:27 AM 0 (0x0000)
    FindFile: The file x86\Microsoft.BDD.Utility.dll could not be found in any standard locations. ZTIGather 12/2/2015 6:21:28 AM 0 (0x0000)
    FindFile(...\Microsoft.BDD.Utility.dll)  Result : 1 ZTIGather 12/2/2015 6:21:28 AM 0 (0x0000)
    RUN: regsvr32.exe /s "" ZTIGather 12/2/2015 6:21:28 AM 0 (0x0000)
    FindFile(...\Microsoft.BDD.Utility.dll)  Result : 0 ZTIGather 12/2/2015 6:21:28 AM 0 (0x0000)
    RUN: regsvr32.exe /s "X:\Deploy\Tools\x64\Microsoft.BDD.Utility.dll" ZTIGather 12/2/2015 6:21:28 AM 0 (0x0000)
    Property AssetTag is now = ZTIGather 12/2/2015 6:21:28 AM 0 (0x0000)
    Property SerialNumber is now = 256MP32 ZTIGather 12/2/2015 6:21:28 AM 0 (0x0000)
    Property Make is now = Dell Inc. ZTIGather 12/2/2015 6:21:28 AM 0 (0x0000)
    Property Model is now = Latitude E5550 ZTIGather 12/2/2015 6:21:28 AM 0 (0x0000)
    Property Product is now = 06DJY6 ZTIGather 12/2/2015 6:21:28 AM 0 (0x0000)
    Property UUID is now = 4C4C4544-0035-3610-804D-B2C04F503332 ZTIGather 12/2/2015 6:21:28 AM 0 (0x0000)
    Property Memory is now = 8082 ZTIGather 12/2/2015 6:21:28 AM 0 (0x0000)
    Property Architecture is now = X64 ZTIGather 12/2/2015 6:21:28 AM 0 (0x0000)
    Property ProcessorSpeed is now = 2301 ZTIGather 12/2/2015 6:21:28 AM 0 (0x0000)
    Property CapableArchitecture is now = AMD64 X64 X86 ZTIGather 12/2/2015 6:21:28 AM 0 (0x0000)
    Property IsLaptop is now = True ZTIGather 12/2/2015 6:21:28 AM 0 (0x0000)
    Property IsDesktop is now = False ZTIGather 12/2/2015 6:21:28 AM 0 (0x0000)
    Property IsServer is now = False ZTIGather 12/2/2015 6:21:29 AM 0 (0x0000)
    Property IsUEFI is now = False ZTIGather 12/2/2015 6:21:29 AM 0 (0x0000)
    Property IsOnBattery is now = False ZTIGather 12/2/2015 6:21:29 AM 0 (0x0000)
    Property SupportsX86 is now = True ZTIGather 12/2/2015 6:21:29 AM 0 (0x0000)
    Property SupportsX64 is now = True ZTIGather 12/2/2015 6:21:29 AM 0 (0x0000)
    Property SupportsSLAT is now = True ZTIGather 12/2/2015 6:21:29 AM 0 (0x0000)
    Finished getting asset info ZTIGather 12/2/2015 6:21:29 AM 0 (0x0000)
    Getting OS SKU info ZTIGather 12/2/2015 6:21:29 AM 0 (0x0000)
    Unable to determine Windows SKU while in Windows PE. ZTIGather 12/2/2015 6:21:29 AM 0 (0x0000)
    Determining the Disk and Partition Number from the Logical Drive X:\WINDOWS ZTIGather 12/2/2015 6:21:29 AM 0 (0x0000)
    Property OriginalArchitecture is now = ZTIGather 12/2/2015 6:21:29 AM 0 (0x0000)
    Getting virtualization info ZTIGather 12/2/2015 6:21:29 AM 0 (0x0000)
    Property IsHypervisorRunning is now = False ZTIGather 12/2/2015 6:21:29 AM 0 (0x0000)
    Property SupportsVT is now = True ZTIGather 12/2/2015 6:21:29 AM 0 (0x0000)
    Property SupportsNX is now = True ZTIGather 12/2/2015 6:21:29 AM 0 (0x0000)
    Property Supports64Bit is now = True ZTIGather 12/2/2015 6:21:29 AM 0 (0x0000)
    Property SupportsHyperVRole is now = True ZTIGather 12/2/2015 6:21:29 AM 0 (0x0000)
    This computer does not appear to be a virtual machine (BIOS is 'DELL   - 1072009'). ZTIGather 12/2/2015 6:21:29 AM 0 (0x0000)
    Property IsVM is now = False ZTIGather 12/2/2015 6:21:29 AM 0 (0x0000)
    Finished getting virtualization info ZTIGather 12/2/2015 6:21:29 AM 0 (0x0000)
    Connection succeeded to MicrosoftVolumeEncryption ZTIGather 12/2/2015 6:21:29 AM 0 (0x0000)
    There are no encrypted drives ZTIGather 12/2/2015 6:21:29 AM 0 (0x0000)
    Property IsBDE is now = False ZTIGather 12/2/2015 6:21:29 AM 0 (0x0000)
    Processing the PREINSTALL phase. ZTIGather 12/2/2015 6:21:29 AM 0 (0x0000)
    Determining the INI file to use. ZTIGather 12/2/2015 6:21:29 AM 0 (0x0000)
    Finished determining the INI file to use. ZTIGather 12/2/2015 6:21:29 AM 0 (0x0000)
    Using from [Settings]: Rule Priority = DEFAULT ZTIGather 12/2/2015 6:21:30 AM 0 (0x0000)
    ------ Processing the [DEFAULT] section ------ ZTIGather 12/2/2015 6:21:30 AM 0 (0x0000)
    Property DEPLOYROOT is now = \\xxxxxxx\DeploymentShare$ ZTIGather 12/2/2015 6:21:30 AM 0 (0x0000)
    Using from [DEFAULT]: DEPLOYROOT = \\xxxxxxxx\DeploymentShare$ ZTIGather 12/2/2015 6:21:30 AM 0 (0x0000)
    Property USERID is now = administrator ZTIGather 12/2/2015 6:21:30 AM 0 (0x0000)
    Using from [DEFAULT]: USERID = administrator ZTIGather 12/2/2015 6:21:30 AM 0 (0x0000)
    Property USERDOMAIN is now = xxxxxxxx ZTIGather 12/2/2015 6:21:30 AM 0 (0x0000)
    Using from [DEFAULT]: USERDOMAIN = xxxxxxxx ZTIGather 12/2/2015 6:21:30 AM 0 (0x0000)
    <Message containing password has been suppressed> ZTIGather 12/2/2015 6:21:30 AM 0 (0x0000)
    <Message containing password has been suppressed> ZTIGather 12/2/2015 6:21:30 AM 0 (0x0000)
    Property SKIPBDDWELCOME is now = Yes ZTIGather 12/2/2015 6:21:30 AM 0 (0x0000)
    Using from [DEFAULT]: SKIPBDDWELCOME = Yes ZTIGather 12/2/2015 6:21:30 AM 0 (0x0000)
    ------ Done processing X:\Deploy\Scripts\Bootstrap.ini ------ ZTIGather 12/2/2015 6:21:30 AM 0 (0x0000)
    Remapping variables. ZTIGather 12/2/2015 6:21:30 AM 0 (0x0000)
    Property TaskSequenceID is now = ZTIGather 12/2/2015 6:21:30 AM 0 (0x0000)
    Property DeploymentType is now = NEWCOMPUTER ZTIGather 12/2/2015 6:21:30 AM 0 (0x0000)
    Finished remapping variables. ZTIGather 12/2/2015 6:21:30 AM 0 (0x0000)
    ZTIGather processing completed successfully. ZTIGather 12/2/2015 6:21:30 AM 0 (0x0000)
    Command completed, return code = 0 LiteTouch 12/2/2015 6:21:30 AM 0 (0x0000)
    Property WizardComplete is now = Y Wizard 12/2/2015 6:21:31 AM 0 (0x0000)
    Validating connection to \\xxxxxxxx\DeploymentShare$ LiteTouch 12/2/2015 6:21:31 AM 0 (0x0000)
    Mapping server share: \\xxxxxxxx\DeploymentShare$ LiteTouch 12/2/2015 6:21:31 AM 0 (0x0000)
    Mapped Network UNC Path Z:  = \\xxxxxxxx\DeploymentShare$ LiteTouch 12/2/2015 6:21:32 AM 0 (0x0000)
    Found Existing UNC Path Z: = \\xxxxxxxx\DeploymentShare$ LiteTouch 12/2/2015 6:21:32 AM 0 (0x0000)
    Successfully established connection using supplied credentials. LiteTouch 12/2/2015 6:21:32 AM 0 (0x0000)
    About to run command: wscript.exe "X:\Deploy\Scripts\ZTIGather.wsf" /nolocalonly LiteTouch 12/2/2015 6:21:32 AM 0 (0x0000)
    Property definition is now = WelcomeWiz_Initialize.xml Wizard 12/2/2015 6:21:32 AM 0 (0x0000)
    Property nolocalonly is now = ZTIGather 12/2/2015 6:21:32 AM 0 (0x0000)
    Microsoft Deployment Toolkit version: 6.3.8298.1000 Wizard 12/2/2015 6:21:32 AM 0 (0x0000)
    Microsoft Deployment Toolkit version: 6.3.8298.1000 ZTIGather 12/2/2015 6:21:32 AM 0 (0x0000)
    ------------------------- Object Initialization ------------------------- ZTIGather 12/2/2015 6:21:32 AM 0 (0x0000)
    ------------------------- Initialization ------------------------- ZTIGather 12/2/2015 6:21:32 AM 0 (0x0000)
    Synchronizing the environments. ZTIGather 12/2/2015 6:21:32 AM 0 (0x0000)
    Property DeployRoot is now = \\xxxxxxxx\DeploymentShare$ ZTIGather 12/2/2015 6:21:32 AM 0 (0x0000)
    Not Wizard = False Wizard 12/2/2015 6:21:32 AM 0 (0x0000)
    Property DeployDrive is now = X: ZTIGather 12/2/2015 6:21:32 AM 0 (0x0000)
    Property WizardComplete is now = N Wizard 12/2/2015 6:21:33 AM 0 (0x0000)
    Finished synchronizing the environments. ZTIGather 12/2/2015 6:21:33 AM 0 (0x0000)
    Skipping local settings gathering because it has already been done. ZTIGather 12/2/2015 6:21:33 AM 0 (0x0000)
    Processing the PREINSTALL phase. ZTIGather 12/2/2015 6:21:33 AM 0 (0x0000)
    Determining the INI file to use. ZTIGather 12/2/2015 6:21:33 AM 0 (0x0000)
    FindFile: The file CustomSettings.ini could not be found in any standard locations. ZTIGather 12/2/2015 6:21:33 AM 0 (0x0000)
    Finished determining the INI file to use. ZTIGather 12/2/2015 6:21:33 AM 0 (0x0000)
    Unable to find rules INI file, rc = 1 ZTIGather 12/2/2015 6:21:33 AM 0 (0x0000)
    ZTI ERROR - Non-zero return code by ZTIGather, rc = 8000 ZTIGather 12/2/2015 6:21:33 AM 0 (0x0000)
    Command completed, return code = 8000 LiteTouch 12/2/2015 6:21:33 AM 0 (0x0000)
    FAILURE: 8000: Running wscript.exe "X:\Deploy\Scripts\ZTIGather.wsf" /nolocalonly LiteTouch 12/2/2015 6:21:33 AM 0 (0x0000)
    Validating connection to \\xxxxxxxx\DeploymentShare$ LiteTouch 12/2/2015 6:21:33 AM 0 (0x0000)
    Mapping server share: \\xxxxxxxx\DeploymentShare$ LiteTouch 12/2/2015 6:21:33 AM 0 (0x0000)
    Found Existing UNC Path Z: = \\xxxxxxxx\DeploymentShare$ LiteTouch 12/2/2015 6:21:33 AM 0 (0x0000)
    Found Existing UNC Path Z: = \\xxxxxxxx\DeploymentShare$ LiteTouch 12/2/2015 6:21:33 AM 0 (0x0000)
    Successfully established connection using supplied credentials. LiteTouch 12/2/2015 6:21:33 AM 0 (0x0000)
    Property WizardComplete is now = Y Wizard 12/2/2015 6:21:34 AM 0 (0x0000)
    Property LTIDirty is now = TRUE LiteTouch 12/2/2015 6:21:34 AM 0 (0x0000)
    About to run command: MSHTA.exe "\\xxxxxxxx\DeploymentShare$\Scripts\Wizard.hta" /definition:DeployWiz_Definition_ENU.xml LiteTouch 12/2/2015 6:21:34 AM 0 (0x0000)

    Thursday, December 3, 2015 12:26 PM

Answers

All replies

  • Did you ever find a fix for this issue? 
    Thursday, December 31, 2015 5:24 PM
  • Unfortunately I did not. I'm chalking it up to a bug in either MDT 2013 Update 1 or ADK 10. Previous versions work fine on the same server.
    Thursday, December 31, 2015 6:04 PM
  • Did you ever verify permissions as per:https://keithga.wordpress.com/2015/10/02/mdt-uberbug11-security-vs-usability/

    Logs are very important. https://keithga.wordpress.com/2014/10/24/video-mdt-2013-log-files-basics-bdd-log-and-smsts-log/ Mention any customizations you have made.

    Thursday, December 31, 2015 9:14 PM
    Moderator
  • Did you ever verify permissions as per:https://keithga.wordpress.com/2015/10/02/mdt-uberbug11-security-vs-usability/

    Logs are very important. https://keithga.wordpress.com/2014/10/24/video-mdt-2013-log-files-basics-bdd-log-and-smsts-log/ Mention any customizations you have made.

    This worked for me! Make sure to change the SHARE PERMISSIONS. Which involves going into the properties of your deployment share and then going to advanced sharing. I originally just changed the basic permission of the deployment share. Not the actual SHARE PERMISSIONS. It works now. 

    Thursday, December 31, 2015 9:29 PM
  • To save some time, here are the quick and easy steps for fixing this issue:

    Right click the deployment share folder. Click Properties, and in the Sharing tab, click Advanced Sharing... Click Permissions, and Add "Everyone" 

    Make sure Everyone has "Read" checked under the allow column. No others needed.


    Wednesday, May 23, 2018 4:08 PM