locked
Lost AERO due to WDM not running. RRS feed

  • Question

  • Hi There,

     

    I am experiencing problems when trying to enable the Vista Aero interface.

     

    I installed a fresh copy of Vista Business 3 days ago, and loaded all my applications.  The Aero interface was working fine up until today, when I booted the system and noticed it was running the Basic interface.  The option to enable the theme had also dissapeared from the Appearance Settings color scheme selection list.

     

    My machine meets all the criteria for Aero to run, as per the WinSAT technical documentation from Microsoft.  It is Quad Core, with the new ATI HD3850 PCI Express video card, running the latest Catalyst 7.11 drivers.

     

    After doing a lot of research on the net, I've noticed I am not alone with this problem.  It actually appears to be quite common.  The problem however, is that I have tried all the suggestions that were offered to correct the problem and none have succeeded.  I tried all the fixes that are documented by Microsoft at this link: http://www.microsoft.com/whdc/device/display/aero_rules.mspx

     

    I have also tried non-microsoft suggestions, such as reinstalling the video card drivers, removing startup programs, removing non-ms startup services, forcing desktopcomposition on in the registry, restarting the desktop windows services (net stop uxsms, net start uxsms), etc.  Vista simply won't give me the option to re-enable Aero.

     

    Upon running "winsat features" from the command line, I see that there is one problem which I cannot figure out how to resolve. 

     

    Windows System Assessment Tool
    > DWM not running
    > System processor power policy saved and set to 'max performance'
    > Running: Feature Enumeration v1.0.0.0 ''
    > Gathering System Information
    > Run Time 00:00:00.41
    > Operating System                        : 6.0 Build-6000
    > Processor                               : Intel(R) Core(TM)2 Quad CPU    Q6600
      @ 2.40GHz
    > TSC Frequency                           : 3420100000
    > Number of Processors                    : 1
    > Number of Cores                         : 4
    > Number of CPUs                          : 4
    > Number of Cores per Processor           : 4
    > Number of CPUs Per Core                 : 1
    > Cores have logical CPUs                 : NO
    > L1 Cache and line Size                  : 32768  64
    > L2 Cache and line Size                  : 4194304  64
    > Total physical mem available to the OS  : 1.99 GB (2,145,910,784 bytes)
    > Adapter Description                     : ATI Radeon HD 3850
    > Adapter Manufacturer                    : ATI Technologies Inc.
    > Adapter Driver Version                  : 8.432.0.0
    > Adapter Driver Date (yy/mm/dd)          : 2007\11\1
    > Has DX9 or better                       : Yes
    > Has Pixel shader 2.0 or better          : Yes
    > Has LDDM Driver                         : Yes
    > Dedicated (local) video memory          : 253.29MB
    > System memory dedicated as video memory : 0.00MB
    > System memory shared as video memory    : 767.50MB
    > Primary Monitor Size                    : 1600 X 1200  (1920000 total pixels)
    > WinSAT is Official                       : Yes
    > Total Run Time 00:00:01.25
    > The System processor power policy was restored

     

    Upon researching was I was getting the error that DWM was not running, I looked at the Event Viewer.  I discovered that DWM was logging event ID 9011 which states "The Desktop Window Manager was unable to start because a mirroring driver is in use"

     

    I looked into what that error meant and I found this description online.

     

    "A "mirroring driver" is a special type of display driver that is
    installed by some applications in addition to the regular videcard
    driver to receive complete copy of the display information. It doesn't
    display anything by itself, but it provides necessary information for
    applications like screen readers for people with insufficient
    eyesight. "

     

    I looked at my device manager, but did not find any "mirroring drivers".  I also read that there are a few applications which cause this error, specifically Trillian Messenger, Quicktime, and iTunes.  I removed them all but the problem remains.

     

    I have now invested a total of 5 hours troubleshooting this, and am facing a reinstallation of Vista to get Aero back.  If anyone can offer some suggestions, it would be greatly appreciated.

     

    Thank You!

    Tuesday, December 4, 2007 4:11 PM

Answers

  •  

    Solution found.

     

    Uninstall Symantec pcAnywhere V12.1, which is supposedly Vista Certified.

     

    As soon as I did that and rebooted, I got Aero back.

     

    I found this to be the culprit by doing a search for the word "mirror" in the registry, and found that pcAnywhere was loading a Mirror Driver.

    Thursday, December 6, 2007 1:42 PM

All replies

  •  

    Solution found.

     

    Uninstall Symantec pcAnywhere V12.1, which is supposedly Vista Certified.

     

    As soon as I did that and rebooted, I got Aero back.

     

    I found this to be the culprit by doing a search for the word "mirror" in the registry, and found that pcAnywhere was loading a Mirror Driver.

    Thursday, December 6, 2007 1:42 PM
  •  

    Good to see that you have solved your problem. Otherwise running the following command should help re-enable Aero by flushing it. Details at WinVistaClub.

     

    rundll32.exe Dwmapi.dll,DwmEnableComposition
     

     

     

     
    Saturday, December 15, 2007 6:07 PM
  • Nope, that command doesn't work in my situation.  I tried it.

     

    I reinstalled pcAnywhere 12.1, and as soon as I connect to the machine from a remote, and disconnect. Aero is permanantely lost until pcAnywhere is uninstalled.

     

    What a huge pain in the butt.

     

    I'd write Symantec about this but they are terrible at fixing problems.

     

    Wednesday, December 19, 2007 1:01 AM
  •  

    Very interesting - I have the same problem, and although I'm not using PCAnywhere, I *am* using UltraVNC and I wonder if it's the same problem.  I was pulling my hair out same as you and thought I was up against a brick wall so thanks for giving me something else to go on!  :-)
    Tuesday, April 15, 2008 6:42 PM
  • Hi Bob,

     

    I'm glad to see my post helped someone! 

     

    Since this happened, I have actually switched to UltraVNC as well.  However, I have had no problems with it at all.

     

    I am running server version 1.0.4 RC14 and the only default option I had to change for it to work perfectly was to run the admin setup, and under misc, i checked the box "Remove Aero Vista" to disable Aero upon a connection.

     

    For me, it is working 100%.  The only drawback to UltraVNC is that it can only display 1 monitor, whereas if pcAnywhere had worked, I would have been able to control both my monitors in dual display mode.

     

    Let me know if there is anything i can do to help you out.

     

    -Steven Rodriguez

    Wednesday, April 16, 2008 1:19 AM
  • You know you're getting old when you have an issue, remember that you solved it before but can't remember how, search the internet, and then find one of your own posts.  :-D
    I was actually working fine with UltraVNC, but was having terrible performance even if I was on my own LAN.  In fact I had just switched to a gigabit router, so was checking to see if it was a network performance issue (it isn't).
    I think in the process of messing around with the UVNC admin setup settings I checked something on that was off or vice versa, and ended up installing the mirroring driver.  Thank god I found this post a SECOND time!  Now I'll go find it in the registry and reset everything!  :-)

    -B
    Thursday, September 11, 2008 11:48 AM
  • This fix was partially offered in the Symantec Forum.

    Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\awecho\Video.
    Identify the value for 'Video ID'
    Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Video\**VIDEO ID**\0000\
    Change the value for 'MirrorDriver' from '1' to '0'
    Restart

    T
     

    Tuesday, October 28, 2008 11:02 PM
  • I too have seen this problem with pcanywhere 12.1.  You can install pcanywhere and everything is fine until you connect to the machine for the first time, and then like Steven said, the Aero functionality is gone until you uninstall.  I can confirm that this issue WAS NOT fixed in pcanywhere 12.5 which was disappointing to say the least.  I look forward to trying the above fix on both 12.1 and 12.5 installations to see if this resolves the issue.  I will report back what I find.  I've been really struggling with this issue hoping Symantec would fix this as I really need to be able to access client machines remotely.

    Best,

    Spencer
    Monday, January 5, 2009 7:28 PM