none
Windows 10 - timezone in unattend.xml says its applying but its not (visual proof included) RRS feed

  • Question

  • I have an unattend.xml where in the specialize phase the time zone is set to Eastern Standard Time.  This worked flawlessly in Windows 7, but now that I am trying this command in Windows 10, its not.

    For some reason after sysprep, when the machine is booted, it is shown that the time zone is UTC -06:00 Central Time.  However when I check the log at C:\Windows\Panther\UnattendGC\setupact.log I see at the proper time stamp that the entry to set the system time zone to Eastern Standard Time was run.  So why isn't this working in Windows 10, but it worked fine in Windows 7?

    How can I get this resolved, and can I just sync to the domain time via NTP instead of even worry about this?

    I have:

    <TimeZone>Eastern Standard Time</TimeZone>

    within Microsoft-Windows-Shell-Setup which is in the specialize pass.

    I also have it under Microsoft-Windows-Shell-Setup under the oobeSystem pass.  You'd think one of these would hit, in fact the log says it hits... however the system is an hour behind.

    Friday, October 13, 2017 12:23 PM

All replies

  • Is there any specific reason why you are not using CustomSettings.ini to set your time zone?

    Cheers,
    Anton

    Vacuum Breather Blog | Wing Commander Saga | Twitter

    Note: Posts are provided "AS IS" without warranty of any kind. If posts are helpful please don't forget to rate them as "Helpful" or as "Answer".

    Friday, October 13, 2017 3:01 PM
  • I'm not sure about that process.  I'm just using what I've known for Windows 7 and it works fine, for the most part.  Even the log shows its setting the time zone to EST but for some reason the system is not.

    Now I'm going to try a Powershell set-timezone command as one of my synchronous commands under FirstLogonCommands.

    Where do you put CustomSettings.ini and what is the syntax to tell sysprep to use it?

    Right now we run a sysprep.cmd file which does this:
    cd \windows\system32\sysprep
    sysprep.exe /quiet /generalize /oobe /unattend:c:\sysprep\unattend.xml /shutdown

    There are some scripts in C:\sysprep and the very last firstlogon synchronous command is deleting c:\sysprep from the PC.

    Friday, October 13, 2017 3:08 PM
  • Wait a sec: are you or are you not using MDT for OS deployment :-)

    Cheers,
    Anton

    Vacuum Breather Blog | Wing Commander Saga | Twitter

    Note: Posts are provided "AS IS" without warranty of any kind. If posts are helpful please don't forget to rate them as "Helpful" or as "Answer".

    Friday, October 13, 2017 4:22 PM
  • I have a Windows Server 2012 R2 machine on the domain with windows deployment services role, and I pxeboot to it. Its all free, its not the overpriced SCCM stuff.

    We used it to roll out Windows 7 (back in the XP to 7 conversion).

    Do you know of any good tutorial or walk through sites for using it in this way?

    • Edited by KJSTech1 Friday, October 13, 2017 4:29 PM
    Friday, October 13, 2017 4:28 PM
  • Since you posted on the MDT forum, I assumed you are using Microsoft Deployment Toolkit, hence my suggestion to use CustomSettings.ini. You may want to take a look at MDT - I consider it to be the best deployment solution around and, as an added bonus, it integrates with WDS and SCCM: https://docs.microsoft.com/en-us/windows/deployment/deploy-windows-mdt/get-started-with-the-microsoft-deployment-toolkit

    As far as unattend.xml goes - based on the screenshot above, your unattend.xml seems to be in perfect shape. You may be running into the "Set time zone automatically" feature in Windows 10 - just a thought: https://social.technet.microsoft.com/Forums/en-US/35ff7602-2064-4b57-b8e0-2a99b1827594/windows-10-issues-with-timezone?forum=win10itprosetup


    Cheers,
    Anton

    Vacuum Breather Blog | Wing Commander Saga | Twitter

    Note: Posts are provided "AS IS" without warranty of any kind. If posts are helpful please don't forget to rate them as "Helpful" or as "Answer".

    Saturday, October 14, 2017 9:00 AM