locked
Vista remains disconnected using RPC over HTTP with Exchange 2003 RRS feed

  • Question

  • Problem: My new Vista laptops will not allow connection to the Exchange 2003 standard server using RPC over HTTPS. Everytime it is off-network, it tries to connect then just says disconnected.  An error will occasionally say that the server is not available. 

     

    Setup:

    Exchange Server 2003 SP 2

    Windows 2003 Server SP2

    RPC over HTTP enabled

    This is a single server setup

     

    Outlook is connecting using https and basic password with the certificate installed locally. 

     

    Scenarios that work:

    XP Pro with Outlook 2003

    XP Pro with Outlook 2007

     

    Scenario that does not work:

    Vista Business (on Domain) with Outlook 2007

    Vista Home Premium with Outlook 2007

    Vista Ultimate (on Domain) with 2007

     

    Not tried:

    any Vista with Outlook 2003

     

    Other Notes:

    RPCPing utility on Vista Home Premium gives a response without errors

    Wednesday, September 26, 2007 4:12 PM

Answers

  • There is a KB that I tried previously: http://support.microsoft.com/default.aspx/kb/913843/en-us

     

    Two things

    1. My registry didn't have that key.
    2. I created the key and the value, and it didn't work.

    I thought that this was not the answer.  MSFT rep emailed me this (these are the steps in the above KB):

     

    Please try the following steps on the Vista client:
    1. Click Start, click Run, type regedit in the Open box, and then click OK.  
    2. Locate and then click the following subkey:
      HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\RPC 
    3. On the Edit menu, point to New, and then click DWORD Value. 
    4. Type DefConnectOpts, and then press ENTER.
    5. Right-click DefConnectOpts, and then click Modify. 
    6. In the Value data box, type 0, and then click OK.
    7. Exit Registry Editor.
    8. Please restart the client machine, re-configure the Outlook profile, and try again log on via RPC over HTTP

    Again, my Vista setups did not have the RPC key on the computer.  So, I created the key, created the value and rebooted the computer.  Deleted the old outlook profile, created a new one and tested.  This time it worked.

     

    My Outlook 2007 finally connects to Exchange 2003 with RPC over HTTPS proxy on Vista.

    Sunday, September 30, 2007 2:05 AM

All replies

  • UPDATE: I did install Outlook 2003 on a Vista machine and the connection to Exchange 2003 using RPC over HTTP does work.

     

    So the scenarios that do work are:

    XP Pro with Outlook 2007

    XP Pro with Outlook 2003

    Vista with Outlook 2003

     

    Scenarios that do not work:

    Vista with Outlook 2007

    Friday, September 28, 2007 5:19 PM
  • There is a KB that I tried previously: http://support.microsoft.com/default.aspx/kb/913843/en-us

     

    Two things

    1. My registry didn't have that key.
    2. I created the key and the value, and it didn't work.

    I thought that this was not the answer.  MSFT rep emailed me this (these are the steps in the above KB):

     

    Please try the following steps on the Vista client:
    1. Click Start, click Run, type regedit in the Open box, and then click OK.  
    2. Locate and then click the following subkey:
      HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\RPC 
    3. On the Edit menu, point to New, and then click DWORD Value. 
    4. Type DefConnectOpts, and then press ENTER.
    5. Right-click DefConnectOpts, and then click Modify. 
    6. In the Value data box, type 0, and then click OK.
    7. Exit Registry Editor.
    8. Please restart the client machine, re-configure the Outlook profile, and try again log on via RPC over HTTP

    Again, my Vista setups did not have the RPC key on the computer.  So, I created the key, created the value and rebooted the computer.  Deleted the old outlook profile, created a new one and tested.  This time it worked.

     

    My Outlook 2007 finally connects to Exchange 2003 with RPC over HTTPS proxy on Vista.

    Sunday, September 30, 2007 2:05 AM
  • This registry hack worked for me and now I am able to access my exchange server using RPC over HTTP proxy.  I had been waitig for this fix.  So thanks for sharing this important information. 

    Thursday, October 4, 2007 1:50 PM
  • Just wondering if you are you using Basic Authentication or NTLM authentication?  I was having this exact disconnecting problem only when NTLM authentication is selected.  If I change it to Basic, at which I have to enter in credentials, it connects fine.  I did not perform this registry edit either as I don't want to mess around with deleting the user's outlook profile either.   

    Thursday, October 4, 2007 9:07 PM
  • I tried NTLM and Basic, neither worked originally. I had to do the registry edit and re-create the profile.  To answer your question, I am using basic on my laptop but some of my clients are using NTLM with their domain.  I have the both security and the connection tab in Outlook 2007 set to use NTLM.  All of this is over HTTPS.  I do not have anyone setup as NTLM with just http.

    Thursday, October 4, 2007 9:21 PM
  • Okay.  So here is the weird thing as I'm troubleshooting this issue right now.  I think its a windows profile specific issue because when I log in as myself on this computer and launch outlook (via external connection, with all the correct rpc/http settings), I don't encouter this disconnecting issue and I connect to exchange via NTLM authentication.  While still logged in, I have created another outlook profile with the user that's having issues, and when I launch outlook as him, it connects with no problems?!  So when I log off and then log back in as the user that's having issues and I launch outlook as him, I get the disconnecting issue.  I've created a new Outlook profile for him, and the same thing happens.  Does anyone have this scenario?? 

     

    To clarify, this is a brand new Dell Latitude D820 with Vista Ultimate and Office 2007 installed.  We have D820's with XP Pro SP2 and Office 2003 in our environment and they have no issues with RPC/HTTP. 

    Friday, October 5, 2007 12:49 AM
  • The DefConnectOpts fix has to be made for each user profile on the computer.

     

    You have to create the sub-key for each user, then create their outlook profile.  I have actually created a .reg file with the RPC key that I exported from one profile.  This way I can script it as part of the logon process. 

     

    This is a cumbersome problem.  I am trying to make applying the fix as efficient as possible.  Right now we are applying the fix then adding a new profile.

    Friday, October 5, 2007 4:13 AM
  • It work for me after I changed to Basic Authentication.

     

    Thursday, November 8, 2007 3:01 PM
  • Boy is this frustrating!!!! This is not really a Vista issue rather an Outlook 2007 issue.

     

    I have several XP Pro laptops running Office 2003. They are setup for RPC over HTTP. They work fine on the internal network and external network if they are on the road.

     

    I now have a laptopn running XP Pro and Office 2007. I went through the same procedure and set it up manually for RPC(Anywhere). It works fine on the internal network. When I try it on an external network, it just can't connect/log in.

     

    I get that error:

    "The connection to Microsoft Exchange is unavailable. Outlook must be online or connected to complete this action"

     

    There must be some final solution to this already. I've tried suggestions in the forums to no avail. Isn't there some sort of server/client patch or fix for this? A final solution?

     

    I guess I'll just have to have the employee use the Web email. This stinks

    • Proposed as answer by Myto Saturday, March 27, 2010 12:24 AM
    Thursday, February 21, 2008 7:10 PM
  • There is a KB that I tried previously: http://support.microsoft.com/default.aspx/kb/913843/en-us

     

    Two things

    1. My registry didn't have that key.
    2. I created the key and the value, and it didn't work.

    I thought that this was not the answer.  MSFT rep emailed me this (these are the steps in the above KB):

     

    Please try the following steps on the Vista client:
    1. Click Start, click Run, type regedit in the Open box, and then click OK.  
    2. Locate and then click the following subkey:
      HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\RPC 
    3. On the Edit menu, point to New, and then click DWORD Value. 
    4. Type DefConnectOpts, and then press ENTER.
    5. Right-click DefConnectOpts, and then click Modify. 
    6. In the Value data box, type 0, and then click OK.
    7. Exit Registry Editor.
    8. Please restart the client machine, re-configure the Outlook profile, and try again log on via RPC over HTTP

    Again, my Vista setups did not have the RPC key on the computer.  So, I created the key, created the value and rebooted the computer.  Deleted the old outlook profile, created a new one and tested.  This time it worked.

     

     

     

    My Outlook 2007 finally connects to Exchange 2003 with RPC over HTTPS proxy on Vista.


    This works with Windows Vista on Outlook 2010 when connecting to Exchange 2003 as well. 
    Thursday, June 24, 2010 5:20 AM