locked
CCM Setup Failed to Install Client Agent RRS feed

  • Question

  • Dears,

    Recently I have installed SCCM 2012 R2 SP2, it works fine but when I but when i try to deploy sccm client package manually it will not install properly the package. I went to log file from client machine I found below. Any help will be appreciate.

    <![LOG[==========[ ccmsetup started in process 896 ]==========]LOG]!><time="14:51:59.143-180" date="05-20-2016" component="ccmsetup" context="" type="1" thread="2180" file="ccmsetup.cpp:9601">
    <![LOG[Launch from folder C:\Windows\ccmsetup\]LOG]!><time="14:51:59.143-180" date="05-20-2016" component="ccmsetup" context="" type="1" thread="2180" file="ccmsetup.cpp:680">
    <![LOG[CcmSetup version: 5.0.8239.1403]LOG]!><time="14:51:59.143-180" date="05-20-2016" component="ccmsetup" context="" type="1" thread="2180" file="ccmsetup.cpp:686">
    <![LOG[In ServiceMain]LOG]!><time="14:51:59.143-180" date="05-20-2016" component="ccmsetup" context="" type="0" thread="280" file="ccmsetup.cpp:3492">
    <![LOG[Running on 'Microsoft Windows 7 Enterprise ' (6.1.7601). Service Pack (1.0). SuiteMask = 272. Product Type = 18]LOG]!><time="14:51:59.174-180" date="05-20-2016" component="ccmsetup" context="" type="1" thread="280" file="util.cpp:2000">
    <![LOG[Ccmsetup command line: "C:\Windows\ccmsetup\ccmsetup.exe" /runservice /config:MobileClient.tcf]LOG]!><time="14:51:59.174-180" date="05-20-2016" component="ccmsetup" context="" type="1" thread="280" file="ccmsetup.cpp:3719">
    <![LOG[Command line parameters for ccmsetup have been specified.  No registry lookup for command line parameters is required.]LOG]!><time="14:51:59.174-180" date="05-20-2016" component="ccmsetup" context="" type="1" thread="280" file="ccmsetup.cpp:3924">
    <![LOG[Command line: "C:\Windows\ccmsetup\ccmsetup.exe" /runservice /config:MobileClient.tcf]LOG]!><time="14:51:59.174-180" date="05-20-2016" component="ccmsetup" context="" type="1" thread="280" file="ccmsetup.cpp:3925">
    <![LOG[SslState value: 224]LOG]!><time="14:51:59.174-180" date="05-20-2016" component="ccmsetup" context="" type="0" thread="280" file="ccmsetup.cpp:4572">
    <![LOG[CCMHTTPPORT:    80]LOG]!><time="14:51:59.174-180" date="05-20-2016" component="ccmsetup" context="" type="1" thread="280" file="ccmsetup.cpp:8781">
    <![LOG[CCMHTTPSPORT:    443]LOG]!><time="14:51:59.174-180" date="05-20-2016" component="ccmsetup" context="" type="1" thread="280" file="ccmsetup.cpp:8796">
    <![LOG[CCMHTTPSSTATE:    224]LOG]!><time="14:51:59.174-180" date="05-20-2016" component="ccmsetup" context="" type="1" thread="280" file="ccmsetup.cpp:8814">
    <![LOG[CCMHTTPSCERTNAME:    ]LOG]!><time="14:51:59.174-180" date="05-20-2016" component="ccmsetup" context="" type="1" thread="280" file="ccmsetup.cpp:8832">
    <![LOG[FSP:    ]LOG]!><time="14:51:59.174-180" date="05-20-2016" component="ccmsetup" context="" type="1" thread="280" file="ccmsetup.cpp:8884">
    <![LOG[CCMFIRSTCERT:    1]LOG]!><time="14:51:59.174-180" date="05-20-2016" component="ccmsetup" context="" type="1" thread="280" file="ccmsetup.cpp:8942">
    <![LOG[Config file:      C:\Windows\ccmsetup\MobileClientUnicode.tcf]LOG]!><time="14:51:59.174-180" date="05-20-2016" component="ccmsetup" context="" type="1" thread="280" file="ccmsetup.cpp:4686">
    <![LOG[Retry time:       10 minute(s)]LOG]!><time="14:51:59.174-180" date="05-20-2016" component="ccmsetup" context="" type="1" thread="280" file="ccmsetup.cpp:4687">
    <![LOG[MSI log file:     C:\Windows\ccmsetup\Logs\client.msi.log]LOG]!><time="14:51:59.174-180" date="05-20-2016" component="ccmsetup" context="" type="1" thread="280" file="ccmsetup.cpp:4688">
    <![LOG[MSI properties:    INSTALL="ALL" SMSSITECODE="HQK" CCMHTTPPORT="80" CCMHTTPSPORT="443" CCMHTTPSSTATE="224" CCMFIRSTCERT="1"]LOG]!><time="14:51:59.174-180" date="05-20-2016" component="ccmsetup" context="" type="1" thread="280" file="ccmsetup.cpp:4689">
    <![LOG[Source List:]LOG]!><time="14:51:59.174-180" date="05-20-2016" component="ccmsetup" context="" type="1" thread="280" file="ccmsetup.cpp:4697">
    <![LOG[                  \\XXX.XXX.com\SMSClient]LOG]!><time="14:51:59.174-180" date="05-20-2016" component="ccmsetup" context="" type="1" thread="280" file="ccmsetup.cpp:4704">
    <![LOG[                  \\XXX.XXX.COM\SMSClient]LOG]!><time="14:51:59.174-180" date="05-20-2016" component="ccmsetup" context="" type="1" thread="280" file="ccmsetup.cpp:4713">
    <![LOG[MPs:]LOG]!><time="14:51:59.174-180" date="05-20-2016" component="ccmsetup" context="" type="1" thread="280" file="ccmsetup.cpp:4716">
    <![LOG[                  XXX.XXX.com]LOG]!><time="14:51:59.174-180" date="05-20-2016" component="ccmsetup" context="" type="1" thread="280" file="ccmsetup.cpp:4731">
    <![LOG[No version of the client is currently detected.]LOG]!><time="14:51:59.190-180" date="05-20-2016" component="ccmsetup" context="" type="1" thread="280" file="ccmsetup.cpp:2875">
    <![LOG[Updated security on object C:\Windows\ccmsetup\.]LOG]!><time="14:51:59.736-180" date="05-20-2016" component="ccmsetup" context="" type="0" thread="280" file="ccmsetup.cpp:9445">
    <![LOG[Failed to get client version for sending state messages. Error 0x8004100e]LOG]!><time="14:51:59.752-180" date="05-20-2016" component="ccmsetup" context="" type="2" thread="280" file="state.cpp:178">
    <![LOG[Params to send '5.0.8239.1403 Deployment Error: ']LOG]!><time="14:51:59.752-180" date="05-20-2016" component="ccmsetup" context="" type="0" thread="280" file="state.cpp:215">
    <![LOG[A Fallback Status Point has not been specified and no client was installed.  Message with STATEID='100' will not be sent.]LOG]!><time="14:51:59.752-180" date="05-20-2016" component="ccmsetup" context="" type="1" thread="280" file="state.cpp:229">
    <![LOG[Failed to send status 100. Error (87D00215)]LOG]!><time="14:51:59.752-180" date="05-20-2016" component="ccmsetup" context="" type="3" thread="280" file="state.cpp:242">
    <![LOG[Running as user "SYSTEM"]LOG]!><time="14:51:59.798-180" date="05-20-2016" component="ccmsetup" context="" type="1" thread="280" file="ccmsetup.cpp:2018">
    <![LOG[Detected 35715 MB free disk space on system drive.]LOG]!><time="14:51:59.798-180" date="05-20-2016" component="ccmsetup" context="" type="1" thread="280" file="util.cpp:737">
    <![LOG[Checking Write Filter Status.]LOG]!><time="14:51:59.798-180" date="05-20-2016" component="ccmsetup" context="" type="1" thread="280" file="ccmsetup.cpp:2047">
    <![LOG[This is not a supported write filter device. We are not in a write filter maintenance mode.]LOG]!><time="14:51:59.798-180" date="05-20-2016" component="ccmsetup" context="" type="1" thread="280" file="ccmsetup.cpp:2074">
    <![LOG[Performing AD query: '(&(ObjectCategory=mSSMSManagementPoint)(mSSMSDefaultMP=TRUE)(mSSMSSiteCode=HQK))']LOG]!><time="14:51:59.939-180" date="05-20-2016" component="ccmsetup" context="" type="0" thread="280" file="lsad.cpp:674">
    <![LOG[OperationalXml '<ClientOperationalSettings><Version>5.00.8239.1403</Version><SecurityConfiguration><SecurityModeMask>0</SecurityModeMask><SecurityModeMaskEx>224</SecurityModeMaskEx><HTTPPort>80</HTTPPort><HTTPSPort>443</HTTPSPort><CertificateStoreName></CertificateStoreName><CertificateIssuers></CertificateIssuers><CertificateSelectionCriteria></CertificateSelectionCriteria><CertificateSelectFirstFlag>1</CertificateSelectFirstFlag><SiteSigningCert>308202F4308201DCA003020102021010B99ACC32D1AAA6434680F7B33F32E3300D06092A864886F70D01010B05003016311430120603550403130B53697465205365727665723020170D3136303530373139323634365A180F32313136303431343139323634365A3016311430120603550403130B536974652053657276657230820122300D06092A864886F70D01010105000382010F003082010A0282010100A0A2F8EED602BBFB4A5B9FEE02803ED1A16C8CF19D3E516DED1A8DAF9ECCEAA3D8B2F856A0BA5E90830E814DE11C122A22A4E732320F785685A825B01FAD4F1BE108C1DD463C0537339A581FDFA8B9428167E680137034903508182A58ABE25D3602C9E4488BB74A17461A3A1114C97295E6A73A70947D86FC0C1898C685718F20B577AD3F7375172417E5C52799E90DF1E8CE47386FAC87B53B4D1CDA74832076510410F28A1CE08B5EE3F2255FB6DAE6A151F318A07D8530FF9975A9F77F3960812A9AB7F88C53F9DFC9F6B4A47CF89D1CC45830F58C9117C7B009B187BCAF84A38434101C7A49D6932631698C0CAE32FD166206C205A8394EA8CC0BC3BE530203010001A33C303A30220603551D11041B30198217415233565343434D30312E6B6F72656B74656C2E636F6D30140603551D25040D300B06092B060104018237650B300D06092A864886F70D01010B0500038201010031C28F9B44BC0781B929DF3E8498F61357A7BC394A551BB7D5CE7751A5C4FC9E8DDE7839C3C79133E2BF8B169679D8793E7F7891C5825922140293BC117FC14350CA244584A3DB41253478B3B29AA3839149C1ACFEFB0F974FB58B5A72B3E6DDBB9F55D983E52F0B3D601A012DF9D414EF7432A8D10AF165CC380D7F73A25E9356803CA14B0E44B04CEADA5655181B53F3AEC67B938C4043AD0235DD69D886C71E14D9D35270AA0885CF33ECA2F1C21C26D0D031F7A36D967461D9C93A0E162DF8599BAD623798724CC8CCE955BA08680B58C30871A607E2FF3B893223576EAC01F914606B19495E49DCDEFA28648154168DCD3453DF0880C36D9113FFFE1E5B</SiteSigningCert></SecurityConfiguration><RootSiteCode>HQK</RootSiteCode><CCM> <CommandLine>SMSSITECODE=HQK</CommandLine> </CCM><FSP> <FSPServer></FSPServer> </FSP><Capabilities SchemaVersion ="1.0"><Property Name="SSLState" Value="0" /></Capabilities><Domain Value="XXX.com" /><Forest Value="XXX.com" /></ClientOperationalSettings>']LOG]!><time="14:52:00.235-180" date="05-20-2016" component="ccmsetup" context="" type="0" thread="280" file="lsadcache.cpp:236">
    <![LOG[Unable to open Registry key Software\Microsoft\CCM. Return Code [80070002]. Client HTTPS state is Unknown.]LOG]!><time="14:52:00.235-180" date="05-20-2016" component="ccmsetup" context="" type="1" thread="280" file="ccmutillib.cpp:375">
    <![LOG[The MP name retrieved is 'XXX.XXX.com' with version '8239' and capabilities '<Capabilities SchemaVersion="1.0"><Property Name="SSLState" Value="0"/></Capabilities>']LOG]!><time="14:52:00.235-180" date="05-20-2016" component="ccmsetup" context="" type="1" thread="280" file="lsadcache.cpp:334">
    <![LOG[MP 'XXX.XXX.com' is compatible]LOG]!><time="14:52:00.235-180" date="05-20-2016" component="ccmsetup" context="" type="1" thread="280" file="lsadcache.cpp:339">
    <![LOG[Retrieved 1 MP records from AD for site 'HQK']LOG]!><time="14:52:00.235-180" date="05-20-2016" component="ccmsetup" context="" type="0" thread="280" file="lsadcache.cpp:287">
    <![LOG[Retrived site version '5.00.8239.1403' from AD for site 'HQK']LOG]!><time="14:52:00.235-180" date="05-20-2016" component="ccmsetup" context="" type="1" thread="280" file="siteinfo.cpp:601">
    <![LOG[SiteCode:         HQK]LOG]!><time="14:52:00.235-180" date="05-20-2016" component="ccmsetup" context="" type="1" thread="280" file="ccmsetup.cpp:2099">
    <![LOG[SiteVersion:      5.00.8239.1403]LOG]!><time="14:52:00.235-180" date="05-20-2016" component="ccmsetup" context="" type="1" thread="280" file="ccmsetup.cpp:2100">
    <![LOG[Only one MP XXX.XXX.com is specified. Use it.]LOG]!><time="14:52:00.235-180" date="05-20-2016" component="ccmsetup" context="" type="1" thread="280" file="ccmsetup.cpp:10043">
    <![LOG[Searching for DP locations from MP(s)...]LOG]!><time="14:52:00.235-180" date="05-20-2016" component="ccmsetup" context="" type="1" thread="280" file="ccmsetup.cpp:10957">
    <![LOG[Current AD site of machine is Korek-Site]LOG]!><time="14:52:00.235-180" date="05-20-2016" component="LocationServices" context="" type="1" thread="280" file="lsad.cpp:788">
    <![LOG[Local Machine is joined to an AD domain]LOG]!><time="14:52:00.235-180" date="05-20-2016" component="LocationServices" context="" type="0" thread="280" file="lsad.cpp:732">
    <![LOG[Current AD forest name is XXX.com, domain name is XXX.com]LOG]!><time="14:52:00.344-180" date="05-20-2016" component="LocationServices" context="" type="1" thread="280" file="lsad.cpp:860">
    <![LOG[DhcpGetOriginalSubnetMask entry point is supported.]LOG]!><time="14:52:00.344-180" date="05-20-2016" component="LocationServices" context="" type="0" thread="280" file="ccmiputil.cpp:117">
    <![LOG[Begin checking Alternate Network Configuration]LOG]!><time="14:52:00.344-180" date="05-20-2016" component="LocationServices" context="" type="0" thread="280" file="ccmiputil.cpp:1095">
    <![LOG[Finished checking Alternate Network Configuration]LOG]!><time="14:52:00.344-180" date="05-20-2016" component="LocationServices" context="" type="0" thread="280" file="ccmiputil.cpp:1172">
    <![LOG[Sending message body '<ContentLocationRequest SchemaVersion="1.00">
      <AssignedSite SiteCode="HQK"/>
      <ClientPackage/>
      <ClientLocationInfo LocationType="SMSPACKAGE" DistributeOnDemand="0" UseProtected="0" AllowCaching="0" BranchDPFlags="0" AllowHTTP="1" AllowSMB="0" AllowMulticast="0" UseInternetDP="0">
        <ADSite Name="XXX-Site"/>
        <Forest Name="XXX.com"/>
        <Domain Name="XXX.com"/>
        <IPAddresses>
    <IPAddress SubnetAddress="10.10.18.0" Address="10.10.18.208"/>
        </IPAddresses>
      </ClientLocationInfo>
    </ContentLocationRequest>
    ']LOG]!><time="14:52:00.344-180" date="05-20-2016" component="ccmsetup" context="" type="0" thread="280" file="siteinfo.cpp:96">
    <![LOG[Sending message header '<Msg SchemaVersion="1.1"><ID>{3EDCC82A-3C04-4416-B235-7256B2DB787C}</ID><SourceID></SourceID><SourceHost>SCCM-2012R2-PC</SourceHost><TargetAddress>mp:[http]MP_LocationManager</TargetAddress><ReplyTo>direct:SCCM-2012R2-PC:LS_ReplyLocations</ReplyTo><Priority>3</Priority><Timeout>600</Timeout><ReqVersion>5931</ReqVersion><TargetHost>XXX.XXX.com</TargetHost><TargetEndpoint>MP_LocationManager</TargetEndpoint><ReplyMode>Sync</ReplyMode><Protocol>http</Protocol><SentTime>2016-05-20T11:52:00Z</SentTime><Body Type="ByteRange" Offset="0" Length="1098"/><Hooks><Hook3 Name="zlib-compress"/></Hooks><Payload Type="inline"/></Msg>']LOG]!><time="14:52:00.344-180" date="05-20-2016" component="ccmsetup" context="" type="0" thread="280" file="siteinfo.cpp:185">
    <![LOG[CCM_POST 'HTTP://XXX.XXX.com/ccm_system/request']LOG]!><time="14:52:00.344-180" date="05-20-2016" component="ccmsetup" context="" type="1" thread="280" file="httphelper.cpp:806">
    <![LOG[Failed to receive ccm message response. Status code = 404]LOG]!><time="14:52:00.344-180" date="05-20-2016" component="ccmsetup" context="" type="2" thread="280" file="httphelper.cpp:1692">
    <![LOG[GetDPLocations failed with error 0x80004005]LOG]!><time="14:52:00.344-180" date="05-20-2016" component="ccmsetup" context="" type="3" thread="280" file="siteinfo.cpp:558">
    <![LOG[Failed to get DP locations as the expected version from MP 'XXX.XXX.com'. Error 0x80004005]LOG]!><time="14:52:00.344-180" date="05-20-2016" component="ccmsetup" context="" type="2" thread="280" file="ccmsetup.cpp:11205">
    <![LOG[Failed to get client version for sending state messages. Error 0x8004100e]LOG]!><time="14:52:00.344-180" date="05-20-2016" component="ccmsetup" context="" type="2" thread="280" file="state.cpp:178">
    <![LOG[Params to send '5.0.8239.1403 Deployment Error: ']LOG]!><time="14:52:00.344-180" date="05-20-2016" component="ccmsetup" context="" type="0" thread="280" file="state.cpp:215">
    <![LOG[A Fallback Status Point has not been specified and no client was installed.  Message with STATEID='101' will not be sent.]LOG]!><time="14:52:00.344-180" date="05-20-2016" component="ccmsetup" context="" type="1" thread="280" file="state.cpp:229">
    <![LOG[Failed to send status 101. Error (87D00215)]LOG]!><time="14:52:00.344-180" date="05-20-2016" component="ccmsetup" context="" type="3" thread="280" file="state.cpp:242">
    <![LOG[Next retry in 10 minute(s)...]LOG]!><time="14:52:00.344-180" date="05-20-2016" component="ccmsetup" context="" type="0" thread="280" file="ccmsetup.cpp:8999">

    Friday, May 20, 2016 12:09 PM

Answers

  • As I noted above, 404 means "Not found". This is not an IIS issue, it simply means that IIS can't find what the URL being used is pointing to. IIS can't magically provide something that it doesn't have. The MP is responsible for populating the content thus your issue is with the MP.

    How can you give what admin permissions in IIS?

    To troubleshoot a 1603 MSI error, you need to search for the phrase "return value 3". The line with this phrase on it marks the end of the section in the log where the actual error occurred and you need to read up from there to find the issue occurring.


    Jason | http://blog.configmgrftw.com | @jasonsandys

    Sunday, May 22, 2016 7:00 PM

All replies

  • Have you validated the health of your MP? Based upon the above log, the content location request sent to the MP is returning an http 404 error (which means not found).

    Jason | http://blog.configmgrftw.com | @jasonsandys

    Friday, May 20, 2016 12:30 PM
  • Dear Jason I'm a little bit new in SCCM, kindly can explain how can validated the health of my MP?
    Friday, May 20, 2016 12:42 PM
  • In the console in the Monitoring workspace, there is a node called System Status with two sub-nodes: Site Status and Component Status. This is the place to start.

    Jason | http://blog.configmgrftw.com | @jasonsandys

    Saturday, May 21, 2016 2:31 AM
  • Dear Jason,

    First: During my checking in client log file, it seems we I have issue with 404 it means IIS issue, how can I check IIS log file and give administrator permission to IIS?

    Second: I removed management point then installed again, but when I checked mpMSI.log file it showed me below error

    MSI (s) (B0:70) [08:13:42:329]: Product: ConfigMgr Management Point -- Installation operation failed.
    MSI (s) (B0:70) [08:13:42:329]: Windows Installer installed the product. Product Name: ConfigMgr Management Point. Product Version: 5.00.8239.1403. Product Language: 1033. Manufacturer: Microsoft Corporation. Installation success or error status: 1603.

    • Edited by Dana.Kadi Sunday, May 22, 2016 5:19 AM
    Sunday, May 22, 2016 5:14 AM
  • As I noted above, 404 means "Not found". This is not an IIS issue, it simply means that IIS can't find what the URL being used is pointing to. IIS can't magically provide something that it doesn't have. The MP is responsible for populating the content thus your issue is with the MP.

    How can you give what admin permissions in IIS?

    To troubleshoot a 1603 MSI error, you need to search for the phrase "return value 3". The line with this phrase on it marks the end of the section in the log where the actual error occurred and you need to read up from there to find the issue occurring.


    Jason | http://blog.configmgrftw.com | @jasonsandys

    Sunday, May 22, 2016 7:00 PM
  • Dear Sir,

        Please check if the prerequisites stated in this blog have been installed before you install the MP role:

        https://www.systemcenterdudes.com/sccm-2012-r2-management-point-installation/

        Also examine the MPSetup.log on your site server.

    Best regards,

    Jimmy

       


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, May 24, 2016 9:48 AM