none
Drives mapped via GPO, NET USE shows mapping but doesn't show up in Explorer - Win 8.1 RRS feed

  • Question

  • Fresh install of Windows Enterprise 8.1

    Connected PC to domain, logged in, drive mapping worked as it should.

    Rebooted a few times after installing software that I normally install on my computers (from the same sources/locally from my file server, etc).  Rebooted a few more times all is well.

    A few reboots later, the only drive that is mapped is X: which is my user drive done via the user profile in AD.  The rest of the mappings that normally show up done by the GPO no longer show up.

    After some digging, and noticing no errors in any logs I ran NET USE in a CMD prompt window, low and behold the drives are actually mapped and I can access them via the CLI without issue.  I can navigate via their mapped drive letters, etc.

    They just don't show up in Windows Explorer at all and I cannot navigate to the drive letters via the address bar.  Strangely enough, it still kinda works since the Downloads start menu item is mapped to a network drive and that still works (Q:\) and Chrome can access it as well if I try to download something.

    I'm really not sure what else to check/try here. 

    Have other Windows 7 and Windows 8.1 machines (my laptop) and all works just fine, so it's only this specific install on my desktop that is showing this issue.

    Wednesday, March 5, 2014 8:08 PM

All replies

  • Hi,

    There are several reasons causing the issue:

    First, The problematic client doesn't reconnect to the target share at logon. 

    Please follow the steps to re-configure the mapped driver on the client and then check if the issue will re-occur.

    Steps:

    a. Open "My Computer"

    b. Click on "Tools" and then select "Map Network Driver"

    c. input the \\ipaddressofserver\sharename to give the path of the share

    d. Check "Reconnect at logon"

    e. Drive gets mapped

    f. Double click on the drive to check.

    Second, Antivirus software or Windows Firewall may block the mapped share.

    If there is any Antivirus software and the Windows Firewall is enabled on the problematic client. If so, please disable them to check if the issue can be resolved.

    Third, Fast Logon Optimization is enabled on the clients.

    The fast logon feature may affect the display and drive letter assignment of a mapped network drive. As a result, the drive may have been mapped; however, the user on client cannot see it in Windows Explorer. He may recognize it as a failed network drive mapping. This is the reason why we usually suggest you to disable fast logon on the clients via a GPO, and please check if the mapped network drive will be occur under this circumstance.

    Please also configure the following group policy setting to disable Fast Logon Optimization to see if the issue still exists on the problematic clients.

    Computer Configuration\Administrative Templates\System\Logon\Always wait for the network at computer startup and logon

    If we cannot get this issue fixed, please post back the event log related to this issue.


    Kate Li
    TechNet Community Support

    Thursday, March 6, 2014 9:49 AM
    Owner
  • Thanks for your reply,

    The first point doesn't apply to me as I am pushing the mapped drive via a GPO from the DC.

    Second point is also a non issue as the only AV/Firewall there is on the client is Windows Firewall & Defender, both of which are disabled.

    3rd point would be a possibility I suppose but doesn't make sense as no other PC has not issue with Fast Login Optimizations, but I can test the theory anyway on the effected PC.


    Thursday, March 6, 2014 6:02 PM
  • I decided to wipe the computer, and reinstall (this time with 8.1 Pro N).

    Installing went great, installed only Video drivers (Nvidia), then connected to the DC.  After that I logged into the PC with the domain user as usual, and all the drives appeared as normal (mapped via the existing GPO).

    I then manually disconnected my user profile mapping (X:) and logged off, after logging off and logging back in I now have the exact same issue as before.  None of the drives mapped by the GPO are showing up in Explorer.  Only the X: drive which is mapped in the user Account from the DC is mapped.

    But as usual if I check with NET USE under the CLI it shows that all the drives are mapped and I can access them normally under the CLI.

    Here is a screenshot:

    h t t p://i.imgur.com/IzaO9WV.jpg

    Friday, March 7, 2014 2:00 AM
  • Hi,

    Please check if there are the mapped option under this registry key:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\MountPoints2

    The mapped drive just like below:

    If not, please try to manually add such keys to see what's going on.

    Also, This issue can be user profile related, please check the GPP scope in your AD whether it applies to all domain accounts.


    Kate Li
    TechNet Community Support


    Wednesday, March 19, 2014 7:03 AM
    Owner
  • Yes they are present in the registry location you specified (just as they are when you run NET USE), here is a screenshot:

    h t t p://i.imgur.com/NSeEreX.jpg

    The issue is not user profile related as I've said before this GPO is working on many Windows 7 PC's along with my Windows 8.1 x64 laptop (Lenovo) so I"m not sure why it's not working on this install (or even previous install).

    Today I had a strange occurrence that the drives "magically" appeared in My PC correctly, but again after a log off and back on again, only the X drive is visible/accessible via explorer/My PC.


    Thursday, March 20, 2014 10:34 PM
  • Hi, did you try turning off UAC?

    Also, check this Reg Key for Enabled Linked Connections:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System]
    “EnableLinkedConnections”=dword:00000001

    Thursday, March 20, 2014 10:44 PM
  • If by turning off UAC = sliding the slider to the bottom, then yes :)

    I'll try that reg link later today though.  

    Thanks!

    Friday, March 21, 2014 11:43 AM
  • I have the same problem

    Fast logon is enable too.


    One more thing. If, in CLI, i launch "explorer ." I can see all drives, and navigate through. If I close it and launch explorer in Windows, I don't see the drive and can't access them.

    Tuesday, May 27, 2014 9:15 PM
  • I was having a similar issue, although not via GPO. I use a batch file for "final configuration" that does various things, one being to map 2 network drives. 

    I would right click the batch file>run as administrator, and it would do all the things I needed it to do, including mapping those 2 drives. The problem was that they were nowhere to be seen in Explorer. NET USE showed the two drives mapped with their appropriate letter. For kicks I ran the batch file again, but this time NOT as administrator and lo and behold there they were! I was able to replicate this several times. 

    I know you're using GPO, but the problems seem related.

    Tuesday, June 17, 2014 1:20 PM
  • The issue comes from the GPO as I have experienced this as well. I know this is old, but will help someone in the future: REGKEY: HEKY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer there is a key that ends up here. You will probably see a key "NoDrives" with value of "0x03FFFFFF". Change this to "0". Here is related link for that key in particular. 

    https://technet.microsoft.com/en-us/library/cc938267.aspx


    Friday, October 2, 2015 6:37 PM
  • I was having a similar issue, although not via GPO. I use a batch file for "final configuration" that does various things, one being to map 2 network drives. 

    I would right click the batch file>run as administrator, and it would do all the things I needed it to do, including mapping those 2 drives. The problem was that they were nowhere to be seen in Explorer. NET USE showed the two drives mapped with their appropriate letter. For kicks I ran the batch file again, but this time NOT as administrator and lo and behold there they were! I was able to replicate this several times. 

    I know you're using GPO, but the problems seem related.

    This was my issue anyway.  Thanks!
    Wednesday, October 14, 2015 4:57 PM