locked
Header numbering turns into a black box RRS feed

  • Question

  • Using office 2016, One of my document started blacking out heading 2 numbering. 

    This is an old issue, found people talking about this bug 5 years ago - how come there is no fix ? 

    How can I get rid of the black boxes forever (the fix that is offered by SO is works until you close the document and re-open it)

    supreuser.com question


    Sunday, June 26, 2016 7:24 PM

Answers

All replies

  • Hi,

    Does this issue happen to all documents or just a certain one?

    I'd recommend you fix the issue using the method you found and then try renaming the Normal.dotm to Normal.old. Start Word to create a new Normal.dotm file and then check if this issue continues. By default, the Normal.dotm file is stored in the following location:

    C:\Users\%username%\AppData\Roaming\Microsoft\Templates

    Note: all your custom formatting and styles will lost if you delete the Normal.dotm template file.

    Please let me know the result.

    Regards,

    Steve Fan
    TechNet Community Support


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com.
    Monday, June 27, 2016 6:21 AM
  • Try running the following macro, created by MVP Doug Robbins:

    Sub FixNumberingLevels()
     'Macro created by MVP Doug Robbins
     For Each templ In ActiveDocument.ListTemplates
         For Each lev In templ.ListLevels
             lev.Font.Reset
         Next lev
     Next templ
    End Sub

           

    See http://www.gmayor.com/installing_macro.htm.


    Stefan Blom, Microsoft Word MVP

    Monday, June 27, 2016 7:17 PM
  • I want to try this solution, but it looks like my office is missing macro langauge support. 

    Any idea how to install it ? (it was installed automatically by office 365)

    Tuesday, June 28, 2016 5:41 AM
  • currently it's the only document with this problem. 

    Tuesday, June 28, 2016 5:42 AM
  • If you are running Office 2016 for PC macro support should be installed by default (I don't know about MacWord). Why do you think it is missing? If you click File | Options | Customize Ribbon, are you allowed to display the Developer tab by clicking next to "Developer" in the list of ribbon tabs on the right?

    If macro support is nowhere to be found, repair Office; see https://support.office.com/en-us/article/Repair-an-Office-application-7821d4b6-7c1d-4205-aa0e-a6b40c5bb88b?ui=en-US&rs=en-US&ad=US&fromAR=1.


    Stefan Blom, Microsoft Word MVP

    • Proposed as answer by Steve Fan Wednesday, July 6, 2016 9:13 AM
    • Marked as answer by Steve Fan Monday, July 11, 2016 2:48 AM
    Tuesday, June 28, 2016 11:15 AM
  • will try to repair. the developer is there but it doesn't allow me to run macros.

    Wednesday, July 6, 2016 9:26 AM